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Warranty

Tektronix warrants that this product will be free from defects in materials and workmanship for a period of one (1)
year from the date of shipment. If any such product proves defective during this warranty period, Tektronix, at its
option, either will repair the defective product without charge for parts and labor, or will provide a replacement
in exchange for the defective product. Parts, modules and replacement products used by Tektronix for warranty
work may be new or reconditioned to like new performance. All replaced parts, modules and products become
the property of Tektronix.

In order to obtain service under this warranty, Customer must notify Tektronix of the defect before the expiration of
the warranty period and make suitable arrangements for the performance of service. Customer shall be responsible
for packaging and shipping the defective product to the service center designated by Tektronix, with shipping
charges prepaid. Tektronix shall pay for the return of the product to Customer if the shipment is to a location within
the country in which the Tektronix service center is located. Customer shall be responsible for paying all shipping
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resulting from attempts by personnel other than Tektronix representatives to install, repair or service the product;
b) to repair damage resulting from improper use or connection to incompatible equipment; c) to repair any damage
or malfunction caused by the use of non-Tektronix supplies; or d) to service a product that has been modified or
integrated with other products when the effect of such modification or integration increases the time or difficulty
of servicing the product.

THIS WARRANTY IS GIVEN BY TEKTRONIX WITH RESPECT TO THE PRODUCT IN LIEU OF ANY
OTHER WARRANTIES, EXPRESS OR IMPLIED. TEKTRONIX AND ITS VENDORS DISCLAIM ANY
IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE.
TEKTRONIX’ RESPONSIBILITY TO REPAIR OR REPLACE DEFECTIVE PRODUCTS IS THE SOLE
AND EXCLUSIVE REMEDY PROVIDED TO THE CUSTOMER FOR BREACH OF THIS WARRANTY.
TEKTRONIX AND ITS VENDORS WILL NOT BE LIABLE FOR ANY INDIRECT, SPECIAL, INCIDENTAL,
OR CONSEQUENTIAL DAMAGES IRRESPECTIVE OF WHETHER TEKTRONIX OR THE VENDOR HAS
ADVANCE NOTICE OF THE POSSIBILITY OF SUCH DAMAGES.
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General Safety Summary

General Safety Summary
Review the following safety precautions to avoid injury and prevent damage to
this product or any products connected to it.

To avoid potential hazards, use this product only as specified.

Only qualified personnel should perform service procedures.

While using this product, you may need to access other parts of a larger system.
Read the safety sections of the other component manuals for warnings and
cautions related to operating the system.

To Avoid Fire or Personal
Injury

Use Proper Power Cord. Use only the power cord specified for this product and
certified for the country of use.

Connect and Disconnect Properly. Do not connect or disconnect probes or test
leads while they are connected to a voltage source.

Ground the Product. This product is grounded through the grounding conductor
of the power cord. To avoid electric shock, the grounding conductor must be
connected to earth ground. Before making connections to the input or output
terminals of the product, ensure that the product is properly grounded.

Observe All Terminal Ratings. To avoid fire or shock hazard, observe all ratings
and markings on the product. Consult the product manual for further ratings
information before making connections to the product.

Do not apply a potential to any terminal, including the common terminal, that
exceeds the maximum rating of that terminal.

Power Disconnect. The power cord disconnects the product from the power source.
Do not block the power cord; it must remain accessible to the user at all times.

Do Not Operate Without Covers. Do not operate this product with covers or panels
removed.

Do Not Operate With Suspected Failures. If you suspect that there is damage to this
product, have it inspected by qualified service personnel.

Avoid Exposed Circuitry. Do not touch exposed connections and components
when power is present.

Use Proper Fuse. Use only the fuse type and rating specified for this product.

Wear Eye Protection. Wear eye protection if exposure to high-intensity rays or
laser radiation exists.
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Do Not Operate in Wet/Damp Conditions.

Do Not Operate in an Explosive Atmosphere.

Keep Product Surfaces Clean and Dry.

Provide Proper Ventilation. Refer to the manual’s installation instructions for
details on installing the product so it has proper ventilation.

Terms in this Manual These terms may appear in this manual:

WARNING. Warning statements identify conditions or practices that could result
in injury or loss of life.

CAUTION. Caution statements identify conditions or practices that could result in
damage to this product or other property.

Symbols and Terms on the
Product

These terms may appear on the product:

DANGER indicates an injury hazard immediately accessible as you read
the marking.

WARNING indicates an injury hazard not immediately accessible as you
read the marking.

CAUTION indicates a hazard to property including the product.

The following symbol(s) may appear on the product:
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Preface

Preface
The MTS400 Series MPEG systems are described in three user manuals. The
applications are available on the following MTS400 Series products:

MTS415

MTS430

MTS400P

MTX100B (where installed)

Table i: Overview of the applications
Application Desktop icon
MTS400 Series analyzer application
Transport Stream Compliance Analyzer (TSCA) - Real-time transport stream analysis with user-selectable
MPEG-2, DVB, ATSC and ISDB conformance tests. Shows transport structure, header contents,
hexadecimal packet contents, PCR timing/transport rate graphs, and error message logs.

Transport Stream Compliance Analyzer (TSCA) - Deferred transport stream analysis with user-selectable
MPEG-2, DVB, ATSC and ISDB conformance tests. Shows transport structure, header contents,
hexadecimal packet contents, PCR timing/transport rate graphs, and error message logs.

Packetized Elementary Stream (PES) Analyzer - PES analysis with selectable test options. Shows PES
program structure, header contents, packet contents, PTS/DTS timing graphs, and analysis reports.

Transport Stream - System Target Decoder (T-STD) - Buffer Analyzer analyzes program streams modeling
their behavior in, and their conformance to, the MPEG-2 T STD Buffer Model.

Elementary Stream Analyzer - Elementary Stream analysis at video picture and audio level. This includes
vector graphs and macroblock picture quality.

‘

Carousel Analyzer - Data analysis showing structure, bit rate, repetition rate, syntax and semantics of
data items.
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Table i: Overview of the applications (cont.)

Application Desktop icon
MTS400 Series generators application
Multiplexer - Multiplexes table information and packetized elementary streams together to synthesize new
transport streams. A fine level of control is provided to allow nonconformances and test cases to be
specified for new transport streams.

TS Editor - Viewing and editing transport stream packets, using a hexadecimal view of the packet contents
and semantic interpretation of the header. Provides facilities to remap PIDs, recalculate PCR values and
introduce PCR inaccuracies.

MPEG Player- Records and plays MPEG-2 streams. (The MTX100B/RTX100B/RTX130B players are
described in: MTX100B Quick Start User Manual, Tektronix part number 071-2593-xx and RTX100B Quick
Start User Manual, Tektronix part number 071-2595-xx)
Make Seamless Wizard - Guides the user through the process of creating an MPEG-2 file for use by
Stream Player in continuously looped operation.

TS Cutter - Extracts sections of MPEG-2 files to new files.

Script Pad - Enables users to create and modify System Information (SI) scripts.

TTS Utility - Converts time stamped transport streams to standard transport stream format.
MTS400 Series carousel applications
Carousel Generator - Provides in-depth off-line generation of MPEG-2, DVB transport streams containing
a range of data broadcast protocols.

Carousel Analyzer Data analysis showing structure, bit rate, repetition rate, syntax and semantics of
data items.

x MTS400 Series Generator Applications User Manual



Preface

Documentation
The following related documentation for the instrument is available:

Item Purpose Location
MTS400 Series Quick Start User Manual
(071-2607-xx English, 071-2608-xx
Japanese)

Describes how to install and get
started using the test systems.

MTS400 Series Analyzer Applications User
Manual (077-0205-xx)

Describes the operation of the
following analyzer applications:
TSCA, PES Analyzer, T-STD Buffer
Analyzer, and ES Analyzer.

MTS400 Series Generator Applications
User Manual (077-0204-xx)

Describes the operation of the
following generator applications:
Multiplexer, MPEG Player, TS
Editor, Make Seamless Wizard,
Transport Stream Cutter, and Script
Pad.

MTS400 Series Carousel Applications User
Manual (077-0203-xx)

Optional manual supporting
module-level servicing of the
instrument.

MTS400 Series Release Notes
(077-0200-xx)

Describes known issues with the
test systems.

MTS400 Series Programmer Manual
(077-0206-xx)

Describes the operation of the
MTS4EA application software.

MTS4EA Compressed Video Elementary
Stream Analyzer User Manual
(071-1641-xx)

Describes the operation of the
MTS4EA application software.

MTS4CC Elementary Stream Compliance
Checker User Manual (071-2075-xx)

Describes the operation of the
MTS4CC application software.
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Multiplexer - Getting Started
The Tektronix Multiplexer provides off-line multiplexing of ATSC, MPEG-2,
DVB, and ISDB transport streams.

Transport streams (TS), Elementary Streams (ES), Packetized Elementary Streams
(PES), and Packet Identifiers (PID) can be selected, manipulated and recombined
to form customized, synthesized transport streams. Program Specific Information
(PSI), Service Information (SI), and Program and System Information Protocol
(PSIP) are often referred to as simply SI in this section.

The functions provided include:

Wizards for common tasks, such as populating streams with Program Specific
Information/Service Information/Program and System Information Protocol
(PSI/SI/PSIP), and programs.

Table contents that are displayed in and edited from structure diagrams (tree
diagrams).
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Transport Streams that either conform strictly to the standards selected for
interpretation or have precisely engineered, known, nonconformances.

Two or more instances of Multiplexer can run concurrently. This allows table
information to be copied from one file to another.

The source data for nonconformant streams can be saved in a raw format,
which can be quickly reloaded as the basis for generating more stream data.

Conformance of edits to the standards is checked interactively and enforced
by default. Checking and enforcement may be turned off when specifying
nonconformances to be introduced into the new transport stream.

On opening, streams are analyzed and displayed according to the selected
standard: MPEG, DVB, ATSC, or ISDB. Scripts are used by the analysis process;
this allows private PSI/SI tables and descriptors to be defined.

NOTE. Most examples given in this section of the manual are based on DVB SI.
You should remember that the Multiplexer is equally at home with all major DTV
standards, MPEG-2, DVB, ATSC, and ISDB as well as the major extensions to
those standards.

The Transport Stream Analyzer program should always be used for reliable
analysis of transport streams containing DSM-CC or MPE addressable sections.

In the absence of TS Analyzer, it is acceptable to use Multiplexer for analysis,
provided that the DSM-CC or MPE scripts are first applied using Expert mode in
the Stream Interpretation dialog box (See page 1-6, Scripts.).

However, when multiplexing streams containing DSM-CC or MPE addressable
sections, the related scripts must not be active.

Multiplexer in Playout
Mode

You can initiate a playout in the Multiplexer application using the playout feature
as soon as the multiplex operation is complete. Multiplexer creates a temporary
transport stream in the location specified by the Playout Settings and then initiates
a playout by loading this file into the player. To play the stream in the loop mode,
enable the loop mode in the Playout settings.

To open Playout Settings dialog box, selectMultiplex >Playout settings.
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H.264 ES Input Characteristics
H.264 elementary streams received by the Multiplexer should comply with
ISO/IEC-14496-10/2005 Rec. H.264. Transport streams generated by the
Multiplexer should comply with ISO/IEC-13818-1/2000/AMD_3/2004.

PTS/DTS Timestamp
Generation

The generated transport stream will contain DTS and PTS values calculated
at a constant frame and bit rate. A default frame rate of 25 fps will be used,
unless otherwise specified by the user or derived from the optional VUI
(Video Usability Information) parameters within the stream.

You can specify the constant bit rate or it may be detected automatically by
scanning the transport stream. The scanned bit rate is calculated as follows:

If the transport stream contains the optional HRD (Hypothetical Reference
Decoder) parameters, then the contained maximum bit rate value is displayed
to the user as a guide.

If the transport stream contains optional HRD parameters together with SEI
(Supplemental Enhancement Information) Buffering Period and Picture
Timing messages then the PTS and DTS values will be derived from them.
That is, the PTS/DTS values will always be consistent with any ES layer
parameters.
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Starting the Program
The program can be started by selecting the Tektronix Multiplexer option from
the Start > Programs menu or by double-clicking on the Tektronix Multiplexer
shortcut on the desktop.

Initial Appearance Once the program has started and is ready for use, it will open a Main Window
that looks like the following figure:

Use the View menu to select a standard that will be used to interpret transport
streams, and then open a transport stream file or import a multiplex configuration
file.

Initial Menu Options When the application is opened, you are presented with options relevant only
to opening new or existing multiplex files. Options that are not relevant at this
time are inactive (grayed out).

File Menu Options. The following table lists the options available in the initial
File menu.
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Table 1-1: File menu options
Command Function
New Opens new multiplex configuration file.
Open Opens an MPEG file for use. The program

opens the file selection dialog box allowing
you to choose the required file.

Examine TS Opens the Examine TS window, which allows
a brief summary of the stream to be viewed
before it is subjected to full analysis.

Close Currently disabled
Import... Opens a previously saved multiplex

configuration file.
Export Currently disabled
Export As Currently disabled
1 <filename>
2 <filename>
3 <filename>
4 <filename>

A list of the four most recently used files. If
the program has recently been installed the
list may be empty or hold less than four files.
Selecting a file name opens that file for use.

Exit Finishes running the program.

View Menu Options. The following table lists the options available in the initial
View menu.

Table 1-2: View menu options
Command Function
Interpretation Opens the Stream Interpretation dialog box.

This allows the scripts to be used in stream
analysis to be selected.

Event Log Opens the Event Log window.
Toolbar Displays or hides the Toolbar.
Status Bar Shows or hides the Status Bar.

A check mark next to an option indicates that the object is currently visible.

Scripts
SI scripts are necessary to enable SI table and descriptor data to be analyzed
successfully. Scripts are used to enable analysis of SI data dictated by the various
international standards, for example, MPEG-2, DVB, ATSC, and ISDB.

Essential scripts are installed and enabled using the Stream Interpretation dialog
box. In the absence of any enabled scripts, only the PAT table will be analyzed; all
other data will be presented as private data.
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If a suitably configured script is selected and enabled before a stream is opened,
custom data will be analyzed when the stream is opened. If the script is not
selected or enabled, the stream will be analyzed, but any custom data will be
reported as either an error in the stream configuration or as an elementary stream
PID.

Scripts can be selected and enabled only when no files are open. The Stream
Interpretation dialog box is available when a file is open, but all activity is
disabled.

Note that a script file will not be used for analysis until:

It is present in the Scripts text box in the current analysis mode.

It is successfully enabled by closing the Stream Interpretation dialog box
using the OK button.

Handling Scripts

To open the Stream Interpretation dialog box, with all files closed, select View >
Interpretation. The Stream Interpretation dialog box is displayed as shown.
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The top half of the dialog box is concerned with selecting scripts. The Scripts
text box lists the scripts currently selected. The area adjacent to the text box
is dedicated to Expert mode controls.

Selecting Scripts The selection area of the Stream Interpretation dialog box is best viewed and
used from left to right.

In the Base Standard section, select the MPEG-2, DVB, ATSC, or ISDB standard
for analysis.

The selected standard dictates the availability of the remaining options in the
Regions and Data Standards sections.

In the Regions section, select the country-specific region to be added to the basic
standard scripts. If you select None, only the standard scripts are listed in the
Scripts text box. The remaining country-specific extensions add extra scripts to
the current listing. The choice of Regions option dictates the availability of the
options in the Data Standards section.

Base Standard Description Region
MPEG-2 only Interprets and analyzes

the packets in
conformance to the
MPEG-2 standards.

None
Custom

DVB Interprets and analyzes
the Transport Stream
Packets according to
the specifications of
the DVB and MPEG-2
standards.

None
Custom
UK DTG
Australian
Nordig
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Base Standard Description Region
ATSC Interprets and analyzes

the Transport Stream
Packets according to
the specifications of
the ATSC and MPEG-2
standards.

None
Custom

ISDB Interprets and analyzes
the Transport Stream
Packets according to
the specifications of
the ISDB and MPEG-2
standards.

ISDB-T
ISDB-S
ISDB-T (One segment
ISDB-B (Brazil)
ISDB-TB (One segment Brazil)

The Data Standards section offers a choice of data-specific scripts.

NOTE. The scripts listed by default reside in the default installation directory
(tektronix\scripts). Other directory locations can be specified in Expert Mode. All
selections will be retained between sessions.

Checking Syntax Scripts are syntactically analyzed when the OK button is selected. They are also
checked when the application is opened. A fault in the syntax of a script will not
necessarily prevent a stream from being analyzed, but it may result in incomplete
analysis of the stream.

Scripts listed in the Scripts text box will not be used for stream analysis until they
have been successfully checked (the application has been opened or the Stream
Interpretation dialog box has been closed with no script-related error messages
issued).

For an intermediate check of scripts listed in the Scripts text box, select the
Reload Scripts button. This performs the same action as the OK button but
leaves the dialog box open.

Syntax errors will be indicated and reported in the Event Log (See page 1-59.).

Expert Mode
Expert Mode allows you to select and customize the scripts to be used in

stream analysis and multiplexing. Note that when the expert mode is selected, the
Custom extension option is automatically selected and the management buttons
are enabled. In Expert mode, all scripts become available to be added to the script
list. The scripts will be checked and loaded, ready to be used for analysis, when
the OK button is selected.
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The script management buttons act on the scripts currently listed in the Scripts
text box.

Table 1-3: Script management
Buttons Function

Script files are parsed in the order that they
are listed; in some circumstances this may be
important. To move a file in a list, highlight the file
name and select the Up or Down arrow button as
required. Each press of the button will move the file
up or down one place in the list until it reaches the
top or the bottom.
Add a script to the list: A standard Windows file
selection dialog box is opened. The default file
extension is .scp. Select the required file. The
selected script will be added to the bottom of the
list. If necessary, move it using the Up and Down
buttons.
Scripts can be loaded from any directory.
Delete the highlighted script.

Change scripts default directory: by default, all
scripts are found in a default directory created
during installation (tektronix\scripts). This button
can be used to set a different default directory.
Note that all scripts supplied by Tektronix in the
default installation are installed in a single directory;
as long as this directory is designated as the default
directory, they will work satisfactorily.
View highlighted script with the associated
application; by default, script files are associated
with the ScriptPad utility.
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For a script file to be viewed successfully, the file extension (.scp) must be
associated with a text editor in the Microsoft Windows environment. The MPEG
Test System installation program by default associates a script editing utility
called ScriptPad; you can use another text editor, for example, Microsoft Notepad,
if preferred. ScriptPad is a simple script editor that can be installed with the
MPEG Test System. Scripts can be viewed and edited as required (depending
upon the file permissions).
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Opening a Stream
When opening a multiplexing, you can, open an existing stream or to open a
previously prepared multiplex configuration file.

When a preparing a stream to be multiplexed, you can:

Create a new null stream (using File > New)

Open an existing stream

Import a multiplexer configuration file

Opening an MPEG Stream Any file holding a recorded or synthesized sample of a stream that conforms to the
relevant standards can be opened and used as a basis for a new multiplex. Note
that the Examine TS option can be used to preview stream. (See page 1-59.)

Some nonconformant streams can be opened, although, only the conformant
parts can be edited usefully. Any tables that are carried in a conformant PID
and have the correct syntax will appear in the output transport stream, as will
any elementary streams (whether referenced by a table or not) which are in the
input transport stream.

To open a file holding a transport stream, select File > Open. If the required file is
in the list of recent files, open it from the list using the Open File dialog box.

Alternatively use the Ctrl+O keyboard shortcut or drag the file from Windows
Explorer and drop it into the Multiplexer window. A shortcut button is available
on the Toolbar for opening a file.
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Opening Multiplex
Configuration Files

Any file holding a recorded or synthesized sample of a stream, which conforms
to the relevant standards, can be opened. Many nonconformant streams can be
opened provided that the PAT, PMT, and MGT tables correctly specify all the
other tables and their PIDs.

Multiplexer is used for generating both conformant and nonconformant streams.
Having generated a nonconformant stream, it may not be possible to successfully
open it again in Multiplexer.

The specification for a new transport stream may be saved to a multiplex
configuration file. This also saves time for opening large MPEG files, since the
specification contains the results of the analysis from opening the original MPEG
file.

NOTE. The multiplex configuration file does not contain a copy of the transport
stream; instead it refers to the original MPEG file by the full path name. Deleting
or moving the MPEG file will result in a dialog box prompting for the new
location of the file.

Double-clicking on a *.muxml or *.mux file in Windows Explorer will open the
file in a new instance of Multiplexer.

Importing a File. Importing opens a multiplex configuration file and the MPEG
file on which it is based.

To open a previously exported multiplex configuration file, select File > Import.
If the required file is in the list of recent files, it can be opened from the list to
save using the Import file dialog box.
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Alternatively, use the Ctrl+I keyboard shortcut or drag the file from Windows
Explorer and drop it into the Multiplexer window.

NOTE. Multiplexer reads the name and location of the MPEG file from the
multiplex configuration file and then opens it automatically. The previously stored
changes in the configuration file are applied to the display.

Note that the import dialog box offers a choice of file types: *.muxml, *.mux
and *.*.

Initial Stream Analysis The Navigator Tables view window is opened as soon as a file is opened or
imported. The program now starts to analyze the file with the loaded scripts to
determine what tables are present.

As the file is analyzed, the Top Levels of the Transport Structure diagram are
drawn in the Navigator window. The right pane in the Status Bar at the bottom of
the program window shows the progress of analysis.

Files that are imported require less processing because they were analyzed in the
session from which they were exported.
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What to do Next The file can now be manipulated to form a specification with which to synthesize
a new transport stream. Tables, elementary streams, and PIDs are viewed and
selected using the Navigator views. The components of any table selected in the
Navigator views are viewed and selected using the Section View window.

Tables, Programs and PIDs can be added and modified using the wizards or
manually. A selection of menu options is provided to facilitate manipulation of
the data.

The Multiplex menu has options to inhibit and re-enable forced conformance to
the selected standards.

Having manipulated the file, a transport stream can be synthesized to the new
specification by the multiplex engine. The engine is started from the Multiplex
menu or using a toolbar button. The source file is used as reference data by
Multiplexer and the output written to a different file.

The following illustration gives an overview of the Multiplex process.
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Open/Import

Any file holding a recorded or synthesized
sample of a stream that conforms to the
relevant standards can be opened. (See
page 1-74, Opening an MPEG File.)
Importing opens a multiplex configuration file
and the MPEG file on which it is based.

(See page 1-13, Importing a File.)

Transport Structure Demultiplex
As the file is analyzed, the Top Levels of the
Transport Structure diagram are drawn in the
Transport Navigator.
(See page 1-14, Initial Stream Analysis.)

Transport Structure Modifications
The file can now be manipulated to act as the
specification to synthesize a new transport
stream. The tables and elementary streams
are viewed and selected either with the aid
of Wizards or in the Navigator windows.

Output/Export
The Multiplex Engine synthesizes a new
transport stream and writes it to an MPEG
file.

To ensure that the specification for any
synthesized stream can be reused, it can be
saved to a multiplex configuration file.
(See page 1-106, Multiplexing Transport
Streams.)
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Closing Files
To close the files, select File > Close. This will close both the MPEG file and any
multiplex configuration file that is open.

A shortcut button is also available on the Toolbar for closing a file, which has
a standard file close symbol.

If a multiplex configuration file has been edited, and the changes not exported, the
program will ask if the file should be saved.

Select Yes to export the file, No to close the file without saving, or Cancel to undo
the close command and keep the file open.
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Menus and Controls
This section describes the various menu options, toolbar controls, status bar,
icons, and user interface.

Menu Options
The following pages describe all of the menu options. Since many of the options
are context sensitive, they will be available only when their function is appropriate
for the selected display or window element. When a menu option is not available,
the option is grayed out.

File Menu Options The following table lists the options available in the File menu.

Table 1-4: File menu options
Command Function
Close Closes the current file. This option is

available as soon as analysis starts. If the
wrong file is being opened, or the wrong
options are selected, selecting this option will
abandon the analysis and close the file.

Examine TS Opens the Examine TS window, which allows
a brief summary of the stream to be viewed
before it is subjected to full analysis.

Export... Exports the current multiplex specification
in a form that can be imported even if it no
longer generates a conformant transport
stream. This option is disabled when no file
is open.

Export As... Exports the current file, as above, and allows
a different file name to be specified. This
options is disabled when no file is open.

Exit Closes any file that is open and terminates
the program.
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Edit Menu Options The following table lists the options available in the Edit menu.

Table 1-5: Edit menu options
Command Function
Add Adds a table/section/loop to the currently

selected item in the Navigator or Section
View.

Modify Edits the information in the currently selected
field or item.

Delete Deletes the item currently selected.
Cut Cuts the current selection from the Window.
Copy Copies the contents of the current selection

to the clipboard.
Paste Pastes data from the clipboard to the part of

the transport structure that holds that type
of data.

Export Payload Extracts and exports the payload of the
source transport stream PID in the form of a
simple data file.

Export Elementary Stream Removes the transport stream PID and
PES headers and exports the remaining
information as a simple data file.

Export Section Data Extracts and exports section data. The
created file can be imported as ES using
Multiplexer’s Add function or as SI using the
Import Section Data option (see next option).

Import Section Data Imports SI data from a file and analyzes it.
The section is added to the Navigator view.

View Menu Options The following table lists the options available in the View menu.

Table 1-6: View menu options
Command Function
Interpretation Displays a read-only dialog box for viewing

scripts that have been selected for analysis.
See Initial Menu Options, (See page 6-2.)

Section View Opens the window and displays the table
section currently selected in the Navigator
view.

Event Log Displays the list of events that are recorded
in the Event Log.

Component Bit rate Displays a graphical comparison of the
stream bit rates.
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Table 1-6: View menu options (cont.)

Command Function
Component Duration Displays a graphical comparison of the

stream component durations.
Available Bit rate Displays a graphical view of the bit rate in

the stream.
Properties Opens a properties dialog box for editing

the currently selected item in the Transport
Navigator window.

Zoom In Zooms in the Available Bit rate and
Component Duration views.

Zoom Out Zooms out from the Available Bit rate and
Component Duration views.

Synchronize Synchronizes zoom levels of the Available Bit
rate and Component Duration views (toggle).

Show Cursor Shows or hides the cursor in the Available
Bit rate and Component Duration views.

Toolbar Shows or hides the Toolbar.
Status Bar Shows or hides the Status Bar.

Options Menu Options The following table lists the options available in the Options menu.

Table 1-7: Options menu options
Command Function
Display Filter Opens the SI Filter dialog box.
Single Section View Selects single or multiple section view. When

disabled, multiple section views can be
opened.

Program Wizard Invokes the Program wizard.
Transport Wizard Invokes the Transport wizard.
H264 Bitrate detection settings Opens the H264 stream bitrate detection

settings dialog box. (See page 1-38.)
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Multiplex Menu Options The following table lists the options available in the Multiplex menu.

Table 1-8: Multiplex menu options
Command Function
Start Starts the Multiplex Engine, to synthesize a

new transport stream file.
Stop Aborts multiplexing. The output file is closed

and contains all of the data synthesized
up to the point where the multiplex engine
stopped. This option is available only while
the Multiplex Engine is running.

Standard Mode Enforces conformance to the selected
standards when editing some fields that can
be generated automatically.

Expert Mode Inhibits the above conformance checking so
that nonconformant files may be created.

Report Provides the option of printing all or part of
the transport structure to either a file or a
printer.

Seamless When enabled, the program specified in
Seamless Settings is processed and made
seamless.

Seamless Settings Opens a dialog box in which the Make
seamless parameters are specified.

Playout When enabled, generates and captures
MPEG-2 transport streams that are compliant
with ATSC, DVB, and ARIB standards.

Playout Settings Opens the Playout Settings dialog box in
which path of the MPEG player application
and the folder where the temporary files are
specified.

Loop Sets whether the stream is output using the
looping method.

Update Opens a dialog box in which the parameters
in a stream are updated when looped.

Window Menu Options The following table lists the options available in the Window menu.

Table 1-9: Window menu options
Command Function
Cascade Cascades the open windows when Options > Single

Section View is disabled.
Tile Tiles the windows horizontally when Options >

Single Section View is disabled.
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Table 1-9: Window menu options (cont.)

Command Function
Arrange Icons Aligns icons of any minimized windows at the

bottom of the program’s main window.
1 <window title>
2 <window title>
3 ... etc.

Makes the named window active, putting it on top of
any window that had been hiding all or part of it.

Help Menu Options The following table lists the options available in the Help menu.

Table 1-10: Help menu options
Command Function
About Multiplexer Opens a dialog box that displays the program version

number and license number.

Toolbar

Toolbars provide a set of convenient shortcuts for the more frequently used menu
options. The buttons are context sensitive and are enabled or disabled depending
upon the currently highlighted view or the action being performed.

The Toolbar can be hidden from view by selecting View > Toolbar.

Status Bar
The Status Bar may be hidden from view, but when displayed it is always at the
bottom of the main window. For example:

The following information is displayed from left to right on the Status Bar:

Message Field. Provides a description of any button or menu option over which
the cursor pointer is placed. Other noncritical messages may also be shown.

Filter Status. Indicates the status (On/Off) of the SI Filter.
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Standard Interpretation. Indicates the selected standard with which the file is
processed: MPEG-2, ATSC, DVB, or ISDB.

TS Rate & Duration. Shows the transport stream rate and the duration at that rate.
A default rate is displayed during initial analysis.

User Mode. Shows the User mode selected: Expert or Standard. The Standard
mode prevents changes to certain fields. The Expert mode enables editing.

Processing Status. Indicates the progress (%) during initial analysis and
multiplexing.

Processing Progress. Indicates the progress during initial analysis and
multiplexing.

The Status bar can be hidden from view by selecting View > Status Bar.

NOTE. The status bar (Standard interpretation) displays ISDB-T SS whenever the
ISDB interpretation with Single segment extension is selected.
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User Interface

NOTE. The Menu Bar contains the complete selection of options available in
the Multiplexer. Shortcuts to options are available through the toolbar and
context-sensitive shortcut menus.

Icons Icons are used throughout the Multiplexer user interface to help you to identify
components and make visual links with toolbar shortcuts and menu options.

The following table lists all the icons used.

Table 1-11: Icons
Icon Description Icon Description

About
Multiplexer

Program

Add Program
Group

Audio
stream

Program
Wizard

Bit field Properties
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Table 1-11: Icons (cont.)

Icon Description Icon Description
Close Report

Container/Loop Seamless

Copy Seamless
Settings

Current
selection

Section

Cut Section
timing

Delete Section View

Display
Filter dialog
box

Single
window

Examine
Transport
Stream

Standard
mode

Exit Start

Expert
mode

Stop

Export Table

Export As Transport
Stream icon

Export
Elementary
Stream

Transport
Wizard

Export
Payload

Unknown

Export
Section
Data

Video stream

Import
Section
Data

View Event
Log

Modify View
Component
Duration
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Table 1-11: Icons (cont.)

Icon Description Icon Description
New View

Component
Bit rate

Open View
Available Bit
Rate

Paste Playout-
Playout the
created TS
using Mpeg
Player

Loop Update

Cutting and Pasting Table types, sections, and PIDs can be cut, copied, and pasted using the Windows
clipboard. Only one selection can be held on the clipboard at a time. Alternatively,
a selection can be dragged and dropped using the mouse.

Cutting a Selection to the Clipboard. A selection (table type, section or PID)
can be deleted and automatically placed on the Windows clipboard. It can then
be pasted to a different file or back into the current file. Highlight the selection
in the Navigator Tables or PIDs view and select Edit > Cut or use the Ctrl+X
keyboard shortcut.

Copying a Selection to the Clipboard. A selection (table type, section or PID) can
be copied to the Windows clipboard. From the clipboard, it can be pasted to a
different file or back into the current file.

Highlight the required selection in the Navigator Tables or PIDs view and then
select Edit > Copy or use the Ctrl+C keyboard shortcut.

Pasting a Selection from the Clipboard. More than one instance of Multiplexer
can run concurrently on a machine. A selection (table type, section, or PID) can
be pasted from the clipboard into any open transport stream file. The contents of
the clipboard are not affected by the paste operation, so the section can be pasted
to many files and more than once to the same file.

Activate the Navigator Tables or PIDs view of the required transport stream file
(that is, in an instance of Multiplexer). Then select Edit > Paste or use the
Ctrl+V keyboard shortcut.

The section or version is always appended to the end of the list under the
appropriate table. Program or version numbers are automatically created. If the
table is not present in the multiplex configuration, it will be created automatically.
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Dragging and Dropping A concept familiar to Windows users is "drag and drop" in which files can be
highlighted by clicking on them with the mouse and then dragged and dropped to
a new location, either in the same application or across applications.

In Multiplexer, the main uses of the drag and drop feature are to modify
multiplexes and to build new ones.

Elements can be dragged within Multiplexer, or from the Multiplexer Browser,
Windows Explorer or other instances of Multiplexer.

The program references and the numbering will be automatically added and/or
updated when a new program is dropped onto the Navigator Programs view.

NOTE. Only the MPEG aspects of the transport structure are updated. Tables
specific to DVB and ATSC are not updated.

Manipulation in Program View.

The following manipulations are available in the Program view:

When using the Navigator Program view, a program can be copied or
dragged. The program can be dropped only on the transport stream node
of the Program view.

Only the standard MPEG elements are copied, namely the PAT entry, the
PMT section and the elementary streams. Standard dependent information is
not copied, for example, DVB SDT.

When a conflict occurs with the target, new values will be allocated for the
Program and PID numbers.

Elementary streams can also be dragged and dropped between the Program
Views. They can be dropped only onto the elementary stream root node.

An elementary stream may have a stream type, a component tag and
descriptors associated with it; this information is retained during a drag and
drop in the program view. The program view displays this information when
the properties dialog box is activated.
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Wizards
In the Navigator Programs view, wizards provide you with a step-by-step approach
to building streams to be multiplexed by offering defaults for PSI/SI and the
opportunity to include user-selected programs. The standard previously selected
in the Interpretation dialog box will dictate which PSI/SI components are offered.

There are two major wizards: the Transport Wizard and the Program Wizard.
Other minor wizards may be opened by these major wizards or they may
be opened in a new window to facilitate specific tasks, such as adding EIT
information. When configuring a new multiplex, the Transport Wizard is opened,
followed by the Program Wizard; although, on completion of the Transport phase,
an opportunity to exit the wizard process you have before the Program Wizard
opens. For some detailed operations, only the appropriate wizard can be opened.

At their most basic level, wizards open, in a logical order, the property dialog
boxes that are available when building a stream manually.

The following paragraphs provide a step-by-step description of the wizards.

Wizard Controls The following control buttons are provided on the wizard dialog boxes where
relevant:

Next Retain changes made using this dialog box
and move to next dialog box.

Back Discard changes made using this dialog and
return to the previous dialog box.

Cancel Exit the wizard and discard all changes.
Finish Exit the wizard and implement all changes.

Transport Wizard
Toolbar icon:

The Transport wizard allows you to easily create a basic stream populated with
the PSI/SI necessary to hold program information. It may also be opened when
PSI/SI is to be added to an existing stream.
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Creating a New Transport
Stream

The following steps show the screens used in the creation of a DVB stream.

NOTE. When the Transport Wizard is used to populate a new stream, if the
defaults in the various dialog boxes are retained, then the resulting stream will
conform to the selected standard.

1. To open a new file, select File > New.

2. Select the Program tab in the Navigator view.

3. Select and highlight the Transport Structure element. At this stage of creating
a new stream, this will be the only element visible in the Program Navigator
view.

4. Select Add from the shortcut menu. The Transport Stream Settings dialog
box appears.
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The Transport Stream Settings dialog box allows you to set up the transport
stream identity (part of the PAT section) and version. Adjustments can also be
made to the PAT timing, if required, by selecting the PAT button.PAT timing -
see Editing PSI/SI Table Properties. (See page 1-83.)

NOTE. You cannot add a PAT with the ISDB interpretation and Single segment
extension selected. When you click Add, the Add a Program wizard is displayed
instead of the Transport Stream Settings.

5. In the Transport Stream Settings dialog box, click Next to move to the
Optional Tables dialog box. This dialog box allows you to include and
configure basic PSI/SI information if required.
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6. Select the check box next to each table to add the table name. The table name
is added to the graphical representation on the left and the associated buttons
are also enabled. You can modify the settings of the table such as, timing.

For NIT, TOT, and TDT Timing information, see Editing PSI/SI Table
Properties.(See page 1-83.)
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NIT Settings 7. In the Optional Tables for the Stream dialog box, click Settings for the
Network Information Table (NIT). The Set up the NIT dialog box appears.

8. Enter or select the required values and click OK.

NOTE. If a Delivery System other than Undefined is selected, an additional
settings dialog box becomes available, specific to the Delivery System chosen.
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9. Select Next to move to the Transport Wizard Complete dialog box. This
dialog box allows you to review the changes made by the wizard before
confirming the process. The process can be cancelled, thereby losing all
changes, by selecting the Cancel button.

At this stage in the creation of a new multiplex, if you want to add programs,
leave the Add Program Wizard check box enabled and select Next. If you want to
add them by some other means, clear the Add a Program Wizard check box. The
Next button label will change to Finish, which allows you to exit the wizard and
implement all changes.

When the Transport Wizard has closed, note that the Navigator views are updated
with the new PSI/SI.

Program Wizard

Toolbar Icon:

The Program Wizard allows you to add programs as required to a stream that is
already populated with basic PSI/SI. Each use of the Program Wizard allows
the addition of one program. Adding more programs requires the wizard to be
opened each time.

If a new stream is being created, the Transport Wizard offers an opportunity
to open the Program Wizard. Alternatively, in the Navigator Programs view,
highlight the Programs node and select Add from the shortcut menu.
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Adding a Program to a
Transport Stream

To add a program to the transport stream, follow these steps:

NOTE. When the Program Wizard is used to add programs to a stream, if the
defaults in the various dialogs are retained, the resulting stream will conform
to the DVB standard.

1. When you open the Program Wizard, either as a continuation of creating a
new stream or as an attempt to add a new program, a dialog box similar to that
shown below is displayed:

The values placed automatically in the three displayed fields will be the next
in the sequence of programs. (In the example screen, the stream contains no
prior programs, therefore this is program number 1. PID 32 is used because
that is the first free PID after the reserved PSI/SI PIDs.)

PMT Timing - see Editing PSI/SI Table Properties. (See page 1-83.)

2. Select Next to move to the Add Service Description dialog box.

NOTE. If ISDB interpretation with Single Segment extension is selected the
program number starts from 8 (default). However, you can enter numbers from 1
to 7.
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Service Description Dialog
Box

The Service Description dialog box allows you to identify the Service Provider to
be associated with a program.

3. By default, the Add Service Description check box is clear. When it is
enabled, a Service Provider Name and a Service Name must be entered and a
Service Type selected from the drop-down list. If no details are provided, the
section will still be created but the relevant descriptors will be empty.

Enabling the Use Single Section check box will cause the SDT descriptors to
be added to the existing SDT section. If the stream contains no SDT section,
the check box is disabled.

SDT timing - see Editing PSI/SI Table Properties. (See page 1-83.)

4. Select Next to move to the Program Content dialog box.
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Program Content Dialog
Box

This dialog box allows you to compile a list of elementary streams to be associated
with the program in the final multiplex.

5. Select Add to display the Add Program Stream dialog box. This dialog box
allows you to identify elementary streams to be included in the new multiplex.
You must specify the PID and Stream Type of the new stream. A Component
Tag can also be allocated.

If the Component Tag is enabled, it can be referenced by other tables, for
example, the Event Information Table.
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The dialog box consists of three tabbed pages that specify the source of the
stream, its timing within the multiplex, and whether it should be carrying
a PCR PID.

6. Select a Stream Type from the drop-down list. This will be the Stream Type
allocated to the stream in the new multiplex.

NOTE. The Stream Type drop-down list displays the previously selected stream as
the default type.

7. Allocate a PID Number in which the elementary stream is to be carried.

8. Enable the Component Tag check box, if required. Enter a Component Tag
number (0-255) in the enabled field.

Source Tab. Use the Source tab of the Add Program dialog box to select and
specify elementary streams to be included in the new multiplex.
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9. Enter an elementary stream File Name. You can enter it directly or use the
Browse button to open a standard Windows file selection dialog box.

10. Select the File type of the selected stream from the drop-down list.

If you select MPEG-2 video, the bit rate is detected automatically and
displayed in the Bit rate field.

If you select H.264 video, the Bitrate Detection dialog box is opened.

If the video stream contains HRD information, the bit rate is automatically
calculated. (See page 1-38, Calculating the Bit Rate for H.264 HRD
Streams.)

If the video stream does not contain HRD information, the bit rate must be
calculated manually. (See page 1-40, Calculating the Bit Rate for H.264
Non-HRD Streams.)

When the selected file type does not match with the selected file name, an
error message is displayed and you will have to reselect the correct file type.

11. If you select H.264 video with SEI stream, a Suppress PTS/DTS insertion
check box is displayed. Select this check box to suppress the PTS/DTS
insertion.

Calculating the Bit Rate for H.264 HRD Streams. If HRD information is detected
in the stream, the maximum bit rate is calculated automatically and displayed
in the Bitrate Detection dialog, as shown in the following screen capture. You
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can override the calculated bit rate, either by entering a value manually or by
selecting Detect Bitrate.

12. When the displayed bit rate is satisfactory, select Accept.

13. To alter the settings used for bit rate detection, before the bit rate is detected,
select Scan Settings.

When you select Scan Settings, the H264 Stream Bitrate Detection Settings
dialog box is displayed.

The H264 Stream Bitrate Detection Settings dialog box has three Scan
Duration options. Select one of the following options to proceed:

Scan the entire source stream

Select the number of bytes in the stream to scan

Select a percentage of the stream to scan.

NOTE. The accuracy of the detected bit rate increases with the percentage of
the source stream that is specified.

The chosen setting will be used in subsequent calculations. Select
Automatically start detecting bitrate to use the selected setting.
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Calculating the Bit Rate for H.264 Non-HRD Streams. If no HRD information is
detected in the stream, you must either enter a value manually or use the Detect
Bitrate function in the Bitrate Detection dialog box.

Timing Tab. The Timing tab of the Add Program dialog box is used to specify the
portion of the new multiplex that the selected stream will use. The default start
time is set to 0.002 s.
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12. Complete the fields as required. The default settings assume that the stream is
to be carried throughout the new multiplex, looping if necessary.

PCR Tab. The PCR tab of the Add Program dialog box is used to specify
whether PCR information should be carried with the selected elementary
stream or in a separate associated PID.

13. If the PCR is to be held in an associated PID, disable the Carry PCR check
box and enter a PCR PID number.

14. If the PCR is to be carried with the stream, enable the Carry PCR check box
and complete the remaining fields as required.

Set Defaults returns the settings to their initial values.

15. Select the OK button to complete adding an elementary stream to the listing
in the Program Wizard.

16. More streams can be added using the Add button. Listed streams can be
deleted using the Delete button. Details of listed streams can be modified
using the Update button.
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This completes the addition of one or more program streams.

17. Select Next to move to the Event Information dialog box.

For more details about the fields on these tabs, refer to Adding an Unreferenced
Elementary Stream. (See page 1-88.)

Event Information Dialog
Box

The Event Information dialog box allows you to add the Present and the Following
event information.

18. If the Event Information Table (EIT) is to be included in the multiplex, enable
the Event Information Table check box.

19. Enable the Present and Following check boxes as required.
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Present/Following timing - For more information on Present/Following
timing, see Editing PSI/SI Table Properties. (See page 1-83.).

20. Use the Settings buttons to open the Present/Following Events dialog box.

21. In the Present/Following Events dialog box, click Add. The Event dialog box
appears. Add and specify events as required.
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22. Click OK.

23. In the Event Information dialog box, click Next to move to the Program
Complete dialog box.

Program Complete Dialog
Box

The Program Complete dialog box provides you with a summary of the created
Transport Structure.

24. To confirm and implement the Transport Structure, select the Finish button.

Note that the proposed structure is created in the Navigator views.

This completes the procedure of adding a program to a transport stream using the
Program Wizard.
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Views
Multiplexer contains a number of views, which are displayed in the working area
of the user interface. All of the views can be manipulated using conventional
Windows techniques. The Navigator and Error Log views can be docked against
the edges of the UI or floated independently of the Multiplexer window. The
Section view can be manipulated within the Multiplexer window, including tiling
and cascading where multiple Section views are displayed.

Each available view displays a different aspect or level of detail of stream analysis
and manipulation.

Navigator Views
The Navigator view contains three subviews or tabs: Programs, Tables, and PIDs.

Program Views The Navigator Programs view extracts and displays system information that is
relevant to programs. Information that is not directly related to programs (for
example, NIT), or that has not been incorporated into a program (for example,
elementary streams not listed in a PMT) will be omitted from the Program view.
The system information is still available for viewing in the Navigator Tables
and PIDs views.
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It is recommended that manipulation of programs and elementary streams should
take place from the Program view.

1–46 MTS400 Series Generator Applications User Manual



Views

Tables View The Tables view displays a high-level structure of the Program and System
Information Protocol (PSIP), Service Information (SI), and Program Specific
Information (PSI) tables. More detailed payload information can be examined and
edited, for a selected section of a table, using the Section View.

Any PSI/SI information that the program cannot confidently analyze, will be
shown in the PIDs view.
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PIDs View The PIDs view displays the PIDs contained in the stream. The PIDs are displayed
in ascending numerical order.

PSI/SI table types are identified in the section nodes of System Information nodes.

Elementary stream PIDs are identified by source and type where possible.
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Section View
The Section View displays the contents of the currently selected section in any
of the Navigator views.

The Section view is dynamic in that it will be instantly refreshed if a new section
is highlighted in the Navigator view. If no section is selected, the Section view
will be blank.

The lock icon - - adjacent to certain elements of the table in the Section view
indicates that those items have restricted access due to the mode of user operation:
Expert or Standard.
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Syntax of a Section The following diagram shows a section from a Master Guide Table (MGT).

The syntax specified for an MGT in the ATSC standard A65 is:

master_guide_table_section () {
table_id
section_syntax_indicator
private_indicator
zero
section_length
table_id_extension
reserved
version_number
current_next_indicator
section_number
last_section_number
protocol_version
tables_defined
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for (i=0;i<tables_defined;i++) {
table_type
reserved
table_type_PID
reserved
table_type_version_number
number_bytes
reserved
table_type_descriptors_length
for (k=0;k<N;k++)
descriptor()

}
reserved
descriptor tag
descriptors_length
for (I = 0;I< N;I++)

descriptor()
CRC_32

}

The terms used in this manual to describe the components, represented by nodes,
in the structure diagram are:

Container. A term used to describe a node in the structure diagram
which may contain zero, one or more loops. It is analogous to the for
(i=0;i<loops_defined;i++) statement used to describe the syntax of a table in the
ATSC standards. The container is always preceded by a field which specifies the
number of loops it contains.

Loop. Describes a data structure composed of a specified set of fields and
subordinate loops. The structure diagram shows each loop as a node with the
fields and subordinate loops as children. Each loop node in the section view
represents one iteration of the loop body (the contents of the curly braces { }) in
the syntax specified by the ATSC standards.

Field. Fields are referred to in the standards documents as both data items and
fields. They are the smallest pieces of information that make up a table.

For example, taking an MGT that defines three tables, the Section View represents
the syntax and contents of the Tables container like this:

The loop for the first table, EIT-0 has been expanded to show the fields and
subordinate loops that it contains.
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Syntax of a Multiple String
Structure

The ATSC standard A65 defines a data structure called the Multiple String
Structure. An instance of this structure may contain zero or more strings and each
string may contain zero or more segments. The syntax specified for a Multiple
String Structure in A65 is:

multiple_string_structure () {
number_strings
for (i= 0;i< number_strings;i++) {

ISO_639_language_code
number_segments
for (j=0;j<number_segments;j++) {

compression_type
mode
number_bytes
for (k= 0;k<number_bytes;k++)
compressed_string_byte [k]

}
}

}
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Using the notation of container, loop, and field nodes, the Section View represents
the Multiple String Structure in the same way as any other data structure. For
example: an Extended Text Table (ETT) carries its extended_text_message in a
Multiple String Structure. The default view of a section of an ETT in the Section
View looks like this:

Section View displays a node for the extended_text_message (with as much as
possible of the first segment) from the first string.

Expanding the node reveals a number_strings field which specifies the number of
strings and a container which holds them (strings):

The number_strings field shows that there are two strings in this example.
Expanding the strings container shows the loop for each string. From this it can
be seen that both strings are in English.

Expanding each of the strings reveals the number of segments (number_segments)
that make up each string and a segments container. Similarly, expanding the
segments container reveals segments.

MTS400 Series Generator Applications User Manual 1–53



Views

The contents of each segment loop define what compression and character set are
used, followed by the actual text. The text is held in the compressed_string field.

Expert and Standard
Modes

The Multiplexer has two modes of operation for conformance checking when
editing table contents. These are selected from the Multiplex menu. The checks
that affect the Navigator are:

Standard Mode. Prevents changing the PID of a table whose PID number is
specified in the standard, for example, PID 0x0 carries the PAT.

Expert Mode. A warning is displayed and confirmation requested before changing
the PID of a table whose PID number is specified in the standard.
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An adjacent check mark indicates the mode selected. The mode is also indicated
on the Status Bar.

In the Section View a padlock symbol is displayed adjacent to all of the fields
that cannot be edited in the current mode. For example, the following screens
show the same tables in Standard and Expert mode.
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Figure 1-1: Expert mode

NOTE. The current_next_indicator in both Standard and Expert mode cannot
be edited. This is because the field is affected solely by the Section Properties
concerned with Version Timing. (See page 1-84.)

The selected mode is also reflected in the Wizards that are used to create of
multiplexes. Elements that are restricted in the tables in Standard mode will also
be restricted in the relevant wizard. Similarly, elements that are enabled in Expert
mode will be enabled in the associated wizard.
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Figure 1-2: Standard mode

NOTE. The Section View may need to be closed and reopened to update the
padlock icons.
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Structure Diagram Manipulation
A tree diagram, with the "root node" or highest level component at the top
represents the Transport Structure. A square box indicates components that
contain more information beneath them in the structure.

Clicking on the box does not select that node. It only shows or hides the next
level of detail under that node.

If the node has a minus sign in the box the level of detail below it is currently
displayed. The lower level(s) may be hidden by clicking the mouse pointer on
the box.

If the box contains a plus sign, there is another level in the node that is currently
hidden. Click the mouse pointer on the box to display the next level of information
under the node.

Components that are connected to a branch of the tree without a square box are
leaf nodes; the accompanying icon indicates the node type. They display the
lowest and finest level of detail available in this diagram. These are either a
Section of a Table or a PID.

Fields in the Section view that cannot be edited directly are indicated by a padlock

symbol, . This protection can be switched off by selecting Expert Mode from
the Multiplex menu. It can be reenabled by selecting Standard Mode.
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Event Log
Messages about significant events are written to the Event Log from the time a
file is first opened. You can open the Eent Log for viewing at any time during or
after the initial analysis. When the initial analysis is done, the mean transport rate,
bit rate for each PEES PID, and a Demultiplex complete message are written
in the Event Log.

The start and end times for generating a new transport stream are shown by the
Multiplexer started and Multiplexer completed messages.

Note that when demultiplexing and multiplexing streams, the bit rate at which the
demultiplex or the multiplex is performed is given in the Event Log. This is in
addition to the stream bit rate derived from the stream itself.

When synthesizing a new transport stream any errors or warnings about the new
stream are written to the Event Log between the start and completed messages.

The Category column indicates the type of event. The subject or time of the
event is shown in the Reference column and the details are given in the Comment
column.

The complete text can be copied onto the Windows clipboard, using the Copy
option from the shortcut menu. The text can also be cleared with the Clear
command. Both commands are also available from the Edit menu.

Examine Transport Stream Window
The Examine Transport Stream (Examine TS) window (File > Examine TS)
performs two main functions within the Multiplexer:

It allows you to take an overview of a transport stream before subjecting it
to full analysis.

It allows tables and programs to be dragged and dropped from the examined
stream to the file that is currently open in Multiplexer.
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Menu Bar The Examine TS window menu bar contains only two items: File and Edit.

File Menu. The following table lists the items in the File menu.

Table 1-12: Examine TS - File menu options
Command Function
Open... Analyzes and opens the selected file in the

Examine TS window. Closes the current file.
Close Closes the Examine TS window.

Edit Menu. The following table lists the items in the Edit menu.

Table 1-13: Examine TS - Edit menu options
Command Function
Copy Copies the currently highlighted section to

the clipboard.

File Summary These fields provide a brief summary of the analyzed file.

Filename: The file name of the examined stream.

Interpretation: The interpretation applied to the stream. This is the same as
that selected in the Multiplexer application through the View menu: MPEG-2,
DVB, ATSC, or ISDB.
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TS Rate: The transport stream bit rate derived from the stream.

Duration: The duration of the transport stream.

Status: The status of the stream analysis.

Navigator Views The Examine TS Navigator views correspond to the Navigator views in the main
application. Programs, Tables, and PIDs are shown as they would be after a full
analysis. The PSI/SI tables are expanded and collapsed in the same manner. The
Section view is not available in the Examine TS window.

Examine TS Section Copy While examining transport streams, it is possible to copy sections to the main
multiplex using the standard Windows techniques: copy and paste or by dragging
and dropping them with the aid of the mouse.

For example, to import a section that is visible in the Examine TS window into the
new multiplex configuration:

1. Select the Navigator Tables view.

2. Highlight the section to be copied in the Examine TS window and do one
of the following:

Select Edit > Copy. With the Navigator Tables view active, select Edit
> Paste.

Using the mouse, place the cursor over the highlighted section, press and
hold the left button on the mouse and drag the section onto the Navigator
Tables view. Release the mouse button.

3. Note that the copied section is placed in the PSI/SI structure at the correct
location. If any conflict arises concerning similar PID numbers, a new version
is created.
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SI Filtering
Table elements can be excluded from the Navigator Tables view using the Display
Filter available through Options > Display Filter.

The following dialog box is displayed:
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Selecting a Table for
Filtering

Example: Before filtering, the stream tree may be as shown below:

In the Filter SI Display dialog box, table identities are listed in the Table Id
drop-down menu.

All sections of a table can be excluded by enabling the Exclude all table sections
check box.
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To preview the result of filtering, click the Apply button.

Note that all references to the PMT tables is removed as shown below:

To exclude a range of sections, enable the section by selecting from the Table ID
drop-down list and entering the required range.

Note that section names shown in the dialog box change according to which
table is selected.
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To preview the result of filtering, click the Apply button.

For example, the following settings will result in the display as shown:

NOTE. Minimum and maximum values may be entered in either decimal (12345)
or hexadecimal (0xA12B) format.

The parameters for each table must be set individually. Overall settings can be
applied individually by selecting the Apply button when a setting is made or as a
whole by making all of the settings and selecting the OK button.
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To preview the result of filtering, select the Apply button. All settings can be
cleared by selecting the Clear All button.

Note that filter settings remain in force for as long as the current multiplex is
active. The settings are lost when the Multiplexer is closed unless they have
been previously saved.

Saving/Loading SI Filter
Settings

The filter settings made in the Display Filter dialog box can be saved and
subsequently reapplied to the same stream or other streams.

To save the current filter settings, select the Save button and enter a name (and
location) in the Save As dialog box. To retrieve or load filter settings, select the
Load button and identify the filter file in the Open dialog box. The file extension
*.fil is used.

Component Views
The Component views provide a graphical view of the bit rate and duration of the
components of a stream. The management of the views has a number of common
features; these are described in the Common Features.

Component Bit rate The Component Bit rate view provides a graphical comparison of the stream
components.

Open the Component Bit rate view either by selecting View > Component Bit
rate from the Menu Bar or by using the toolbar button.

Each component includes the following information: Program name, PID,
Description and the Bit rate in numerical and graphical form. Where appropriate,
the Service ID and the Service Name are displayed (extracted from the SDT).
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Component Duration The Component Duration view provides a graphical view of the timing and
duration of each program/component within the current stream. Adjustments can
be made to the duration of each component.

Open the Component Duration view by selecting either View > Component
Duration from the Menu Bar or by using the toolbar button.

The following data is displayed for each component of the stream: Program,
Description, PID, Start and Stop time (in numerical and graphical form), Length
and Bit rate. The timing and bit rate elements of this information are also available
in the Program Stream Properties dialog box. (See Program Content Dialog
Box. (See page 1-36.)

Scaling Bar. The Scaling bar, which is displayed at the top of the Component
Duration view, allows you to select the portion of the transport stream that is to
be displayed.

1–68 MTS400 Series Generator Applications User Manual



Views

The Stream limits bar represents the full extent of the stream. The Display limits
bar (dark portion) indicates the portion of the stream that is currently displayed in
the body of the view.

The Display limits fields indicate the extents of the Display limits bar and the
current Pointer position.

The Pointer can be dragged to a new position on the Stream limits bar. The
Display limits bar will center on the Pointer.

Duration Control. The duration of each element in the stream is given by the Start
and Stop values and shown graphically by the associated bar. The components are
color coded according to which program group they belong to.

The Start, Stop and Length values can be changed by clicking on the appropriate
field and entering the required value. The associated bar will reflect the change.

The Start, Stop and Length values can also be changed graphically by
manipulating the bar. The cursor shape indicates the action that can be taken.

The changes are reflected in the associated field values.

Components can be changed individually. In addition, whole Program groups can
be changed by manipulating the Program duration bar, but only when the view
is sorted by Program.

A vertical dotted line indicates the upper limit of the multiplexed stream.

In the Transport Stream Properties dialog box (View > Properties with the
Transport Stream node highlighted in the Navigator Programs view), you can
determine how and if the stream duration is updated. The available options will be:

Select Fixed to ensure that the stream duration can only be updated in the
Stream Properties dialog box.

Select Set to the greatest component stop time to ensure that the stream
duration is set to the greatest stop time recorded in the SI/PSI/PSIP tables.
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Component start and stop times changed in the Component Duration view are
automatically updated in the SI/PSI tables.

Available Bit rate The Available Bit rate view displays in graphical form the available bit rate for
the duration of the multiplex.

The bit rate is calculated using the MGB2 measure (Ref: ETSI TR 101 290).
Open the Available Bit rate view by selecting View > Available Bit rate from the
Menu Bar or by using the toolbar button.

If the bit rate falls below zero, the points will be highlighted in red. When editing
a multiplex, you can add components which cause the bit rate to fall below
zero and no warnings will be displayed. However, if a transport stream is then
generated, errors will be logged and displayed in the Log view.

Use Refresh to redraw the graph. Clicking anywhere within the graph will place a
vertical cursor at that point; the position and bit rate are displayed in the Time
and Available Bit rate fields.

The zoom level and cursor placement of the Available Bit rate and the Component
Duration views can be synchronized by selecting View > Synchronize.
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Common Features Columns in the Component views can be sorted and rearranged to suit your
preferences. Column management in the two Component views is similar.

Field Selection. You can select the fields to be displayed in each Component view.
The Header bar indicates which fields are currently displayed.

When you right-click on the Header bar, a menu is displayed. You can select
which fields are to be displayed. A check mark next to a field name indicates that
the field display is currently enabled.

You can display the version number of the PAT and PMT in the Description
column by enabling the Show program version option in the shortcut menu from
the Description column header.

Similarly, you can display the PID numbers in hexadecimal, by selecting Display
in hexadecimal from the PID column shortcut menu.
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Column Repositioning. You can reposition Columns as required. Click and drag
the column to the required position.

Column Width. You can resize Columns as required. Place the cursor over the
dividing line between two columns; it will change to the resizing cursor. Click
and drag the column to the required width. The change will be made to the
column to the left of the cursor.

Double-clicking the column divider will automatically resize the column to the
left to the optimum size required to view the content.

Column Sort. You can sort Columns in ascending or descending order. Click the
cursor on the heading to sort the column. Clicking again will sort the column
in reverse order.

Similarly, the columns can be grouped in Program order, by clicking the Program
header.
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Common Menu Options
The specifications for components of the various views can be manipulated by
options from the Edit menu, View Menu, and Toolbar.

A shortcut menu also provides the Add, Modify, Delete, Import, Export and
Properties options. Place the mouse pointer over the component to change and
click the right mouse button to open the menu.

A typical shortcut menu is shown here:

The menu options are context-sensitive and will be enabled or disabled according
to the current selection in the view.

The following options are available from the various shortcut menus:

Add Adds a component to the currently selected
item.

Modify Opens the properties dialog box.
Delete Deletes the currently selected component.
Properties Opens a properties dialog box for editing the

currently selected item.
Export Payload Extracts and exports the payload of the

source transport stream in the form of a
simple data file.

Export Elementary Stream Removes the transport stream and PES
headers and exports the remaining
information in the form of a simple data file.

Export Section Data Extracts and exports section data. The
created file can be imported as ES using
Multiplexer’s Add function or as SI using the
Import Section Data... option.

Import Section Data Imports SI data from a file and analyzes it.
The section is added to the Navigator view.
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Editing in the Navigator Views
Multiplexer provides a variety of ways of building and modifying transport
streams for multiplexing. In addition to the Menu Bar options and Toolbar
shortcuts built into the Multiplexer, many of the operations can be carried out
using familiar drag and drop Windows techniques.

In the following descriptions, the alternative methods for carrying out a task
are given at the head of the section, but only one method is described for each
action. Other methods for the same action often invoke the same dialog boxes and
sequence of follow-on actions.

Dragging and Dropping
To drag a file, click on its name and hold down the left button of the mouse while
dragging the file to the required location. The cursor will change according to
the background that it is dragged over:

(With Ctrl key held) when dropped, the file will be
copied.

When dropped, the file will be moved (cut and
pasted).

When dropped, no action will be taken.

Note that as the file is dragged over elements in the Navigator, receptive elements
(elements where the file can be meaningfully dropped) will be highlighted.

Transport Stream
Opening an MPEG File For information on Opening a Stream, (See page 1-12.)

Opening a Multiplexer File For information on Opening a Stream , (See page 1-12.).

Changing Transport
Stream Bit rate and

Duration

To specify a new bit rate or duration for the transport stream, select and highlight
the Transport Structure component in the Navigator view.

From the shortcut menu, select Properties. The dialog box will be displayed
as shown.
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Edit the Bit rate and the Duration as required, then click the OK button.

Programs
The introduction of the Navigator Programs view has provided a more
program-centered means of manipulating SI/PSI. Whole programs can be added
to the multiplex and the application will update the associated tables, including
the PAT and PMT.

Note that the nodes of the tree structure in the Navigator Programs view are
context sensitive. When dragging and dropping files from either the Examine TS
window or from another instance of Multiplexer, a node will be highlighted as
the cursor passes over it only when the operation proposed is valid. Note that
there may be a short delay before the node is highlighted while the legality of the
operation is checked.
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Adding a New Program With the Transport Stream ID field highlighted in the Navigator Programs view,
selecting the Add option either from the shortcut menu (PAT highlighted in
Navigator Programs view) or the Menu Bar (Edit > Add) will open the Program
Wizard. (See page 1-33.)

In the Navigator Programs view, the PAT is represented by the Transport Stream
ID field.

Copying/Moving a Program Methods available:

Drag and drop (copy only) from the Examine TS window (Programs view) to
the Navigator Programs view.

Drag and drop (copy/move) from another instance of Multiplexer to the
Navigator Programs view.

In the Navigator Programs view, programs can only be dropped onto the PAT node.
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Tables
Adding a New PSI/SI Table Methods available:

Highlight the PSI/SI Tables level in the Navigator Tables view and select
Add from the shortcut menu.

Drag and drop (copy only) from the Examine TS window (Tables view) to
the Navigator Tables view.

Drag and drop (copy/move) from another instance of Multiplexer to the
Navigator Tables view.

Any table that is defined in the selected standards, and not already present, can be
added the transport stream. To add a table to the transport stream, click on PSI/SI
Tables in the Navigator Tables view:

1. Highlight the PSI/SI Tables level and select Add from the shortcut menu.

This will open the Select dialog box. The dialog box displays a list of the table
types that are not already present in the stream.
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NOTE. A PAT table cannot be added when ISDB interpretation with Single
segment extension is selected.

2. Select the required table type and click OK.

Pressing Cancel will abandon the operation without adding a new table.

Only the table types that are not currently specified for the stream are listed. If
the required table type is not listed, press the Cancel button to close the dialog
box without affecting the specification for the stream.

The Select PID & Table ID dialog box is displayed only if a PID and/or Table
ID need to be identified. Otherwise, the selected Table type is automatically
created.
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A single section is automatically added to the newly created table type.

Copying a PSI/SI Table Methods available:

Drag and drop (copy only) from the Examine TS window (Tables view) to
the Navigator Tables view.

Drag and drop (copy/move) from another instance of Multiplexer to the
Navigator Tables view.
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Tables can be copied (or moved) from existing multiplexes, using either of the
available methods.

If a similar table type is already present in the multiplex, the contents of the
copied table will be integrated with it.

Deleting a PSI/SI Table A table is automatically removed when the last section is deleted (See page 1-87.)

Exporting a Table For more information, see Exporting a Section. (See page 1-87.)

Importing a Table For more information, see Importing a Section. (See page 1-88.)

Sections
Adding a New Section to a

PSI/SI Table
Methods available:

Highlight the parent table level in the Navigator Tables view and select Add
from the shortcut menu.

Drag and drop (copy only) from the Examine TS window (Tables view) to
the Navigator Tables view.

Drag and drop (copy/move) from another instance of Multiplexer to the
Navigator Tables view.

To add a section to a table, select the parent table in the Navigator Tables view.
For example, to add a section to the SDT, select SDT Tables:

Then select Add from the shortcut menu.
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The Select PID & Table ID dialog box is displayed only if a PID and/or Table ID
need to be identified. Otherwise the selected section is automatically created.

Select the required PID and Table ID (where enabled) and press OK.

Pressing Cancel will abandon the Add operation without adding a new section.

The version/section of a table is created with a new version or section number.
The rules used by Multiplexer for numbering are:

For tables that the selected standard dictates should always have a section
number of 0, the version number is increased by one. The new version
number is based on the version currently in the table with the most recent
number. The version_number is a 5-bit field, so if the new version would
be 32, it is reset to 0.

version_numberNEW = (version_numberRECENT + 1) modulo 32
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For any table type that allows a section_syntax_indicator, the Add multiple
sections check box in the Generate subtable part of the dialog box is enabled.
Additionally, the One section per segment check box will only be enabled for
the EIT schedule table type.

Up to 256 sections can be added.

Additions to existing subtables using the same Table Id Regions and Versions
will be rejected.

When multiple EIT Schedule sections are being added, the One section per
segment check box is enabled. When it is checked, only the first section in
each segment will be created, rather than all sections numbered between First
section and Last section.

When dragging and dropping a section, the Multiplexer will resolve any
numbering conflicts by creating new versions of duplicated tables.
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Editing PSI/SI Table
Properties

Table and Section Properties are edited by selecting and highlighting one of the
versions/sections within the transport structure and selecting the Properties
option from the shortcut menu.

This opens a dialog box with four tabs, one for each property. Depending on
the type of table, properties can be applied to a specific version or section of
the table. Multiplexer allows only operations that make sense in the context of
the selected table type.

The properties that can be edited from the Navigator Tables view are:

PID Number. The PID tab is displayed by default when the Section Properties
dialog box is opened.

Edit the value and select OK to change the PID number.
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Edit the value and select Apply to make the changes and update the other
properties (tabs) without having to close this dialog box.

Multiplexer checks the new PID number against the selected standards and warns
of any nonconformance. If a conflict is found, a warning message is displayed,
with the option to continue. Multiplexer also checks for conflicts with other
PIDs. If the new PID number conflicts with an existing PID, an error message is
displayed and the change is rejected; in this case, either choose a different PID
number for the table or edit the number of the PID that is currently the owner.

If no conflict is found, another dialog box is opened to define the scope of the
changes:

Select the required scope and click OK. Selecting Cancel will abandon the
change.

Version Timing. The Version Timing tab shows the time when the version will
become current, and the start and end times. New values may be specified for
any of these times.

1–84 MTS400 Series Generator Applications User Manual



Editing in the Navigator Views

Start Time Specifies the time at which sections of this version
will start to appear in the transport stream.

Signalled As Current Time Controls the time when the sections with this version
will have the current_next_field set to 1.
By default when these sections start to appear in the
transport stream, the current_next_field of the section
set to 0. To specify a version that is always current
set the Start Time and Signalled As Current Time
fields to the same value.

Transmit until end of transport
stream

Enables the section to be repeated until the end of
the transport stream. If the check box is disabled, the
Stop Time becomes active.

Stop Time Specifies the time after which no sections of this
version will appear in the transport stream.

All the times are in seconds, taken from the start of the transport stream file. The
default start time for PAT is 0.00 s and for PMT is 0.001 s.

Edit the values and select OK to change the timings. Edit the values and select
Apply to make the changes and update the other properties (tabs) without having
to close this dialog box.

Subtable Timing. Service information is usually constrained to appear at regular
intervals in the transport stream. This is usually implemented as a maximum time
between appearances of all the sections of a subtable (where a table is defined by
the table_id, table_id_extension and version_number on the same PID).

Use the Subtable Timing tab to specify the desired and the maximum acceptable
period between instances of the subtable. When an MPEG file has been opened,
this shows the mean time between instances of the subtable in the transport stream.

Cycle Time Displays the mean time between instances of the subtable specified
for synthesizing a new MPEG file. Edit the value can be to specify a different
cycle time.
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Below the Cycle Time, the dialog box displays subtable specific information
from the currently selected standard.

Edit the values and select OK to change the Cycle Times. Select Apply to make
the changes and update the other properties (tabs) without having to close this
dialog box.

When synthesizing a new transport stream, the multiplex engine tries to insert
the subtable at the frequency specified by the Cycle Time. An error message is
written to the event log whenever a subtable cannot be multiplexed into the stream
within the period specified by the maximum cycle time.

Section Timing. Where a table can contain only a single section (for example,
TOT and TDT), a Section Timing tab is displayed in the Properties dialog box.

Start Time Specifies the time at which the first
appearance of this section will occur.

Stop Time When enabled, specifies the time at which
the last appearance of this section will occur.

Transmit until end... When enabled, specifies that the section
should be transmitted until the end of the
stream.

Cycle Time Specifies the interval at which the section
should be transmitted.

Max cycle time... Gives the cycle time recommended by the
current standard.

Edit the values and click OK to change the timings. Click Apply to make the
changes and update the other properties (tabs) without having to close this dialog
box.

An error message is written to the event log when a table cannot be multiplexed in
accordance with the timings set.
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Deleting a Section Highlight a section in a table in the Navigator Tables view and select Delete from
the shortcut menu. To delete more than one section, select and delete each one
in turn. When the last section is deleted from a table, the table is automatically
deleted from the structure.

Exporting a Section Section data can be exported in the form of a binary file. In the Navigator Tables
view, highlighting a Table node (for example, PMT Tables), allows all sections
of the table to be exported. Similarly, highlighting a single section entry (for
example, Program 123) allows only that section to be exported.

Highlight the required section or Table node in the Navigator Tables view. From
the shortcut menu, select Export Section Data. Name the file to be created and
choose a location. Select Save to confirm the action.

Individual sections can also be exported using the Navigator Programs view.
Select the required section to be exported. From the shortcut menu, select Export
Section Data. Name the file to be created and choose a location. Select Save to
confirm the action. Note that not all tables are shown in the Navigator Programs
view, for example, TOT.
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Importing a Section In the Navigator Tables view, select the PSI/SI Table node. From the shortcut
menu, select Import Section Data. In the PID tab of the Import Section Data
dialog box, identify the PID that is to carry the information. Similarly, in the
Source tab, identify the file that holds the section data to be imported. Select
OK to confirm the selection. During the import action, the content of the file is
examined to determine where the section(s) should be placed.

ES PIDs
ES PIDs that carry additional Elementary Streams can be multiplexed into the
synthesized transport stream. Do the following when defining an elementary
stream to be added:

Allocate a PID number

Define the source of the elementary stream to be added

Define the timing to be applied to the new stream

Define the PCR placement

Adding an Unreferenced
Elementary Stream

Methods available:

Select the ES PIDs in the Navigator Tables view and select Add from the
shortcut menu.

Drag and drop (copy only) from the Examine TS window (Tables view) to
the Navigator Tables view.

Drag and drop (copy/move) from another instance of Multiplexer to the
Navigator Tables view.

To add a new stream, select ES PIDs in the Navigator Tables view and select
Add from the shortcut menu.
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This opens the Add Stream dialog box; the Source tab is displayed by default.

Defining the PID Source. In the Add Stream dialog box, select the Source tab, to
select and define the PID source.
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File name Enter the file name of the stream to be multiplexed. If the
file name is unknown, select Browse to open a standard file
browser dialog and locate the file required.
The names of files being copied to the multiplex will be
automatically filled in.
Select the type of file to be multiplexed from the drop-down
list box.
The following file types are available:
MPEG-1 video ES or PES
MPEG-2 video ES or PES
MPEG-2 audio ES or PES (MPEG-1 or MPEG-2)
MPEG-2 AAC audio ES or PES (ADTS format only)
MPEG-4 audio ES or PES
AC-3 audio ES or PES
(ES - Elementary Stream; PES - Packetized Elementary
Stream)
H.264 video ES or PES
Transport Packets: A single PID stream. The Bit rate value
will require setting. The Original TS PID will require setting.
Section: The content of the file will be Sections. The sections
will be in binary form. The file will consist of one, or many
sections appended one after the other.
When multiplexed, the sections will be encoded on the given
PID as SI. If the resulting multiplex is subsequently opened
in the Multiplexer, the sections will be interpreted as SI and
displayed under the SI Tables node in the tree.
A file generated using the Edit > Export Section Data menu
option can be used here. The Bit rate value will require
setting.

File type

Other: Any binary or ASCII file that is to be packetized into
the transport stream at the specified bit rate. The Bit rate
value will require setting.

The remaining fields are interactive and will only be enabled when a value is
required.

Bitrate When first defining a source, the bit rate is unknown and
0 Kbps is displayed. If a Transport Packet Stream or an
"Other" File Type is selected, the field is enabled and
a value (in Kbps) can be entered. If MPEG-2 video or
H.264 video with HRD messages is selected, the bit rate
value is detected automatically and displayed. If H.264
video without HRD messages is selected, the bit rate is
not detected automatically.

Original TS PID For streams other than transport streams, this field will be
blank and disabled.
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Extra DTS offset When multiplexing ES or PES streams, the Multiplexer
will derive an offset between the PCR and the decoded
timestamp (DTS) of the first access unit (video picture /
audio frame).
You can override this offset and make it larger (positive
number) or smaller (negative number). Changing
this value may cause the resultant stream to be
nonconformant with respect to the T-STD of the
MPEG-2 standard. Enter the DTS offset in seconds
required.

Stream_id Only enabled for elementary stream types. This number
specifies the value of the stream_id field in the PES
packet header.
Only needs to be set for DVB stream. Stream identity in
the PES header.

Start each field in a new PES
packet

Only enabled when File Type: MPEG-2 Video is selected.
When disabled, both field pictures making up a coded
frame are put in a single PES packet. Otherwise, each
field picture is put into a separate PES packet. This
setting has no effect upon frame pictures.

Start each section in a new
packet

Only enabled when File Type: Section is selected.
When disabled, SI data is placed in the packet payloads
in the most efficient manner. The start of a section will
immediately follow the end of the previous section; no
stuffing bytes will be used.
When enabled, each section will begin in a new packet
and stuffing bytes will be used to pad any payloads that
are not full.
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Defining the Stream Timing. In the Add Stream dialog box, select the Timing tab.
This tab will allow timing parameters for the selected source stream to be defined.

NOTE. To achieve compatibility between MUX and MTS4EA, the start time is set
to the following default values: PAT is 0.000, PMT is 0.001, and ES is 0.002.

Start/Stop Time Enter the times that the selected source stream is to
start and stop within the host transport stream. Note
that the overall duration of the host transport stream
is defined through the Transport Stream Properties
dialog box.

Loop Select this check box to loop the selected source
stream for the duration of the synthesis. A Loop
Interval can be set that introduces a delay between
each repeat of the source stream; if zero is entered,
the source stream will loop continuously. The Loop
check box will always be disabled for transport
stream types. The Multiplexer cannot loop transport
streams.

Select OK to accept all changes and close the dialog box.
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Defining the PCR Placement. In the Add Stream dialog box, select the PCR tab
to PCR define the placement.

PCR for Elementary Streams. (Includes File Type: Transport Packets.) PCRs are
placed in the packets at the specified interval, starting with the specified initial
value.

PCR for Remultiplexed PIDs. (Includes File Type: Transport Stream)

If the Carry PCR check box is not enabled, any PCRs in the packets will
be removed.

If the Carry PCR check box is enabled, PCRs will be sent as follows: If
Preserve PCR Inaccuracy is set, the PCRs from the original transport stream
will be used, otherwise the initial PCR value can be specified.

If the Preserve PCR Intervals check box is enabled, PCRs will be sent in
those packets that originally contained them, otherwise PCRs are inserted
into packets at the specified intervals.
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Specifying the PID Number Enter the PID number. A new value can be entered using either decimal or
hexadecimal notation. Values are assumed to be decimal unless preceded with
0x. The dialog box is not case sensitive and values may include zeros after the
prefix and before any significant digits.

When all details (in all tabs) are satisfactory, select OK to accept all changes
and close the dialog box.

Adding Elementary
Streams to the Program

Structure

Methods available:

Select an Elementary Stream node in the Navigator Programs view and select
Add from the shortcut menu.

Drag and drop (copy only) from the Examine TS window (Programs view) to
the Navigator Programs view.

Drag and drop (copy/move) from another instance of Multiplexer to the
Navigator Programs view.

Elementary stream data can be added using the Navigator Programs view.

1. In the Navigator Programs view, select an Elementary Streams node to which
the elementary stream is to be added.

2. From the shortcut menu, select Add. The Add Program Stream dialog box
is displayed.
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The dialog box tabs allows the input elementary stream to be selected and
specified. The main dialog box fields Stream Type and PID Number dictate
the PID that will carry the stream and the stream type entry that will be made
in the PMT.

3. The functionality of the tabbed dialog boxes is described in the following
pages:

Source: See Defining the PID Source. (See page 1-89.)

Timing: See Defining the Stream Timing. (See page 1-92.)

PCR: See Defining the PCR Placement. (See page 1-93.)

4. Enable the Component Tag check box, if required. Enter a Component Tag
number (0 - 255) in the enabled field. If the Component Tag is enabled, it can
be referenced by other tables, for example, Event Information Table.
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Exporting Elementary
Streams

The Export Elementary Stream option allows the nonpacketized elementary
stream data to be extracted from an elementary stream and saved to a binary file.
Note that this data will not include the transport packet or the PES packet headers.

In the Navigator Programs view, highlight the elementary stream whose payload
is to be exported. Select the Export Elementary Stream... option from the
shortcut menu. Name the file to be created and choose a location. Select Save
to confirm the action.

Exporting PES Packets The Export Payload option allows the PES packets to be extracted from an
elementary stream and saved to a binary file. Note that this data will not include
the transport packet headers.

In the Navigator Programs view, select the elementary stream whose payload is to
be exported. Select the Export Payload option from the shortcut menu. Name the
file to be created and choose a location. Select Save to confirm the action.

Modifying PES PID Details To modify any of the ES PID parameters, highlight the required PID in the
Navigator Tables view and select Properties from the shortcut menu. The Stream
Properties dialog box and its tabs are identical to the Add Stream dialog box.
Refer to Adding an Unreferenced Elementary Stream (See page 1-88.)

ES PID parameters can also be modified in the Navigator Programs view.
Highlight an Elementary Stream in the Programs view and select Properties from
the shortcut menu. The dialog box thus displayed (Program Stream Properties) is
similar to the Add Program Stream dialog box.

Deleting a PES PID An elementary stream can be removed from the multiplex by deleting the PID. To
delete a PID, highlight the required PID and select Delete from the shortcut menu.
Then select the Delete option from the Edit or pop-up menus. Alternatively, click
the delete button from the toolbar.

Multiplexer asks for confirmation before removing the PID from the multiplex.
Select Yes to delete the stream or No to abandon the operation and leave the
stream unchanged.
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DSM-CC
Adding an Unreferenced

DSM-CC Section
Methods available:

Select the ES PIDs node in the Navigator Tables view and select Add from
the shortcut menu.

Drag and drop (copy only) from the Examine TS window (Tables view) to
the Navigator Tables view.

Drag and drop (copy/move) from another instance of Multiplexer to the
Navigator Tables view.

Adding an unreferenced DSM-CC section is similar to adding an unreferenced
elementary stream, with the following modifications: (See page 1-88.)

In the Source tab of the Add Stream dialog box, select Transport
Packets/Sections as the File type and set the bit rate.

Adding DSM-CC Sections
to the Program Structure

Methods available:

Select an Elementary Stream in the Navigator Programs view and select Add
from the shortcut menu.

Drag and drop (copy only) from the Examine TS window (Programs view) to
the Navigator Programs view.

Drag and drop (copy/move) from another instance of Multiplexer to the
Navigator Programs view.

Adding a DSM-CC section to the program structure is similar to adding
an elementary stream to the program structure (See page 1-88.), with the
following modifications:
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The main dialog box fields Stream Type and PID Number dictate the PID that
will carry the stream and the stream type entry that will be made in the PMT.
The Stream Type should be set to one of the DSM-CC entries.

In the Source tab of the Add Program Stream dialog box, identify the File
name to be added. Select Transport Packets / Sections as the Stream type
and set the bit rate.

The DSM-CC section will be added.

Delete a DSM-CC Section A DSM-CC section can be deleted from a table by highlighting it in the Navigator
view and selecting Delete from the shortcut menu. To delete more than one
section, select and delete each one in turn.

Export a DSM-CC Section DSM-CC data can be exported in the form of a binary file.

Select the required DSM-CC section in the Navigator Tables view. From the
shortcut menu, select Export Section Data. Name the file to be created and
choose a location. Select Save to confirm the action.

Individual DSM-CC sections can also be exported using the Navigator Programs
view. Under any Elementary Streams node, select the DSM-CC section to be
exported. From the shortcut menu, select Export Section Data.... and Name the
file to be created and choose a location. Select Save to confirm the action.
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Editing in Section View
Use the Section View window to modify the contents of a version/section. This
includes version, section, and table-specific data that the Navigator Tables view
displays. If the Section View window it is not already open, select View >
Section View.

If a section/version is selected in the Navigator Tables view, the contents are
automatically displayed in the Section View; otherwise the Section View window
is blank.

To open a table version/section in Section View, select the component in the
Navigator Tables view. The Section View is updated immediately to show the
selected section/version.

Editing Fields
To add, change, or delete a field, element or loop in a section/version, the parent
table must be selected in the Navigator Tables view. Select the appropriate line in
the Section view and select the required option from the shortcut menu.

Selecting a Field To select a field or container, place the mouse pointer over it and click the left
button.
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The magnifying glass icon indicates the selected component.

If Standard Mode is selected, the magnifying glass selection cannot be placed
on a field that is locked. To select and edit locked fields, first select the Expert
Mode option from the Multiplex menu.

Adding an Element to Loop To add an element to a loop, select the parent loop that will contain it, and then
select Add from the shortcut menu. For example, to add a program to a PAT, select
the Programs container and select Add from the shortcut menu.
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In this example, a dialog box is displayed in which the Program Number and
Program Map PID can be accepted or respecified. Other table loops may not
display any dialog box, but immediately create a new element with default
contents. An entry is displayed for the new element, with its details collapsed, at
the end of the list of elements in the loop. In addition, the section length field is
automatically recalculated and amended. For the above example the new entry is
program_number = 6 (0x6).

NOTE. The example above was taken with Standard mode selected. In Standard
mode, all recalculation is done automatically. In Expert mode, a program element
will be added, but the program number and PID must be manually adjusted.
Similarly, the section length will need to be calculated and amended manually.
(See page 1-54, Expert and Standard Modes.)

Deleting an Element in a
Loop

To delete a loop element, in the Section view highlight the element and select
Delete from the shortcut menu.

The element is deleted and the Section View window updated to reflect the
changes.

Modifying the Contents of
a Field

To edit the contents of a field, select the field and selectModify from the shortcut
menu. This will open an appropriate dialog box for modifying the type of data
held by the field.

The following paragraphs describe the different types of data that may be modified.

Enumerated Value. The Modify value dialog box displays the name of the
field and the current value. The value is shown as a number followed by the
interpretation of the governing standards.

In this figure, the field being edited is a service_type and the current text is 1
(digital).

Type the number, without any text, for the required value. When the changes are
accepted, Multiplexer will display the interpretation in the Section View window.

Alternatively, click the down arrow to select the value from the drop-down list.

This displays a list of the defined values and their interpretation. The list will vary
depending upon the field being edited.
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Enter the required value and select OK to continue. Multiplexer may open a
simple context-sensitive dialog box offering advice and/or asking for more
information or confirmation. An error message is displayed if the number that was
typed in requires more bits than are allocated to the field.

Date and Time. The Modify Time dialog box displays the name of the field. It
displays the time in both interpreted and raw formats; only the interpreted mode
can be edited.

Edit the numbers in any of the fields as required. All fields are updated as each
digit is added, changed or deleted. Select OK to commit the changes or Cancel to
abandon editing and keep the original time.

The Set to all ones check box, when enabled, sets the 40-bit date field to
0xFFFFFFFFF. This may be required when setting the start_date for an event in a
Near Video on Demand (NVOD) reference service.
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Compressed String. The Modify dialog box displays the name of the field, which
is always a compressed string, and the contents of the selected string segment.
Text can be entered, deleted, selected, copied to and pasted from the Windows
clipboard.

Edit the text and select OK to continue. Select Cancel to abandon the edits and
leave the original segment unchanged. Multiplexer checks to ensure that the
new string length does not cause the total section length to exceed the maximum
specified by the standards.

If the total section length exceeds the maximum specified by the standards, an
error message is recorded in the Event Log.

Text. The Modify Text dialog box displays the name of the field and the current
text on a single line. Text can be entered, deleted, copied to and pasted from
the Windows clipboard.

In the following figure, the field being edited is an ISO_639_language_code and
the current text is eng.
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View Value As: You can choose between viewing the text as an ASCII character
string or a hexadecimal sequence. Character codes for DVB Appendix A strings
used in language code pages must be entered in double byte format and padded
with preceding zeroes if necessary. For example, 0x04 should be entered in the
hexadecimal field as 0004 and 0x51d should be entered as 051d. Switching from a
modified hexadecimal value will display the modified character string.

Most text strings have a maximum length, specified by the governing standards,
which this dialog box will enforce. Edit the text and select OK to continue. Select
Cancel to abandon the edits and leave the original text unchanged.

1–104 MTS400 Series Generator Applications User Manual



Editing in Section View

Numeric. The Modify dialog box displays the name of the field and the current
value in decimal. Edit the existing value or type in a new value.

In the following figure, the field being edited is a version_number and the current
value is 0xc.

A new value can be entered using either decimal or hexadecimal notation. Values
are assumed to be decimal unless preceded by 0x. The dialog box is not case
sensitive and values may include zeros after the prefix and before any significant
digits, for example:

Edit or replace the existing value and then select OK to continue. Select Cancel
to abandon any changes made in the field.

Multiplexer will check the new value against the governing standards and for
conflicts with other fields. It may open a simple context-sensitive dialog box
offering advice and/or asking for more information or confirmation. For example,
when changing a version_number, a dialog box appears to determine the scope
of the change.
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Multiplexing Transport Streams
The Multiplex Engine in the Multiplexer synthesizes a new transport stream
and writes it to an MPEG file. The contents of the new stream are multiplexed
according to the specification currently held in memory, which is shown in the
Navigator and Section views.

The tables that are displayed in the Navigator are synthesized from the current
specification. Elementary streams and other data are acquired from the original
MPEG file and other stream files and remultiplexed according to the specification.

Starting the Multiplex Engine
To start the Multiplex Engine, select the Start option from the Multiplex menu.
Alternatively, select the start button on the Toolbar.

Multiplexer opens a standard file browser dialog box to specify the file name and
path for the synthesized transport stream.

A new file can be created or an existing file can be selected to be overwritten. The
program will seek confirmation before overwriting an existing file.

NOTE. The Multiplexer automatically creates 188 byte packets in the transport
stream output file, regardless of the source material size.
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Errors and Reporting
The right pane of the status bar indicates progress as the Multiplex Engine
synthesizes the new transport stream.

Any errors are recorded in the Event Log, which can be opened at any time
before, after and during processing. Here is an example where a table cannot be
multiplexed into the new stream at the specified rate.

Each table has a specification for nominal and maximum interval, in milliseconds,
between instances of the table. These can be edited using the Navigator. The
multiplex engine will try to multiplex the table into the synthesized transport
stream at the nominal repetition rate. Errors are reported whenever packets for
any PID cannot be encoded at their specified minimum rate.

The complete text may be copied to the Windows clipboard, using the Copy
option from the shortcut menu. The text can also be cleared with the Clear
command. Both commands are available from the Edit menu.
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Stopping the Multiplex Engine
The Multiplex Engine can be stopped at any time while it is running. This will
abandon processing and close the file. The file will contain all of the packets
synthesized up to the time the engine was stopped.

To stop the Multiplex Engine, selectMultiplex > Stop.

Alternatively, select the Stop button on the Toolbar.

Exporting the Multiplex Configuration File

NOTE. Multiplexer is used for generating both conformant and nonconformant
streams. Use the Export and Export As options to save copies of the specification
for nonconformant streams in a multiplex configuration file. This file does not
include a copy of the transport stream, instead, it refers to the original MPEG file
by name and location.

The multiplex configuration file can be reopened using the Import option. (See
page 1-13.)

Export Select File > Export to save any changes to the current multiplex configuration
file. Alternatively, use the Ctrl+E keyboard shortcut.

If a multiplex configuration file has not been opened, Export opens a standard file
browser dialog box to specify the file. This is the same as selecting the Export
As... option.
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Export As File > Export As exports a file with a user-specified name.

Multiplexer opens a standard file browser dialog box to select an existing file
or specify a new file.

If you are creating a new file, specify the name of the exported file and select where
it will be saved. By default, files are be created with .muxml as the file extension.
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Make Seamless
When you loop a transport stream to simulate continuous playout, errors can be
generated at the loop point caused by discontinuities in timing information. The
Seamless option provides the opportunity of creating seamless MPEG-2 files.

The option can be set up and enabled so that all multiplex operations result in
seamless output or none.

Enabling the Seamless Option
Toggle the Seamless option by selectingMultiplex > Seamless or by using the

toolbar button .

Seamless Settings
Open the Seamless Settings dialog box by selectingMultiplex > Seamless >
Settings.... The Seamless Settings dialog box appears.
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Priority Program First program in PAT has priority If this setting is enabled, the first program
specified in the PAT will be given priority in
the make seamless process.
If the setting is disabled, the priority program
can be specified in the Priority Program. The
number can be deduced by inspecting the
results of the transport stream analysis.

PSI Settings Make PSI seamless If enabled, the service information contained in the
transport stream is processed to make it seamless.
If the setting is disabled, the PSI/SI is not processed
but simply copied to the output transport stream.

Make remaining programs
seamless

If enabled, the remaining programs are made seamless
but are constrained by limits defined by the priority
program. This may lead to these remaining programs
having a gap at the beginning and end of the file.
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Abbreviations
AIT Application Information Table
ASCII American Standard Code for Information Interchange
ATSC Advanced Television Systems Committee
CAT Conditional Access Table (MPEG
CDT Carrier Definition Table
CVCT Cable Virtual Channel Table (ATSC)
DSM-CC Digital Storage Media - Command and Control
DTS Decoding Time Stamp
EIT Event Information Table (DVB/ATSC)
ES Elementary Stream
ETT Extended Text Table (ATSC)
HRD Hypothetical Reference Decoder
MGT Master Guide Table (ATSC)
MMT Modulation Mode Table
NIT Network Information Table (DVB)
PAT Program Association Table (MPEG)
PES Packetized Elementary Stream
PID Packet IDentifier
PIT Program Information Table (ATSC)
PMT Program Map Table (MPEG)
PSI Program Specific Information (MPEG)
PSIP Program and System Information Protocol (ATSC)
PTS Presentation Time Stamp
RAID Redundant Array of Independent Disks
RRT Regional Ratings Table (ATSC)
RST Running Status Table (DVB)
SDT Service Description Table (DVB)
SEI Supplemental Enhancement Information (H.264)
SI Service Information (DVB)
SIT Satellite Information Table
STT System Time Table (ATSC)
TDT Transponder Data Table (ATSC)
TNT Transponder Name Table
TOT Time Offset Table (DVB)
TS Transport Stream
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TSTD Transport Streams Description Table
T-STD Transport Stream System Target Decoder
TVCT Terrestrial Virtual Channel Table (ATSC)
UTC Universal Coordinated Time
VCT Virtual Channel Table (ATSC)
VUI Video Usability Information (H.264)
XML Extensible Markup Language
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Transport Stream Editor
The Transport Stream Editor can be used to edit the contents of transport stream
packets contained in a file. It displays the complete contents of each packet in
hexadecimal and provides an interpreted view of the packet header information.

Packet headers can be edited from both the header interpretation and hexadecimal
displays. These are referred to as the Header Editor and the Hex Editor,
respectively. All changes made in one view are immediately shown in the other.
The Header Editor is context sensitive, only allowing edits that make sense with
the other fields in the header. It gives full syntax checking of all changes that are
made. The payload and any Reed Solomon data are edited from the Hexadecimal
Editor.

On the right of the Hex Editor pane, the ASCII character is displayed. Unprintable
characters are shown as a period (dot or full stop).

It is normal to edit a copy of a transport stream. Transport Stream Analyzer can
be used to view the original while editing the copy.
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Starting the Program
The program may be started by selecting the Tektronix TS Editor option from
the Start > Programs menu or by double-clicking the Tektronix TS Editor
shortcut on the desktop.
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Initial Appearance Once the program has started and is ready for use, it will open a Main Window
that looks like this:

Options
The Transport Stream Editor has a set of options relating to general use and
opening files. It is a good idea to review the options before opening a file.

The settings can be changed at any time by selecting Options... from the Edit
menu. This opens the Options dialogue box.
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Opening File Specifies how the program will interpret the packet size of the stream. The options
are mutually exclusive and are as follows:

Always edit copy When opening a file Editor always makes a copy, without
asking.

Always edit original, don’t make copy Uses the original files without making a
copy or asking for confirmation.

Always ask Before opening a file for editing, asks if it should edit the original
or make a copy.

Only open valid MPEG Transport Stream files Will open files that have five
or more consecutive sync bytes.

Open as ARIB ISDB-S Transport Streams Opens transport streams encoded as
ARIB ISDB-S format (including TMCC information).

General Options Show Wizard Introduction pages Causes any wizards invoked by Editor to
display their Introduction pages.

Warn about remapping to existing PIDs Warns if an operation will remap
a PID onto one that is already in use.
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Opening a File
Any stream that is held in a file can be edited with the Transport Stream Editor.

Opening a File from the
Menus and Toolbar

To edit a file, select the Open from the File menu. If the required file is in the
list of recently edited files, it may be selected from the list to save using the
Open file dialog box.

Alternatively, use the Ctrl+O keyboard shortcut.

There is also a shortcut button available on the Toolbar for opening a file, which
has the standard file open symbol:

Opening a File from
Windows Explorer or a File

Browser Window

The program can be started and a file opened (with the last set of program options)
in a single operation from Windows Explorer or a File Browser Window.

Place the pointer over the file name or icon, press the right mouse button to open a
menu, and then select the Edit option.
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Copying File before Editing TS Editor writes all edits to the file immediately. To avoid accidental changes to
prime data, the application can make a copy of the file and edit that copy. By
default, once a file has been selected for opening, you are prompted to decide
whether to edit the original or make a copy.

If you do not want to be presented with this dialog box each time a file is opened,
set the copy or edit original option as the default.

It is recommended that this dialog box be left as the default option.

If someone else has used the MPEG Test System, it is a good idea to look at the
Options before opening a file.

To edit the original file, (useful when making edits to a file that is already a copy)
select the No, I want to edit the original option, and then select the OK button.

To make a copy, select the Yes option, specify the copy file, and then select OK.
While the copy is being made, the pointer changes to the busy pointer, usually
an hour glass.
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When the Edit a copy option is selected, the dialog box suggests a suitable
filename, which you can edit. To look for a different directory or filename, select
the Browse button. This will open a standard file browser window, like this:
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Menus and Controls
The following pages contain descriptions of the different menu options, toolbar
controls, status bar, and slider bar.

Toolbar
The Toolbar provides a set of convenient shortcuts for the more frequently used
menu options. The available commands are:

Opens a file. If a file is currently
open, it will be closed when a new
file is selected.
Closes the current file. There is no
save option because all changes
are written to file immediately.
Prints the current packet.

Opens a print preview of the current
packet.
Copies the bytes that are currently
selected in the Hexadecimal Editor
from the packet to the clipboard.
The bytes are copied using the
hexadecimal representation. This
button is disabled (grayed out)
when nothing is selected that can
be copied.
Copies the entire contents of the
current packet to the clipboard.
Pastes any data, held in
the TS Editor’s hexadecimal
representation, from the clipboard
into the packet starting at the
currently selected byte.
Undoes the last edit, restoring the
previous value. Selecting Undo
again undoes the previous change
and so on.
Reinstates the previously undone
change.
Opens the Options dialog box.
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Status Bar
The Status Bar may be hidden from view, but if it is always visible at the bottom of
the window. It displays the following information about the program and open file:

When no file is open, the File Size, Packets, and Packet Size fields are all set to
zero or null:

Slider Bar
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The contents of any transport stream packet in the currently open file can be
selected using the Slider bar. Packets are numbered according to their position in
the file, with the first packet being 0 (zero). The controls in the slider bar are:

PID Filter

Slider
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Packet Number

It is normal to edit a copy of a transport stream. Transport Stream Analyzer uses
the same packet numbering as Editor. So the packet number can be used to find
and view a packet in Analyzer, and then edit the copy of the same packet in Editor.

The Slider Bar can be dragged from the edge of the main window into a floating
pallet. To do this, place the mouse pointer on the background (inside the Slider
Bar), hold down the left mouse button, and drag the slider bar away from the
window border. The result is a self contained window that looks like this:

To replace the Slider Bar on the window border drag, it over the border until the
outline changes shape.

Menu Options
The following pages describe all of the menu options. Since many of the options
are context sensitive, they will be available only when their function is appropriate
for the selected window or display element. When a menu option is not available,
the option is grayed out.

File Menu Options The following table lists the File menu options.

Table 2-1: File menu options
Command Function
Open Opens a file for editing. If a file is currently

open, it is closed when a new file is selected.
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Table 2-1: File menu options (cont.)

Command Function
Close Closes the current file. There is no need

for a save option because all changes are
written to file immediately.

1 <filename>
2 <filename>
3 <filename>
4 <filename>

A list of the four most recently edited files. If
the program has recently been installed, the
list may be empty or hold less than four files.

Print Prints the current packet.
Print Preview Opens a print preview of the current packet.
Print Setup Selects printer and configuration.
Exit Closes any file that is open and terminates

execution of the program.

Edit Menu Options The following table lists the Edit menu options.

Table 2-2: Edit menu options
Command Function
Undo Undoes the last edit, restoring the previous

value. Selecting undo again undoes the
previous change.

Redo Reinstates the previously undone change.
Copy Copies the bytes that are currently selected

in the Hexadecimal Editor from the packet to
the clipboard. The bytes are copied using
the hex representation.

Copy Packet Copies the entire contents of the current
packet to the clipboard.

Paste Pastes hexadecimal from the clipboard into
the packet starting at the currently selected
byte.

Select Packet Selects the entire contents of the packet.
Fill Prompts for and fills all selected bytes with

a value.
Options … Opens the options dialog.
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View Menu Options The following table lists the View menu options.

Table 2-3: View menu options
Command Function
Toolbar Shows or hides the Toolbar, which provides

a set of convenient shortcuts for the more
frequently used menu options.

Status Bar Shows or hides the Status Bar.
The following menu options select which standard is used to interpret the values held in the
Transport Scrambling Code field. Only one standard can be selected at any time.
MPEG2 Selects the MPEG2 interpretation of the

Transport Scrambling Code.
DVB Selects the DVB interpretation of the

Transport Scrambling Code.
ATSC Selects the ATSC interpretation of the

Transport Scrambling Code.

Tools Menu Options The following table lists the Tools menu options.

Table 2-4: Tools menu options
Command Function
Remap PIDs… Starts the tool to Remap packets from one or

more PIDs to different PIDs.
PCR Recalculation… Opens a Wizard to Recalculate the Program

Clock References (PCR) carried in one or
more PIDs.

Help Menu Options The following table lists the Help menu options.

Table 2-5: Help menu options
Command Function
About… Displays the program version number and

license number.
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Hex Editor
The Hex Editor displays and provides editing facilities for the contents of the
current packet in both hexadecimal representation and ASCII characters.

Color Coding
Color coding is used to show the "footprint" of various header fields, in both the
hexadecimal and ASCII views. The packet payload and any Reed Solomon data is
shown in black. The bytes of the packet header field are shown in magenta text.

When an adaptation field is present it is shown by blue colored text:
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If transport private data is present it is shown in green:

NOTE. It is possible to define a transport private data area that is not contained
within the adaptation field area specified by the adaptation field length.

Selecting & Editing
One or more bytes can be selected using either the hexadecimal or ASCII view.
Changes are made using options from the menus and by typing new values in
the hexadecimal view.

When the mouse pointer is moved over either of the views in the Hex Editor, the
pointer changes to the Text Select pointer.

Individual Bytes To edit a byte or character, position the mouse pointer over the desired character
in either the ASCII or hexadecimal view. Then click the left mouse button. A
flashing inverse video cursor appears to the left of the character.

Alternatively, double-click either view of the byte to select it for use with an
option from the Edit menu operation.

New values can be entered from the keyboard. As each character is typed, the
cursor moves on to the next. It can be repositioned with the mouse or by using the
up, down, left and right cursor keys.

The cursor will not move forward beyond the end or back before the start of the
packet. To select another packet, use the Slider Bar.
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Block of Bytes A block of bytes can be selected for operations such as copying to the clipboard
or filling with the same value.

Click on the first required byte and hold down the left mouse button. Then drag
the mouse pointer to the last byte to be selected and release the left mouse button.
Both the ASCII and Hex views can be used for selection. The selection is shown
in inverse video in the view from which the it was made, and by an outline around
the selection in the other view. For example, when made from the ASCII view, a
selection looks like this:

Once selected, the block of bytes can be edited with the available options from
the Edit and the Pop-Up menus. Clicking the mouse or pressing a cursor key
clears the selection.

To select a block using the cursor keys: position the cursor on the first byte,
and then hold down the Shift key and move the cursor with the cursor keys.
The selection is drawn between the initial and current cursor positions. Release
the Shift key when the cursor has reached the last byte. Clicking the mouse or
pressing a cursor key clears the selection.

Editing Commands The Edit menu, pop-up menu, and toolbar buttons provide a variety of options
for editing the packet contents. The Pop-Up menu is opened by clicking the right
mouse button when the pointer is over the Hex Editor, for example:

Depending on what operations have recently been performed and on what is
selected, the menus and toolbar will offer different commands. The complete set
of menu options and associated buttons are as follows:

2–16 MTS400 Series Generator Applications User Manual



Hex Editor

TS Editor keeps a list of recent changes.
Each Undo command backs out the most
recent change from the list. That change is
moved to the Redo list in case it needs to
be reinstated. As each change is undone
the cursor moves to the appropriate field (in
the Hex or Header Editors) and restores the
previous value.
Reinstates the most recently undone
operation. When a new edit is made, the
Redo list is cleared.
Copies the currently selected bytes to
the clipboard. From there they may be
pasted in to other packets or used by other
applications.
Copies the entire contents of the current
packet to the clipboard. From there it can be
pasted into other packets or used by other
applications.
Pastes packet contents held on the clipboard
into the current packet, starting at the current
cursor position.

Select Packet Selects the entire packet. This is a quick
alternative to selecting all the packets with
the mouse or keyboard.

Fill Fills all the selected bytes with a hexadecimal
value.

This option opens the Fill Byte dialog box.
Enter the fill value then select the OK button.
The Cancel button abandons the operation,
leaving the bytes in their original state.

There are no Toolbar buttons for the Select Packet and Fill commands.
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Header Editor
The Header Editor has three tabs. These show and allow editing of the basic
header, adaptation field, and the adaptation field extension contents. The Hex
editor is immediately updated to show the new values when changes are made in
the Header Editor.

Binary flags are shown with check boxes whose state can be changed by clicking
in the box with the mouse pointer. Multi-bit fields may be edited by typing in the
new values or selecting a value from a drop-down list.

NOTE. It is important to remember that changing a flag or field often alters the
structure of the header. The other flags and fields will be reinterpreted according
to the data underlying their new position in the structure.

Header Information Tab

The Header Information Tab interprets the contents of the Packet Header (shown
in magenta text in the Hex Editor) for ease of understanding and editing.

The PID Value field displays, and allows editing of, the 13-bit PID as a decimal
value. (The PID is packed into a pair of bytes with the Flags shown below.)

The Flags fields display the state of each binary flag in a check box:

= 0 or false
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= 1 or true

Click in the box to toggle the state of a flag.

The Continuity Count field displays the value of the four bit Continuity Count
field in decimal.

To avoid any typing errors, the drop-down list allows selection of a different value.

The Transport Scrambling Control displays the two bit Transport Scrambling
Control field as a binary bit pattern, with a text description.

Use the drop-down list to select a different value.

The text gives the interpretation for the bit pattern according to the standard that
is currently selected: MPEG2, DVB or ATSC. Use the View menu to select the
required option.

The Adaptation Field Control displays the two bit Adaptation Field Control as a
binary bit pattern, with a text description.

Use the drop-down list to select a different value.

The Adaptation Field and Adaptation Field Extension Tabs will be empty (grayed
out) when the 01 - Payload Only or 00 – Reserved values are selected.
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Adaptation Field Tab

The Adaptation Field Tab interprets the contents of the Adaptation field (shown in
blue text in the Hex Editor) if one is present in the packet. To be able to edit an
Adaptation Field, the Adaptation Field Control value in the Header Information
Tab must indicate that an adaptation field is present.

The Adaptation Field Length field shows the length of the Adaptation Field in
bytes and allows it to be edited in decimal.

The Flags fields display the state of the binary flags in check boxes:

= 0 or false

= 1 or true

Click in the box to toggle the state of a flag.

The PCR Flag field displays the state of the binary PCR Flag in check boxes:

= 0 or false

= 1 or true

When the flag is true the PCR Value is shown and can be edited in decimal
notation.
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The OPCR field displays the state of the binary OPCR Flag in check boxes:

= 0 or false

= 1 or true.

When the flag is true, the OPCR Value is shown and can be edited in decimal
notation.

The Splicing Point Flag fields displays the state of the Splicing Point Flag in
check boxes:

= 0 or false

= 1 or true

When the flag is true, the Splice Countdown value is shown and can be edited in
decimal.

The Transport Private Data Flag field displays the state of the Transport Private
Data Flag:

= 0 or false

= 1 or true.

When the flag is true, the Data Length is shown in bytes and can be edited in
decimal.

The Adaptation Field Extension Flag indicates the state of the binary Adaptation
Field Extension flag.

= 0, no Adaptation Field Extension. The Adaptation Field Extension Tab can be
viewed, but all of the fields will be grayed out.
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= 1, Adaptation Field Extension present. The Adaptation Field Extension
Tab will show and enable editing of the information contained in the Adaptation
Field Extension.

Adaptation Field Extension Tab

The Adaptation Field Extension Tab interprets the contents of the Adaptation
Field Extension if one is present in the packet. To be able to edit an Adaptation
Field Extension the Adaptation Field Extension flag must be set to 1 (the box must
be checked) in the Adaptation Field Tab.

Shows the length of the Adaptation Field Extension in bytes and allows it to be
edited in decimal.

Displays the state of the LTW Flag:

= 0 or false

= 1 or true

When LTW is true, the state of the LTWValid flag and value of the LTWOffset are
shown. The Valid flag may be toggled and new Offsets can be typed in decimal.

Displays the state of the Piecewise Rate Flag:
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= 0 or false

= 1 or true

When the flag is true, the Rate is shown and can be edited in decimal notation.

Displays the state of the Seamless Splice Flag:

= 0 or false

= 1 or true

When the DTS Next AU value is shown and it can be edited in decimal notation.

The 4 bit Splice Type is shown as a bit pattern.

It has a drop-down list containing all 16 possible bit patterns.

Use the list to select a different value.

MTS400 Series Generator Applications User Manual 2–23



PID Remapping

PID Remapping
NOTE. The packets of one or more PIDs may be remapped (moved to different
PIDs). Only the PID in the packet headers is changed. Any packet payload
contents, such as SI and PSI tables are unaffected. So remapping can break the
references from tables to PIDs, or be used as an investigation to correct broken
references.

To remap packets from one or more PIDs, select the Remap PIDs option from
the Tools menu.

The program scans the file to build a list of PIDs, displaying the Hourglass mouse
pointer while it is busy. It then opens the Remap PIDs dialog box:

To specify a mapping from a current PID to a new PID, select the current PID
entry from the list by clicking on it.
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Now select the Edit.. button, which opens the PID Entry dialog box.
(Alternatively, double-click on the required entry in the list.)

Type in the value for the new PID to map to and select OK.

Repeat this process for each PID that is to be remapped.

The Restore button will change the value of the selected Map to PID back to that
of the Current PID without having to open the PID Entry dialog.

When all the mappings are specified, select the Remap button. (The Remap button
is not enabled unless one or more mappings has been specified.)
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The hourglass mouse pointer is displayed while the program performs the
remapping. On completion, the dialog box closes and control is returned to the
main window.
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PCR Recalculation
The Program Clock References to one or all Programs can be changed. The
rate can be changed and/or any one of six types of jitter added. Uses of PCR
Recalculation include:

Recalculating the rate at the correct value, without adding jitter, on a recording
of a faulty stream can be used to remove suspected PCR problems. If the
recalculated stream works correctly the problem is in the PCR.

Creating test data with known deviations in rate for exercising other
equipment.

NOTE. Do not perform PCR Recalculation on an original recording. This
operation is not reversible, so it is strongly recommended that a copy of the
original file is used.

To modify the PCR, select the PCR Recalculation option from the Tools menu.

This runs a wizard to analyze the program structure, guide the user through the
available options, and then recalculate the PCR values. The wizard presents 3, 4
or 5 pages depending upon the chosen options:
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By default, the wizard will display this Introduction first.
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It may be disabled for future recalculations by selecting the check box option at
the bottom of the introductory text. Selecting the Next button moves on to the
Select Program page.

The wizard has to analyze the file to extract the relevant Program Information,
which may take a while. When analysis is complete, the Select Program page
shows a list of the programs whose PCR values may be changed (see the following
illustration).
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To recalculate the PCR rate for all the programs, check the All programs? option.
Otherwise, select one of the programs from the list. Then select Next to move on to
the Select New Rate page. The Back button moves back to the Introductory Page.

Keeping the rate as New Playout = Current Playout and selecting Jitter Function
of <none>, will recalculate the PCR based on the current rate. This could be used,
For example, to investigate a suspected problem with the PCR by playing the
original and recalculated versions to see if there is a difference.
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A new playout rate can be specified and/or a Jitter Function can be applied to the
rate. There are seven Jitter Functions available including <none>. The available
functions are:

Each of the jitter functions is described in more detail at the end of this subsection.

If a Jitter Function is required, choose one of the six functions from the drop-down
list, otherwise leave it set to <none>. Specify any change in the New Playout rate
and select the Next button. Selecting Back returns to the Select program page.

When no Jitter function, (<none>), was selected, the Select Jitter Parameters
page will not appear. Go on to the Summary page, which shows a picture of
a checkered flag.

With a Jitter Function selected, the next page will be Select Jitter Parameters. This
asks for additional information specific to the chosen Jitter Function. For example,
the Sine Wave function requires the parameters shown in the following illustration.
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Specify the required parameters and select Next to move on to the Summary page.
Use the Back button to return to the Select New rate page.

The Summary page displays a short list of the specified PCR rate changes.

NOTE. Select Finish to recalculate the PCR values. Remember, once Finish has
been selected, there is no going back.
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Use the Back button to return to the previous pages to make any changes.

The program may take a while to perform the recalculations. The Summary page
will stay on screen and the Hourglass mouse pointer be displayed while the wizard
is processing. When the summary page disappears the calculation is complete and
the file can be closed or edited.

Jitter Functions
Select the required Jitter Function from the Select New rate page, then select
Next to move on to the Select Jitter Parameters page to specify the parameters
for the selected Jitter Function. The following subsections give details about
each function.
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Impulse The Impulse Jitter function adds a positive or negative value to a single PCR.

Max Amplitude Specifies the size of the impulse in
nano-seconds. Type a minus sign in front of
the value for a negative impulse.

Interval Specifies the time taken from the start of the
file at which the Impulse is to be applied.

Step The Step Jitter Function adds a positive or negative offset to the ideal PCR values
after a specified time. The offset will be the same for all PCRs.
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Max Amplitude Specifies the size of the offset in
nano-seconds. Place a minus sign in front of
the value for a negative offset.

Interval Specifies the time taken from the start of the
file of the first PCR to which the offset is to
be applied.

Sine Wave An offset that varies according to a sine function is applied to the ideal PCR
value for each PCR.

Max Amplitude Specifies the amplitude of the sine wave in
nanoseconds.

Period Specifies the period of the sine wave in
milliseconds.

Square Wave An offset, which varies according to a square wave function is applied to the ideal
PCR value for each PCR. The square wave has an equal mark/space ratio.
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Max Amplitude Specifies the amplitude of the square wave
in nanoseconds.

Period Specifies the period of the square wave in
milliseconds.

Random The PCR jitter applies offsets of a uniform random distribution to the ideal values
of the PCRs. Each offset will be within the range of ± the specified amplitude.

Max Amplitude Specifies the maximum amplitude of the
jitter, relative to the ideal value, that can be
added to any PCR. Only a positive value
can be entered. The amplitude is always
from -Max. Amplitude to +Max. Amplitude
centered on the ideal PCR value.
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Gaussian The offsets are applied to the ideal PCR values following a Gaussian distribution
according to the specified standard deviation.

Standard Deviation Specifies the standard deviation to be used
by the jitter function in deriving the offset for
each PCR, relative to the ideal PCR value.
Only a positive value can be entered for
standard deviation.
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MPEG Player - Getting Started
NOTE. This section describes the default MPEG Player installed in all MTS400
Series system. The MTX100B/RTX100B/RTX130B players are described in:
MTX100B Quick Start User Manual (Tektronix part number 071-2593-xx) and
RTX100B Series Quick Start User Manual (Tektronix part number 071-2595-xx),

The MPEG Recorder & Player generates and captures MPEG-2 transport streams
that are compliant with ATSC, DVB, and ARIB standards.

The MPEG Player provides the following features:

Data rate: 213 Mbps maximum; 250 Kbps minimum.

Hierarchical display of the stored or captured transport stream.

188, 204, 208 bytes packet size.

Continuous recording of captured streams.

PCR jitter insertion.

Triggered stream capture.

Full remote control using Ethernet interface.

IP, ASI, SMPTE 310M and DVB SPI (DVB Parallel) interfaces available.

Playout interfaces: IP and other interfaces.

Both the commonly used IP versions - IPv4 and IPv6 are supported.

Stream replication (IP) with some attributes of the stream incremented by
a certain value.
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Display Elements
There are two types of display screens to operate the MPEG Player; the Play
screen and the Record screen.

The Play screen is used to output the selected stream.

The Record screen is used to record the input stream. When you select File >
Record, the screen switches to the Record screen.

This subsection explains the name and functions of the display elements in the
Play or Record screen.

The following figure shows the location of display elements of the Play screen.
The Record screen display elements are the same.

Menu Bar The Menu bar displays the names of the menus that can be used in the Play or
Record screen.

Refer to Menus and Controls for detailed information about the menus.
(See page 3-21.)

NOTE. The IP interface mode does not support the Record functionality.
Therefore, the Record option is disabled for IP.

Toolbar The toolbar provides shortcut buttons for many of the most often used menu
commands. Click a toolbar button to select the corresponding command. You can
toggle the toolbar display on and off using Toolbar command in the View menu.
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Refer to Toolbar Buttons for detailed information about the function of each
toolbar button. (See page 3-66.)

Hierarchy Display Each icon in the hierarchy display represents an element of the stream. The
hierarchy text contains a description of the associated icon.

Refer to Hierarchical Display for detailed information about the hierarchy icons.
(See page 3-7.)

Play/Record Status
Indicator

The Play Status indicator is displayed while the selected stream is being output. It
shows the output status of the selected stream: the progress of the stream output,
the output source, the operational status, and the elapsed time.

The Record Status indicator is displayed while the input stream is being recorded.
It shows the record status of the input stream: the progress of the stream record,
the record target, and the elapsed time.

The Play/Record Status indicator shows the following information:

Position Indicator. In the Play screen, this indicator shows the progress of stream
output using the duration gauge. In the Record screen, this indicator shows the
progress of stream record using the duration gauge.

The duration gauge is updated every second. If you output a stream with a
repetition rate of approximately three seconds, the gauge may not be displayed
correctly.

Output Source/Record Target. In the Play screen, this indicator shows the output
source used to output the selected stream. In the Record screen, this indicator
shows the record target that is used to record the input stream.
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One of each set of icons is displayed, depending on the selections and status. The
icons and their meanings are as follows:

The hard disk is being used for the output source or record target.

The RAM is being used for the output source or record target.

Operation Status. Shows the current operation status of the instrument.

In the Play screen, the icons and meanings are as follows:

The selected stream is being output.

The selected stream is being read
from the hard disk to the RAM.

In the Record screen, the icons and meanings are as follows:

(Red)
The captured stream is being recorded.

The stream record is stopped.

(Yellow)

The Player is waiting for a trigger event.

(Red) (Red)
A trigger event has occurred.
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The captured stream is being processed on
the hard disk.

The captured stream is being saved from the
RAM to the hard disk.

Elapsed Time

In the Play screen, this box
displays the elapsed time of the
current stream data output.
In the Record screen, this
box displays the elapsed time
since the input stream started
recording.
In the Play screen, this icon
indicates that the stream is
continuously output using the
loop method.
In the Play screen, this icon
indicates that the stream
parameters are updated.
In the Play screen, this icon
indicates that the PCR accuracy
is enabled.
In the Play screen, this icon
indicates that the Advanced
Protocol Settings is enabled and
applied to the stream.
In the Play screen, this icon
indicates that the errors are
inserted in the stream.
In the Play screen, this icon
indicates that the parametric
settings are enabled and applied
to the stream.
In the Play screen, this icon
indicates that the Stream
replication settings are enabled
and applied to the stream.

Status Bar The Option Status bar and the IP Status bar contain several indicators that display
general information about the transport stream output or record status.
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Figure 3-1: Optional status bar

Figure 3-2: IP status bar

From left to right, the Status bar shows the following information:

Standard In the Play screen, this indicator shows the standard used
to display the selected stream (MPEG2, ARIB, DVB, ATSC,
S-TMCC, M-TMCC, or Non-TS). In the Record screen,
this indicator shows the standard used to display the input
stream.

Packet Size In the Play screen, this indicator displays the packet size in
bytes (188, 204, 208 or Non-TS) of the stream output. In
the Record screen, this indicator displays the packet size
in bytes of the input stream.

Clock Source This indicator displays the source of the reference clock
(internal or external) used for the stream output.

Bit Rate In the Play screen when the SPI/ASI/310M option is
selected, this indicator shown displays the bit rate (Mbps)
of the stream output. In the Record screen, this indicator
displays the bit rate (Mbps) of the input stream.

IP Bit Rate In the Play screen when the IP interface option is selected,
this indicator shown displays the bit rate (Mbps) of the IP
stream output. The Record screen is disabled for the IP
interface option.

Number of Streams In the Play screen when the IP interface option with Stream
Replication Settings is selected, this indicator shown
displays the number of replicated streams.

RAM free space In the Play screen, this indicator shows the RAM free space
that can be used to output the selected stream. In the
Record screen, this indicator shows the RAM free space
that can be used to record the input stream.

Output Source/Record Target In the Play screen, this indicator shows the output source
used to output the selected stream. In the Record screen,
this indicator shows the record target used to record the
input stream.

This indicator is the same as the output source/record target indicator of the
Play/Record Status indicator.
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Remote Connection Status
Icons

The remote connection status icons appear when a TCP/IP connection for remote
control is established. The right icon shows the status of the TCP/IP connection
(this icon is always displayed when the TCP/IP connection is established), and the
left icon shows the lock status of the front-panel buttons and mouse input.

There are two display states:

This shows that the TCP/IP connection for
remote control is established.

This shows that the TCP/IP connection
for remote control is established and the
front-panel buttons and mouse input are
locked by the :SYSTem:KLOCk:STATe ON
command.

To reset the lock status, select the ESC key (or send the :SYSTem:KLOCk:STATe
OFF command).

When the TCP/IP connection is closed, the remote status icons disappear.

Hierarchical Display
The MPEG Player displays the selected transport stream using a hierarchical
structure. This section describes the hierarchical display and defines each icon
you may encounter in the display.

The MPEG Player uses icons displayed in a hierarchical structure to show the
interrelationship of transport stream components. (See Figure 3-3.) Additional
information about each stream component such as PID and Table ID numbers is
displayed next to each icon.
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Figure 3-3: Example of the hierarchical display

The ‘+’ symbol displayed to the left of some icons indicates that the item includes
lower-level transport stream components that are not displayed. The symbol
changes to ‘–’ when the lower level components are displayed. To expand the
hierarchy, click on the ‘+’ symbol. Similarly, to collapse the hierarchy, click on
the ‘–’ of the selected upper-level icon.

When a transport stream contains more items than displayed on the screen at a
time, a scroll bar appears at the right of the screen.

Click an element in the hierarchy to select (and highlight) it.

Hierarchical Display Icons The following table describes the icons you may encounter in the hierarchical
display of the MPEG Player for transport streams using the MPEG-2, ARIB,
DVB and ATSC formats.

Refer to Icon Text and Dialog Box for descriptions of the icon text and dialog box
associated with the hierarchy icon. (See page 3-16.)

3–8 MTS400 Series Generator Applications User Manual



MPEG Player - Getting Started

Table 3-1: Icons used for MPEG-2, ARIB, DVB, and ATSC formats
Icon Element type

ISDB-T
Broadcast transport stream that is defined ARIB
STD-B31.
S-TMCC
Transport stream into which TMCC information
is inserted into 8 bytes in its Reed-Solomon area
(16 bytes).
M-TMCC
Transport stream into which TMCC information is
inserted into its sync byte area, and having super
frame structure.
Non-TS
Data stream other than transport stream format.

Transport Stream (TS)
This icon represents all transport stream packets
that make up the stream.
Program Association Table (PAT)
One or more transport packets with a PID value
and table_id value of 0x00.
Transport Stream Description Table (TSDT)
One or more transport packets with a PID value of
0x02 and a table_id value of 0x03.
Network Information Table (NIT)
One or more transport packets with a PID value
specified by the network_PID in the PAT.
Conditional Access Table (CAT)
One or more transport packets with a PID value of
0x01 and a table_id value of 0x0001.
Program Map Table (PMT)
One or more transport packets with a PID value
specified by the program_map_PID in the PAT and
a table_id value of 0x02.
Program Clock Reference (PCR) .
One or more transport packets with a PID value
specified by the PCR_PID in the PMT and a
PCR_flag value of 1.
Video elementary stream
One or more transport packets with a PID value
specified by the elementary_PID in the PMT and a
stream_type value of 0x01, 0x02, or 0x10.
A lock symbol appears in the icon when the
transport_scrambling_control value is set to 01.
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Table 3-1: Icons used for MPEG-2, ARIB, DVB, and ATSC formats (cont.)

Icon Element type
Audio elementary stream
One or more transport packets with a PID value
specified by the elementary_PID in the PMT and a
stream_type value of 0x03, 0x04, or 0x11.
A lock symbol appears in the icon when the
transport_scrambling_control value is set to 01.
Audio AAC, Audio AC3 (ATSC format)
A lock symbol appears in the icOne or more
transport packets with a PID value specified by the
elementary_PID in the PMT and a stream_type
value of 0x0F or 0x81 (ATSC format) on when the
transport_scrambling_control value is set to 01.
Data stream
One or more transport packets with a PID value
specified by the elementary_PID in the PMT and
a stream_type value of other than 0x01 to 0x05,
0x08, and 0x0F (in ATSC format, 0x81).
A lock symbol appears in the icon when the
transport_scrambling_control value is set to 01.
Private Section
One or more transport packets with a PID value
specified by the elementary_PID in the PMT and a
stream_type value of 0x05.
A lock symbol appears in the icon when the
transport_scrambling_control value is set to 01.
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Table 3-1: Icons used for MPEG-2, ARIB, DVB, and ATSC formats (cont.)

Icon Element type
Digital Storage Media Command and Control
(DSM-CC)
One or more transport packets with a PID value
specified by the elementary_PID in the PMT and a
stream_type value of 0x08.
A lock symbol appears in the icon when the
transport_scrambling_control value is set to 01.
Entitlement Control Message (ECM)
One or more transport packets with a PID value
specified by the CA_PID of the CA_descriptor in
the PMT, a payload_start_unit_indicator value of 1,
and the payload does not start 000001 (section) or
the payload starts 000001 (PES).
Entitlement Management Message (EMM)
One or more transport packets with a PID value
specified by the CA_PID of the CA_descriptor in
the CAT, a payload_start_unit_indicator value of 1,
and the payload does not start 000001 (section) or
the payload starts 000001 (PES).
GHOST
One or more transport packets with a PID value
not specified in the PSI or Private Section PID file
when the transport stream is downloaded.
NULL
One or more transport packets with a PID value
of 0x1FFF.
GARBAGE
One or more transport packets in the section-data
structure at the beginning of the section are not
complete.
Adaptation Field Error (ADFERR)
One or more transport packets with an
adaptation_field_control value of 0x00.
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The following table describes icons that are specific to transport streams using
DVB format.

Table 3-2: Icons specific to DVB format
Icon Element type

Service Description Table (SDT)
One or more transport packets with a PID
value of 0x0011 and a table_id value of 0x42.
Bouquet Association Table (BAT)
One or more transport packets with a PID
value of 0x0011 and a table_id value of 0x4A.
Event Information Table (EIT)
One or more transport packets with a PID
value of 0x0012 and a table_id value of
0x4E-0x6F.
Running Status Table (RST)
One or more transport packets with a PID
value of 0x0013 and a table_id value of
0x4E-0x71.
Stuffing Table (ST)
One or more transport packets with a PID
value of 0x0010-0x0013 and a table_id value
of 0x72.
Discontinuity Information Table (DIT)
One or more transport packets with a PID
value of 0x1E and a table_id value of 0x7E.
Selection Information Table (SIT)
One or more transport packets with a PID
value of 0x1F and a table_id value of 0x7F.
Time and Data Table (TDT)
One or more transport packets with a PID
value of 0x0014 and a table_id value of 0x72.
Time Offset Table (TOT)
One or more transport packets with a PID
value of 0x0014 and a table_id value of 0x73.
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The following table describes icons that are specific to transport streams using
ARIB format.

Table 3-3: Icons specific to ARIB format
Icon Element type

Service Description Table (SDT)
One or more transport packets with a PID
value of 0x0011 and a table_id value of 0x42.
Bouquet Association Table (BAT)
One or more transport packets with a PID
value of 0x0011 and a table_id value of 0x4A.
Event Information Table (EIT)
One or more transport packets with a PID
value of 0x0012 and a table_id value of
0x4E-0x6F.
Running Status Table (RST)
One or more transport packets with a PID
value of 0x0013 and a table_id value of
0x4E-0x71.
Stuffing Table (ST)
One or more transport packets with a PID
value of 0x0010-0x0013 and a table_id value
of 0x72.
Discontinuity Information Table (DIT)
One or more transport packets with a PID
value of 0x1E and a table_id value of 0x7E.
Selection Information Table (SIT)
One or more transport packets with a PID
value of 0x1F and a table_id value of 0x7F.
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Table 3-3: Icons specific to ARIB format (cont.)

Icon Element type
Local event Information Table (LIT)
One or more transport packets with a PID
value of 0x0020 and a table_id value of
0xD0. One or more transport packets with a
PID value specified by the elementary_PID
in the PMT and a table_id value of 0xD0
when a stream type value is 0x05.
Event Relation Table (ERT)
One or more transport packets with a PID
value of 0x0021 and a table_id value of
0xD1. One or more transport packets with a
PID value specified by the elementary_PID
in the PMT and a table_id value of 0xD1
when a stream type value is 0x05.
Index Transmission Table (ITT)
One or more transport packets with a PID
value specified by the elementary_PID in the
PMT and a table_id value of 0xD2.
Partial Content Announcement Table (PCAT)
One or more transport packets with a PID
value of 0x22 and a table_id value of 0xC2.
Software Download Trigger Table (SDTT)
One or more transport packets with a PID
value of 0x23 and a table_id value of 0xC3.
Download Control Table (DCT)
One or more transport packets with a PID
value of 0x17 and a table_id value of 0xC0.
DownLoad Table (DLT)
One or more transport packets with a
PID value specified by the DL_PID in the
DCT and a stream_type value of 0xC1. A
lock symbol appears in the icon when the
transport_scrambling_control value is set to
01.
Broadcaster Information Table (BIT)
One or more transport packets with a PID
value of 0x24 and a table_id value of 0xC4.
Network Board Information Table (NBIT) One
or more transport packets with a PID value of
0x25 and a table_id value of 0xC5 or 0xC6.
Linked Description Table (LDT)
One or more transport packets with a PID
value of 0x25 and a table_id value of 0xC7.
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Table 3-3: Icons specific to ARIB format (cont.)

Icon Element type
Time and Data Table (TDT)
One or more transport packets with a PID
value of 0x0014 and a table_id value of 0x72.
Time Offset Table (TOT)
One or more transport packets with a PID
value of 0x0014 and a table_id value of 0x73.

The following table describes icons that are specific to transport streams using
the ATSC format.

Table 3-4: Icons specific to ATSC format
Icon Element type

Master Guide Table (MGT)
One or more transport packets with a PID
value of 0x1FFB and a table_id value of
0xC7.
Terrestrial Virtual Channel Table (TVCT)
One or more transport packets with a PID
value of 0x1FFB and a table_id value of
0xC8.
Cable Virtual Channel Table (CVCT)
One or more transport packets with a PID
value of 0x1FFB and a table_id value of
0xC9.
Rating Region Table (RRT)
One or more transport packets with a PID
value of 0x1FFB and a table_id value of
0xCA.
Event Information Table (EIT)
One or more transport packets with a PID
value specified by the table_type_PID in the
MGT and a table_id value of 0xCB.
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Table 3-4: Icons specific to ATSC format (cont.)

Icon Element type
Channel Extended Text Table (CETT)
One or more transport packets with a PID
value of 0x1FFB and a table_id value of
0xC8.
Event Extended Text Table (EETT) One or
more transport packets with a PID value of
0x1FFB and a table_id value of 0xC9.
Program Identifier Table (PIT)
One or more transport packets with a PID
value specified by the elementary_PID in the
PMT and a table_id value of 0xD0 when a
stream_type value is 0x85.
System Time Table (STT)
One or more transport packets with a PID
value of 0x1FFB and a table_id value of
0xCD.

Icon Text and Dialog Box To the right of each icon, the MPEG Player displays text that describes each
transport stream component. In addition, for the PCR icon, you can display
a dialog box to change the parameters for the component. The following
table shows the text that will be displayed with each icon.

Table 3-5: Icon text
Component Text
ISDB-T Icon "xxx.rmx": Shows the file name.

Packets: Shows the total number of packets
in the broadcast transport stream.

S-TMCC Icon "xxx.trp": Shows the file name.
TC8PSK/xx, BPSK/xx, or QPSK/xx: Shows
the modulation system and the number of
contract slots (xx).

M-TMCC Icon "xxx.trp": Shows the file name.
SF: Shows the number of super frames.

Non-TS Icon "xxx.xx": Shows the file name.
FileSize: Shows the file size in byte.
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Table 3-5: Icon text (cont.)

Component Text
Transport Stream (TS) Icon "xxx.trp": Shows the file name of the

transport stream.
Packets: Shows the total number of packets
in the transport stream.
When this icon is used with the S-TMCC or
M-TMCC icon, the following text information
is displayed:
TSID: Shows the ID number for the transport
stream.
TC8PSK/xx, BPSK/xx, or QPSK/xx: Shows
the modulation system and the number of
contract slots (xx).

Program Allocation Table (PAT) Icon PID: Shows the PID value of the PAT.
TblID: Shows the table_id value of the PAT.
TSID: Shows the transport_stream_id value
of the PAT.
Prg: Shows the number of programs
contained in the transport stream.

Transport Stream Description Table (TSDT)
Icon

PID: Shows the PID value of the TSDT.
TblID: Shows the table_id value of the TSDT.

Network Information Table (NIT) Icon PID: Shows the PID value of the NIT.
TblID: Shows the table_id value of the NIT.

Conditional Access Table (CAT) Icon PID: Shows the PID value of the CAT.
TblID: Shows the table_id value of the CAT.

Program Map Table (PMT) Icon PID: Shows the PID value of the PMT.
TblID: Shows the table_id value of the PMT.
PrgNo: Shows the program number
associated with the PMT.

Program Clock Reference (PCR) Icon PID: Shows the PID value of the PCR.
See also PCR Inaccuracy Dialog Box (See
page 3-19.)

Video Elementary Stream (VIDEO) Icon PID: Shows the PID value of the video
elementary stream.
StrmTyp: Shows the type of the video
elementary stream (0x01 or 0x02).

Audio Elementary Stream (AUDIO) Icon PID: Shows the PID value of the audio
elementary stream.
StrmTyp: Shows the type of the audio
elementary stream (0X03 or 0X04).
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Table 3-5: Icon text (cont.)

Component Text
AUDIO_AAC and AUDIO_AC3 Icons PID: Shows the PID value of the audio

elementary stream.
StrmTyp: Shows the type of the audio
elementary stream (0X0F or 0x81).

Data Stream (DATA) Icon PID: Shows the PID value of the data stream.
StrmTyp: Shows the type of the data stream.

Private Section (DATA_SECT) Icon PID: Shows the PID value of the private
section.
TblID: Shows the table_id value of the private
section.
StrmTyp: Shows the type of the private
section.

DSM_CC Icon PID: Shows the PID value of the data
DSM-CC.
StrmTyp: Shows the type of the DSM-CC.

Entitlement Control Message (ECM) Icon PID: Shows the PID value of the ECM.
TblID: Shows the table_id value of the ECM.

Entitlement Management Message (EMM)
Icon

PID: Shows the PID value of the EMM.
TblID: Shows the table_id value of the EMM.

GHOST Icon PID: Shows the PID value of the GHOST.
Adaptation Field Error (ADFERR) Icon PID: Shows the PID value of the ADFERR.
NULL Icon PID: Shows the PID value of the NULL.
GARBAGE Icon PID: Shows the PID value of the GARBAGE.
SDT, BAT, EIT, RST, ST, DIT, SIT, LIT, ERT,
ITT, PCAT, SDTT, DCT, DLT, BIT, NBIT, and
LDT Icons

PID: Shows the PID value of the SDT, BAT,
EIT, RST, ST, DIT, SIT, LIT, ERT, ITT, PCAT,
SDTT, DCT, DLT, BIT, NBIT, or LDT.
TblID: Shows the table_id value of the SDT,
BAT, EIT, RST, ST, DIT, SIT, LIT, ERT, ITT,
PCAT, SDTT, DCT, DLT, BIT, NBIT, or LDT.

TDT and TOT Icon PID: Shows the PID value of the TDT or TOT.
TblID: Shows the table_id value of the TDT
or TOT.

MGT and PIT Icons PID: Shows the PID value of the MGT or PIT.
TblID: Shows the table_id value of the MGT
or PIT.
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Table 3-5: Icon text (cont.)

Component Text
TVCT, CVCT, RRT, EIT, CETT, and EETT
Icons

PID: Shows the PID value of the TVCT,
CVCT, RRT, EIT, CETT, or EETT.
TblID: Shows the table_id value of the TVCT,
CVCT, RRT, EIT, CETT, or EETT.
TblType: Shows the table_type value of the
TVCT, CVCT, RRT, EIT, CETT, or EETT.

System Time Table (STT) Icon PID: Shows the PID value of the STT.
TblID: Shows the table_id value of the STT.

PCR Inaccuracy Dialog Box. When you right-click PCR in the hierarchical view,
the PCR Inaccuracy dialog box appears as shown (See Figure 3-4.). This dialog
box allows you to add jitter to the program_clock_reference_base value and the
program_clock_reference_extension value.

Refer to Adding Jitter to PCRs for more information. (See page 3-69.)

Figure 3-4: PCR Inaccuracy dialog box

The following table describes the PCR Inaccuracy dialog box parameters.

Table 3-6: PCR Inaccuracy dialog box parameters
Parameter Description
Pattern Selects the type of the waveform used to add jitter. You can

select Sine, Square, Triangle, Pulse, Sawtooth, Random,
or Offset.

Period Sets the period of the waveform used to add jitter. You can
set the value from 5 to 3000 packets in 1 packet steps.
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Table 3-6: PCR Inaccuracy dialog box parameters (cont.)

Parameter Description
Amplitude Sets the amplitude of the waveform used to add jitter. You

can set the value from 0/27 MHz to 135000000/27 MHz
(0 s to 5 s).

Pulse Width Sets the pulse width of the waveform used to add jitter. You
can set the value from 1 to (period - 1) packet(s) in 1 packet
steps. This Pulse Width parameter is available only when
the Pattern parameter is set to Pulse.
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Menus and Controls
This section describes the function of each selection available in the menus. This
section is divided into the following subsections:

Menus in the Play Screen describes all of the menu commands and their
features available in the Play screen.

Menus in the Record Screen describes all of the menu commands and their
features available in the Record screen.

Toolbar Buttons describes the toolbar buttons and their functions.

Menus in the Play Screen
This subsection describes the menus in the play screen.

File Menu The File menu in the play screen contains commands for selecting a stream
file and for loading and saving a preset file. The following table describes the
commands in the File menu.

Table 3-7: File menu commands (Play screen)
Command Description
Open Opens a stream file stored in the E: drive (volume E). When a

file is selected, the MPEG Player checks the packet size of the
file. For a transport stream the output data is in packets. If an
incomplete packet is included at the start or end point of the file,
that portion is not output.
The function uses a standard Windows Open… dialog box.

Load Preset Loads the specified preset file (*.set). When a preset file is
loaded, the current instrument settings are changed by the file’s
content. Refer to Preset File for more information about the
preset file. (See page 3-71.)

Save Preset Saves the current instrument settings as a preset file. Refer to
Preset File for more information about the preset file.
(See page 3-71.)

RECORD When the SPI/ASI/310M interface is selected the Play screen
switches to the Record screen. The Record screen is disabled
for IP interface.

Exit Quits the MPEG Player application. The MPEG Player application
settings are saved.
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View Menu The View menu contains commands that control the display of the Toolbar and
the Status bar. The following table describes the commands available in the
View menu.

Table 3-8: View menu commands (Play screen)
Command Description
Toolbar Shows or hides the toolbar in the Play

screen.
Status Bar Shows or hides the status bar in the Play

screen.
Compact Mode Displays the play screen at the bottom when

set to ON and the size of the play screen
becomes compact.

Play Menu The Play menu contains commands for defining output parameters, such as packet
size, output clock rate, and output source. The following table describes the
commands available in the Play menu.

Table 3-9: Play menu commands (Play screen)
Command Description
Interface Sets the interface to transmit or receive Ethernet packets. You

can select either IP or SPI/ASI/310M interfaces.
Packet Size Sets the packet size (in bytes) for the stream. You can set

the packet size to 188 (188 + 0), 204 (188 + 16), 208 (188 +
20) bytes, or Non-TS.
These packet sizes can only be set for an MPEG2 transport
stream. For an S-TMCC or an M-TMCC transport stream, the
packet size is fixed to 204. For a Non-TS stream, the packet
size is fixed to Non-TS. In addition, if you select 8VSB, the
packet size is fixed to 188.
When you select Non-TS, the MPEG Player deals with stream
data in a byte unit (not a packet unit) and outputs all of the
data in a file. If a transport stream contains any error, you can
output it by selecting Non-TS.

Clock Sets the clock rate of the stream output. When you select
this command, the Clock dialog box appears. Refer to Clock
Dialog Box for more information. (See page 3-24, Clock
Dialog Box.)

Update Sets whether to update parameters in the stream when
looped. You can select On or Off. You cannot set to On for a
Non-TS stream.
You can select which parameters in the stream are updated
using the Others dialog box. Refer to Others Dialog Box for
more information. (See page 3-65, Others Dialog Box.)
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Table 3-9: Play menu commands (Play screen) (cont.)

Command Description
Sync Sets the format of the PSYNC signal output from the SPI

IN/OUT connector. You can select TS Packet, SF, or Non-TS.
For TS Packet, a single pulse signal is output at the start
point of each packet. For SF, a single pulse is output at the
start point of the SF appearing every 204 X 48 X8 bytes. For
Non-TS, the Set Non-TS Sync dialog box appears, where you
can enable the PSYNC and DVALID signals.
Refer to Set Non-TS Sync Dialog Box for more information.
(See page 3-28, Set Non-TS Sync Dialog Box.)

PCR Initial Value Sets the initial value of the program_clock_reference_base
and program_clock_reference_extension parameters when
the transport stream is output.
When you select this command, the PCR Initial Value dialog
box appears. Refer to PCR Initial Value Dialog Box for more
information. (See page 3-29.)

Source Selects the source for stream output. You can select RAM
or Disk.
Refer to SPI/ASI/310M Interface Menu - Play and IP Interface
Menu for detailed information about differences between the
two sources. (See page 3-37.) (See page 3-37.)

Loop Sets whether or not the stream is output using looping method.
You can select On or Off. If you set it to On, the selected
stream is continuously output. If you set it to Off, the selected
stream is output once.

Start/Stop Sets the start and stop position of the stream, and initial start
position of the stream for loop output.
When you select this command, the Start/Stop Position dialog
box appears. Refer to Start/Stop Position Dialog Box for more
information. (See page 3-30.)

Auto play Sets whether or not the transport stream is automatically
output using the last power-down settings when you turn the
MPEG Player on. You can select On or Off. If you set it to On,
take care of the output level setting used when the MPEG
Player was last turned off and the input level of the instrument
(device) currently connected to the MPEG Player.

Timer Play Sets the date and time used to output a stream automatically.
When you select this command, the Timer Play/Record dialog
box appears. Refer to Timer Play/Record Dialog Box for more
information. (See page 3-32.)

Other Sets the standard used to display the selected stream and
display radix for the text information.
When you select this command, the Others dialog box
appears. Refer to Others Dialog Box for more information.
(See page 3-65.)
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Clock Dialog Box. When you select the Clock... command from the Play menu,
the Clock dialog box is displayed.

Figure 3-5: Clock dialog box for Option Interface

Figure 3-6: Clock dialog box for IP interface

Clock Source: Sets the clock that will be used as the reference for the stream
output. You can select the desired clock source from the following settings:

3–24 MTS400 Series Generator Applications User Manual



Menus and Controls

Internal uses the internal clock of the MPEG Player as the clock reference.

Ext Ref allows you to input a signal on the Reference Clock Input connector
for use as the clock reference. When you select the button to the right of the
ExtRef box, the External Reference dialog box is displayed.

Select the required option:

10 MHz: Selects a 10 MHz signal on the Reference Clock Input connector.

27 MHz: Selects a 27 MHz signal on the Reference Clock Input connector.

ISDB-T IFFT Clock: Selects a signal corresponding to the IFFT sample
clock rate (8.126984 MHz) on the Reference Clock Input connector.

Ext P Clk (external parallel clock) allows you to input a clock signal on the
Reference Clock Input connector for use as the parallel clock.

Ext S Clk (external serial clock) allows you to input a clock signal on the
Reference Clock Input connector for use as the serial clock.

Data Rate sets the clock rate for the transport stream output. You can enter
the clock rate using the following methods (the first method provides greater
clock-rate precision):

Enter values into the numerator and denominator text boxes. The MPEG
Player will then calculate the clock rate based on the ratio of the numerator
and denominator values. (See Figure 3-5.)

Enter a value into the clock rate text box. The MPEG Player will then
calculate the numerator and denominator text boxes based on the clock
rate.

NOTE. The IP data rate will be automatically calculated based on the TS data
rate available. IP Data Rate is calculated as follows:

IP Data Rate = (TS Data Rate x IP Packet Size) / Payload Size
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When you use the Ext P Clk or Ext S Clk mode, set the clock rate to the same
value as the input clock signal. Also, when you use the Ext S Clk mode, you
cannot set the value more than 32 Mbps.

IP Data Rate: Sets the clock rate for the IP packet (See Figure 3-6.). In the IP
mode, a change in the IP data rate will impact the TS data rate and a change
in the TS data rate will impact the IP data rate. The packet length changes
according to the selected protocol.

NOTE. The TS data rate will be automatically calculated based on the IP data
rate available and consequently influence the PCR/PTS/DTS update cycles. TS
Data Rate is calculated as follows:

TS Data Rate = (IP Data Rate x Payload Size) / IP Packet Size

Fixed ES Rate: Sets whether elementary stream rate is fixed. When it is
checked, the elementary stream rate is played at constant rate regardless of
the clock rate setting. If you fix the elementary stream rate, you cannot set
the output clock rate (Data Rate) less than the data rate set when the stream
file was downloaded.

When the Fixed ES Rate check box is enabled, PCR/PTS/DTS Update Method in
the Select Update Item dialog box is set to Hardware automatically (see Others
Dialog Box (See page 3-65.).
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Default Rate: Displays the default clock rate and packet size and then
changes the values. When you select this button, the following Default Clock
dialog box appears.

Figure 3-7: Default Clock Dialog box

Default Data Rate: Changes the default clock rate when the selected
stream file was downloaded.

Since the default clock rate is calculated based on the PCRs in the
downloaded stream file, the value can be different than the original clock
rate. When the elementary stream rate is fixed (refer to the Fixed ES Rate
description), the instrument refers to the default clock rate. Therefore, if
the default clock rate is different than the original clock rate, you need to
set the value to the appropriate value. If you change the value, the clock
rate value in the Data Rate dialog box is also changed.

Packet Size: Changes the default packet size when the selected stream
file is downloaded. If you change the value, the Packet Size setting in the
Play menu will also change.

Press the OK button to enable all setting changes.
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Set Non-TS Sync Dialog Box. When you select Play > Sync > Non-TS, the Set
Non-TS Sync dialog box is displayed.

Psync Enable: Sets the status of the PSYNC signal output from the SPI
IN/OUT connector.

Interval: Sets the output period of the PSYNC signal in the range of 16 to
255 bytes. This value needs to be set equal to or greater than the Width
value in the Dvalid field.

Dvalid Enable: Sets the status of the DVALID signal output from the SPI
IN/OUT connector.

Width: Sets the data width of the DVALID signal in the range of 16 to
255 bytes.

Press the OK button to enable all setting changes.
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PCR Initial Value Dialog Box. When you select the PCR Initial Value... from the
Play menu, the PCR Initial Value dialog box is displayed.

Figure 3-8: PCR Initial Value dialog box

Base Value: Sets the initial value for the program_clock_reference_base
value. You can set the value from 0 to 8589934591. The bracketed number
represents the number of bits for the program_clock_reference_base field.

Extension Value: Sets the initial value for the
program_clock_reference_extension value. You can set the value from
0 to 299. The bracketed number represents the number of bits for the
program_clock_reference_extension field.
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Start/Stop Position Dialog Box. When you select the Start/Stop... from the Play
menu, the Start/Stop Position dialog box is displayed.

Figure 3-9: Start/Stop Position dialog box

Start: Sets the start position of the stream by time (h:m:s) or the number of
packets (the number of super frames for an M-TMCC file, or the number of
bytes for a Non-TS file). Use the Format field to select the method of setting
the position.

Stop: Sets the stop position of the stream by time (h:m:s) or the number of
packets (the number of super frames for an M-TMCC file, or the number of
bytes for a Non-TS file). Use the Format field to select the method of setting
the position.

Initial: Sets the initial start position of the stream for loop output. You can
set the value by time (h:m:s) or the number of packets (the number of super
frames for an M-TMCC file, or the number of bytes for a Non-TS file). Use
the Format list box to select the method of setting the position.

Play: Shows the actual time or number of packets (the number of super
frames for an M-TMCC file, or the number of bytes for a Non-TS file) that is
calculated by the values of the Start and Stop text boxes.

Format: Specifies the method of setting the start, stop, and initial positions of
the stream. For a transport stream file, you can select Time or Packets. For
a M-TMCC file, you can select Time or SF (super frame). For a Non-TS
file, you can select Time or Bytes.
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For an ISDB-T file, the start packet is defined as the first-appearing packet
including an OFDM frame start flag after the specified start position. The stop
packet is defined as the packet at the front of the last-appearing packet including
an OFDM frame start flag before the specified stop position. At this time, if the
number of OFDM frames between the start packet and stop packet is not an even
number, the packet in the last OFDM frame becomes the stop packet.

You can set the start, stop, and initial positions by using either the slider or the
text boxes.

Using the Slider. Ensure that Packets is selected from the Format drop-down list.

1. For the start and stop positions:

a. Select the Start option button.

b. Using the mouse, drag the slider to the required start position.

c. Select the Stop option button.

This moves the slider to the right end.

d. Drag the slider to the required stop position.

e. Select the OK button to enable the values.

2. For the initial start position for loop output:

a. Enable the Initial check box. A red arrow appears on the slider.

b. Drag the red arrow to the required initial start position.

c. Select the OK button to enable the value.

Using the text boxes. Ensure that Time is selected from the Format drop-down
list.

1. Select the Start option button.

2. Enter the time in hour/minute/second format.

3. Repeat for the Stop time and the Initial Start Position time.

4. Select the OK button to enable the values.

To reset all of the settings to the values that were in effect when the dialog box
was first displayed, select the Reset button, and then press the OK button.

MTS400 Series Generator Applications User Manual 3–31



Menus and Controls

Timer Play/Record Dialog Box. When you select the Timer Play... command
from the Play menu, the Timer Play/Record dialog box is displayed.

Figure 3-10: Timer Play/Record dialog box

Start at: Sets the date and time when the stream output or record starts.

When you press the OK button after setting the date and time, the current date
and time and the set date and time are displayed. When the current date and
time coincide with the set date and time, the dialog box closes and stream output
or stream record starts automatically.

If you want to cancel the operation, select the OK button. When the dialog box
that prompts you to confirm the operation is displayed, press the OK button to
execute the operation.
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Others Dialog Box. When you select the Other command from the Play menu,
the Others dialog box is displayed.

Figure 3-11: Others dialog box

Standard: Sets the standard used on the hierarchy-display screen. You can
select ARIB, ATSC, DVB, or MPEG2. For a transport stream (ARIB, ATSC,
DVB, or MPEG2), the standard is set to the previous setting as a default.
For an S-TMCC, M-TMCC, or ISDB-T transport stream, you need to select
ARIB for proper display.

Numeric: Sets the base value used to describe the component information in
the hierarchy display. You can select Decimal, Hex, or Octal.

Ext Play Start: Sets whether or not to start stream output using a trigger
signal applied to the Trig In/Out connector. You can select Off, Rise, or Fall.
When you select Rise, the stream output is started at the rising edge of the
applied trigger signal. When you select Fall, the stream output is started at the
falling edge of the applied trigger signal.

SPI Output Enable: Sets whether the signal output from the SPI connector
is enabled or not.

TDT/TOT or STT: When you select this button, the following TDT/TOT
dialog box appears. The button name changes to the standard selected in the
Standard list box; TDT/TOT for ARIB or DVB, and STT for ATSC. Use
this dialog box to change the initial date and time of the TDT (Time and
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Data Table), TOT (Time Offset Table), or STT (System Time Table) in the
selected stream.

Figure 3-12: TDT/TOT dialog box

The button is disabled when MPEG2 is selected in the Standard list box.

Original: Uses the original (default) value that is already defined in the
selected stream.

System Time: Uses the clock/calendar of the operating system to set
the initial value. When you select this option, the date and time of
all the TDTs, TOTs, or STTs in the selected stream are locked to the
clock/calendar of the operating system.

User Defined: Uses the user-defined value to set the initial value. When
you select this option, the list boxes for setting the initial date and time of
the TDT, TOT, or STT are available.
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ISDB/P-TS:When you select this button, the following ISDB/P-TS dialog
box appears.

Figure 3-13: ISDB/P-TS dialog box

Data Rate Auto Convert (Play Mode): Sets whether to set the clock
rate automatically when the ISDB-Tsb file is loaded. When this option
is enabled, the clock rate is automatically set to (2048/1701) x 27 MHz
and the elementary stream rate becomes constant, regardless of the Fixed
ES Rate setting.

Loop by ISDB-T Frame (Play Mode): Sets whether to output the
ISDB-T transport stream in OFDM frames when looped. When this
option is not enabled, the ISDB-T transport stream is looped in packets.

Treat as Partial TS (Play Mode): Sets whether to output a stream file
consisting of a 192-byte packet as a partial transport stream. When this
option is not enabled, the stream is output in Non-TS format.
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Update: When you select this button, the following Select Update Item dialog
box appears. Use this dialog box to select which parameters in a stream are
updated when looped.

Figure 3-14: Select Update Item dialog box

Continuity Counter: Sets whether to update continuity_counter.

PCR/PTS/DTS: Sets whether to update PCR (Program Clock Reference),
PTS (Presentation Time Stamp), and DTS (Decoding Time-Stamp).

Update Method: Specifies the method to update PCR/PTS/DTS. The
SPI/ASI/310M interface supports both Software and Hardware update
methods but the IP interface supports only the Software method.

Hardware: PCR/PTS/DTS are updated using the counter values of the
27 MHz clock on the output board. Since data output and PCRs are
completely locked, the continuity of PCRs is maintained at the loop point
even when playing long stream loops. However, timing errors occur in
PTS/DTS.

Software: PCR/PTS/DTS are updated by adding the actual looping time
(defined by the start and stop positions) to the stream every time it is
looped. There are no timing errors in PTS/DTS, however, it is difficult to
maintain the continuity of PCRs at the loop point because the update is
not synchronized with the 27 MHz clock on the output board. Since this
method is used to update NPT, if you enable the NPT option, Software is
selected automatically.

TDT/TOT/STT: Sets whether to update TDT (Time & Data Table), TOT
(Time Offset Table), and STT (System Time Table).

NPT: Sets whether to update NPT (Normal Play Time; STC_Reference
field in NPT Reference Descriptor defined by ISO/IEC 18318-6).

The NPT check box is available only when PCR/PTS/DTS is enabled
and Update Method is set to Software. When the check box is enabled,
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PCR/PTS/DTS becomes enabled and Update Method is set to Software.
In addition, the Fixed ES Rate option in the Clock dialog box becomes
disabled.

Reed Solomon (ISDB-T only): Sets whether to update Reed-Solomon
codes in an ISDB-T transport stream.

Select the OK button to enable all setting changes.

SPI/ASI/310M Interface
Menu - Play

The following table describes the commands available in the SPI/ASI/310Mmenu.

Table 3-10: SPI/ASI/310M menu commands (Play screen)
Command Description
BNC Port Sets the format of the output signal at the ASI/SMPTE Out

connector: ASI, 310M 8VSB.
Through Out Sets whether the signal supplied to the ASI/SMPTE In

connector is looped back to the ASI/SMPTE Out connector
when there is no recording or playout selected.

ASI Format Selects either Byte or Packet when an ASI output is
selected at the BNC Port. For Byte, valid data is output
using a burst transmission mode. For Packet, valid data is
output in each transport stream packet.

IP Interface Menu - Play The following table describes the commands available in the IP menu.

Table 3-11: IP menu commands
Command Description
Configuration Configures the IP interface. The packet size, device

name, protocol, ports, and the transmission mode can
be set.

Parametric Settings Sets the burst mode parameters and jitter parameters.
Error Insertion Inserts errors like packet loss, checksum, and sequence

errors in the transmitted stream.
Error Generation Generates errors like packet loss, checksum, and

sequence in the transmitted stream.
Statistics Displays details about parameter names, current stream

values, and the history of the previous transmission.
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Table 3-11: IP menu commands (cont.)

Command Description
TTS Settings Enables whether to play out a TS file as a TTS file by

prefixing a 4-byte time stamp to each TS packet.
Other Settings Sets the player process priority and transmitter thread

priority.

NOTE. Playing the MPEG Player at high bit rates in IP mode could saturate
the network.

NOTE. When you switch from SPI/ASI/310M interface to IP interface, the
Recommended settings dialog box appears. This dialog box has an Auto
Configure button to configure all the settings automatically in the IP mode.

Configuration. When you select Configuration from the IP menu, the IP Playout
Configuration dialog box is displayed as shown in the following figure. This
dialog box allows you to configure the following settings:

Figure 3-15: IP Configuration for IPv4
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Figure 3-16: IP Configuration for IPv6

Configuration name: Allows you to enter or select a configuration name
from the drop-down list. This list can store up to ten configuration names.
The default value is blank.

IP Version: Allows you to choose the IP version (IPv4 or IPv6) from the
drop-down list. IPv4 is the default value.

Protocol: Sets the protocol (UDP, RTP) for the IP playout. RTP is set as
the default value.

Device Name: Allows you to select the device for the IP playout. The
Device Name lists all the active Network Interface Cards (NIC) in the system.
The first interface that has a valid IP address assigned to it is automatically
selected as the default value for both IPv4 and IPv6 versions.

Source IP Address: Sets the source IP address for the IP playout. The first
valid IP address of the selected device will be set as the default. The Source
IP Address can be modified in the Advanced Protocol Settings dialog. If the
Source IP Address is modified in the Advanced Protocol Settings dialog, then
this value is changed to "Customized".

Source Port: Sets the source port for the IP playout. The port value ranges
from 0 to 65535. The default value for UDP protocol is 0 and for RTP
protocol is 16384.
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Transmission Mode: Sets the transmission mode of the protocol. Unicast,
Multicast, and Broadcast are the three transmission modes available in the
drop-down list. Multicast is set as the default value.

NOTE. In Unicast mode, the MPEG Player will auto detect the MAC address
for the destination IP Address. Hence, a valid destination IP address must be
provided for the MPEG Player. If the MAC address cannot be detected, the
destination IP address must be specified in the Advanced Protocol Settings.

Destination IP Address: Sets the destination IP address for the IP playout.
239.1.1.1 is set as the default value for IPv4 and ff0e::1 is set as the default
value for IPv6. Depending on the selected transmission mode, the system
validates the entry based on the following rules:

Unicast Range: Any IP address that does not fall into the Multicast or
the Broadcast range.

Multicast Range: 224.0.0.0 to 239.255.255.255 for IPv4 and FFxx:Y:Y:Y
(where x is 0 to F and Y is 0000 to FFFF) for IPv6.

Broadcast Range: The Network or node portion of an IP address will
be set to "1"s or "0"s.

Destination Port: Sets the destination port for the IP playout. The port value
ranges from 0 to 65535. 16384 is set as the default value.

Enable VLAN: Enables the VLAN layer that is present between the Ethernet
layer and IP layer. You will have to enter the VLAN ID to allow the
identification of 4096 VLANs that is basically used by the 802.1Q standard.

Advanced Protocol Settings: Click Advanced Protocol Settings to
view or customize the protocol settings of active protocols in the current
configuration. All the settings have only header customization for which
no validation is done.
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Figure 3-17: Advanced Protocol Settings dialog box for IPv4

Figure 3-18: Advanced Protocol Settings dialog box for IPv6

The Header Name and Default Value are read only options. The protocol
headers displayed will be limited to headers common to all packets. You
can customize the Current Value of the headers which can be specified at
packet creation. The customized valid values are displayed in lavender and
the customized invalid values are displayed in pink.

Click the Reset to Defaults button to reset the current values to default
values. Whenever any of the attributes is set, an icon is displayed in the status
bar during the play.
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The parameters displayed in the Advanced Protocol Settings dialog box are as
follows:

Ethernet Layer: Destination Mac Address, Source Mac Address, Protocol

802.1Q VLAN Layer: Tag Protocol Identifier, Priority Levels, Canonical
Format Indicator, VLAN Identifier

IPv4 Layer: Version (read only), Header Length (read only), Type Of Service,
Total Length (read only), Time To Live, Protocol, Source IP Address,
Destination IP Address

IPv6 Layer: Version (read only), Traffic Class, Flow Label, Payload Length
(read only), Next Header, Hop Limit, Source IP Address, Destination IP
Address

UDP Layer: Source Port, Destination Port, Length (read only)

RTP Layer: Version (read only), Payload Type, Sequence Number, SSRC

NOTE. A condition where multicast is selected as the transmission mode and a
unicast destination address is entered in the Advanced Protocol Settings dialog
box will not be validated.

NOTE. If the destination IP address is changed in the Advanced Protocol Settings
dialog box, the application will not check for the accessibility of the address. A
change in the source and the destination IP address will not change the source
and the destination MAC address of the Advanced Screen Settings.

Stream Replication Settings: Click Stream Replication Settings to set the
number of replicated streams and customize the attributes accordingly. This
setting is used to replicate the streams wherein a stream is replicated n times
with certain attributes of the stream incremented by a value within the ’n’
replicated streams. The customized valid values are displayed in lavender and
customized invalid values are displayed in pink.

You can enter the number of replications in the Number of replicated streams
text box. The table lists the attributes which can be incremented by entering a
number in the Increment Value column. All attributes except for MACs and
IP addresses will accept an integer.
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Figure 3-19: Stream Replication Settings for IPv4

Figure 3-20: Stream Replication Settings for IPv6

You can click Reset to Defaults to reset the increment values to default
values. Whenever the stream replication is active, an icon is displayed in
the status bar during the play.
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Allow TS Fragmentation: Controls the fragmentation of the transport stream
packets. If this option is selected, the transport stream packets will be split
across the IP packets else all the transport stream packets will be present
in the IP packet. By default, this is cleared. The IP Packet size option
will be enabled only if Allow TS Fragmentation option is selected. The
Number of TS packets option will be enabled irrespective of the Allow TS
Fragmentation option being enabled.

Allow IP Fragmentation: Controls the fragmentation of IP packets. This
option is applicable to packet sizes which are greater than the MTU size of
the interface (typically 1500B). If this option is selected, the IP packets are
fragmented else they will be retained with the same size. By default this
option is cleared. The maximum packet size is 16128 when IP fragmentation
is selected. This option is available only in IPv4 version.

IP Packet Size: Allows you to set the size of IP packet. This option is enabled
only if TS fragmentation is allowed. When IP fragmentation is enabled, the
maximum size of IP packet for IPv6 version is 16128 bytes and for IPv4
version is 1500 bytes.

The IP packet size includes the headers. The payload size is calculated at runtime
using the following equation:

IP Packet Size = Payload Size + Header Size

For IPv4 version, the header size is 54 (58 with VLAN enabled) for RTP and 42
(46 with VLAN enabled) for UDP. For IPv6 version, the header size is 74 (78 with
VLAN enabled) for RTP and 62 (66 with VLAN enabled) for UDP.

Number of TS Packets: Allows you to type the number (integer) of TS
packets that needs to be embedded into an IP packet.

The maximum IP packet size is 1500 bytes or equivalent to TS packets.

A read only text field showing the IP packet size is displayed next to this
option. The IP packet size will be calculated automatically and displayed in
bytes. Based on the number of TS packets, the IP packet size is calculated
using the following equation:

IP Packet Size = Payload Size + Header Size

where payload size is calculated as follows:

Paylaod Size = Number of TS Packets x TS Packet Size

Store Settings: Stores or updates the entire configuration settings including
the Advanced Protocol Settings. All these settings will be listed out in the
Configuration Name drop-down list.

Delete Settings: Deletes the selected configuration setting that is displayed in
the Configuration Name drop-down list and selects the next configuration in
the list. If there are no more configurations stored in the list, the values in the
configuration dialog box will be reset to the default values.
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Clear Settings: Clears the selected configuration setting including the
Advanced Protocol Settings and resets them to the default values.

802.1Q VLAN Layer: Tag Protocol Identifier, Priority Levels, Canonical
Format Indicator, and VLAN Identifier

Parametric Settings. When you select Parametric Settings from the IP menu, the
Parametric Settings dialog box is displayed as shown in the following figure.

Burst Mode: Allows you to transmit the player thread in the form of bursts.
Burst mode is not selected by default.

Burst Period: You can set the time during which the packets will be
transmitted in the burst mode. Burst period is selected by default.

Burst Size: You can set the burst size which determines the number of
packets being transmitted in every burst.
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Jitter: Inserts jitter during IP playout.

Lower Jitter Mode: When Lower Jitter Mode is enabled, the Statistics
and the Error Generation options are disabled in the IP menu.

Jitter Distribution: There are four types of Jitter Distribution namely
Fixed, Laplacian, Gaussian, and Sinusoidal. Fixed is the default jitter
distribution. When Fixed is selected, a Duration text box is displayed
where you can enter the jitter in microseconds. When Jitter Distribution
other than Fixed is selected, a slider is displayed where you can set the
jitter as percentage of the interpacket time by moving the slider. The
interpacket gap will follow the selected jitter distribution. The overall bit
rate of the playout is not affected by jitter insertion.
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Error Insertion. When you select Error Insertion from the IP menu, the Error
Insertion dialog box is displayed as shown in the following figure. This dialog box
allows you to insert errors during playout. For Non-TS playout, Error Insertion is
limited to packet drop and checksum errors.

Figure 3-21: Error Insertion dialog box

Enable Error Insertion: Enables error insertion. All error insertions are
specified as X errors per Y packets except for jitter. You can have error
insertion in sequential or random order.

Sequential: The errors are inserted in sequential packets; that is, for every
Y packets the first X packets have errors inserted in them.

Random: The errors are inserted in random packets; that is, for every Y
packets X random packets have errors inserted in them. Random mode
is set as the default.

Packet Loss: Inserts packet loss. The packets are dropped at a frequency you
specify. You can specify the rate as X packets within Y packets.

Checksum Error: Inserts checksum error. The checksum error can be
inserted in UDP layer of both IPv4 and IPv6 versions and in the IP layer of
IPv4 version. The CRC errors are generated in packets at a frequency you
specify. You can specify the rate as X packets within Y packets.

Sequence Error: Inserts packet sequence error. This option is enabled only
if RTP protocol is selected in the IP configuration Playout dialog box. The
packets will be reordered at the frequency specified in the Packets text box.
You can enter the number of packets after which you want the reordering to
happen in the Packets Apart text box. You can specify the rate as X packets
per Y packets after every Z number of packets.
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Error Generation. When you select Error Generation from the IP menu, the
Error Generation dialog box is displayed as shown in the following figure. This
dialog box allows you to insert errors manually.

Generate Packet Loss: Drops an IP packet during the IP playout. The number
of packets dropped will be equal to the number of times you click the button.

Generate Sequence Error: Generates sequence error manually. When you
click this button the packet will be resequenced with another packet within a
100-packet boundary.

Generate IP Checksum Error: Generates checksum errors manually in the
IP layer. This option is available in IPv4 version.

Generate UDP Checksum Error: Generates checksum errors manually
in the UDP layer.
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Statistics. When you select Statistics from the IP menu, the Statistics dialog
box is displayed. The player displays the current and historic statistics of IP
parameters, TS parameters, and Errors. These will be retained until the start of
next play or until a new file is opened. This option is not available when Low
Jitter Mode is enabled.
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Current: Displays the instantaneous statistics of parameters at that time.
Once the play is started, this dialog box is refreshed at the rate of every second.

IP Parameters: The current bit rate, percentage variation of this current
bit rate from the nominal (set) bit rate, number of IP packets transmitted,
and the IP packet size used for playout are all displayed. The jitter value
which reflects the insertions done at runtime is also displayed.

TS Parameters: The TS bit rate of the MPEG file being played is
displayed. The number of TS packets and the TS packet size is also
displayed. If the player is in the Non-TS mode, then all the statistics will
display Non-TS playout.

Errors: Number of packets dropped, packet loss rate, sequential errors,
and checksum errors for both IP and UDP are all displayed.

Value (per stream): When stream replication is enabled, the Current tab
displays the Value column. This column gives the value of each parameter
per stream.

Total Value (in n streams: When stream replication is enabled, the
Current tab displays the Total Value column. This column gives the total
value of each parameter for the set number of streams. Here n streams is
equal to the sum of the replicated streams and the actual stream.

Historic: Displays the minimum, maximum, and average values of parameters
(IP, TS) for the current play. When stream replication is enabled, the History
tab signifies that the statistics displayed is per flow.

IP Parameters: The current bit rate, percentage variation of this current
bit rate from the nominal (set) bit rate, and the jitter value are displayed.

TS Parameters: The bit rate and the percentage variation from this bit
rate are displayed.

Timestamped TS Playout Settings. When you select TTS Settings from the IP
menu, the TTS Settings dialog box is displayed. The TTS Settings option is only
supported by the IP mode.

When TTS is enabled, each packet (188 bytes) of TS file is prefixed by a 4-byte
time stamp and converted into a TTS stream. If the TS packet size is more than
188 bytes (192, 204, 208), the extra bytes following the 188th byte are truncated
and 4-bytes of time stamp will be transmitted along with it. For a partial TS
file with the TTS settings selected (with Preserve timestamp not selected), the
submenus namely the Update mode, Clock dialog box, and the PCR initial value
of the Play menu are all enabled.
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Preserve timestamps if the file already has them: By selecting this option,
you can preserve the time stamps of the TTS file if it already exists or add
4-bytes of time stamp to the TS packet.

Enable TTS Jitter: By selecting this option, you can insert jitter to the time
stamps that gets appended to the TS packets.

Pattern: You can select the distribution of jitter that is inserted to time
stamp from the Pattern list. The various patterns listed are Sine, Pulse,
Triangle, Square, Saw, Random, and Offset. Sine is set as the default
pattern.

Period: You can set the period for the time stamp as number of packets.
Based on the selected pattern, the Period text box is enabled or disabled.
100 packets is set as default period value.

Amplitude: You can enter the amplitude of the time stamp in the
Amplitude text box. Based on the selected pattern the Amplitude text box
is enabled or disabled. 0.00 ns is set as the default amplitude.

Pulse Width: You can set the pulse width as the number of packets.
Based on the selected pattern, the Pulse width is enabled or disabled. 50
packets is the default pulse width.

In the TTS mode, the Packet size option of the Play menu is disabled with 188
bytes selected. When the TTS mode is selected, the status bar displays TTS mode
as the standard with 192 packet size.

The displayed IP bit rate changes because there will be four extra bytes added
to each TS packet. When TTS Playout settings is enabled, the packet size in
the Statistics screen displays the actual packet size (188 bytes) with the four
time-stamped bytes.

Other Settings. When you select Other Settings from the IP menu, the Other
Settings dialog box is displayed. The Others Settings dialog box allows you to set
the priority of the player process and the transmitter thread. As a result, you can
increase or decrease the accuracy of the interpacket gaps during playout.

The Other Settings dialog box allows you to set the following parameters:

Player: You can set the process priority for the player. The priorities are
Real Time, Normal, Above Normal, and Highest. Above Normal is set as
the default.

Transmitter: You can set the priority for the transmitter thread. The priorities
are Idle, Below Normal, Normal, Above Normal, Highest, and Real Time.
Real Time is set as the default.
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Recommended Settings
for MPEG Player in IP Mode

This section lists the recommended settings that are required to improve the
performance of the MPEG player in IP mode.

Settings for Intel(R) Pro/1000 MT Drivers. Perform the following steps to set the
options for Intel/Pro 1000 MT drivers.

1. Click Control Panel > Network and Internet Connections > Network
Connections in Category view or click Control Panel > Network
Connections in Classic view.

2. Select Intel(R) Pro/1000 MT Network Connection device and right-click to
select the Properties option.

3. Click Configure > Advanced to set the following options in the dialog box:

Adaptive Inter-Frame Spacing: Disabled

Flow Control: Off

Interrupt Moderation Rate: Off

Jumbo Frames: 16128

Link Speed and Duplex: Auto-negotiate 1000Mbps

Receive Descriptors: 2048
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Settings for Playout Performance. Perform the following steps to set the options
of Administrative tools for improved performance during the Playout:

1. Click Control Panel > Administrative Tools > Services in Classic view.

2. SelectWindows Firewall/Internet Connection Sharing (ICS) to open the
dialog box. Stop the service and select Disabled from the Startup type list
to disable the startup.

Figure 3-22: Windows Firewall/Internet Connection Sharing (ICS)
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3. Select Automatic Updates to open the dialog box. Stop the service and select
Disabled from the Startup type list to disable the startup.

Figure 3-23: Automatic Updates Properties
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4. Select IIS admin to open the dialog box. Stop the service and select Disabled
from the Startup type list to disable the startup.

Figure 3-24: IIS Admin Properties
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Settings for Java Update Perform the following steps to disable automatic Java updates:

1. Click Control Panel > Java.

2. Select the Update tab and clear the Check for Updates Automatically check
box.

Figure 3-25: Java Control Panel

A Java warning message is displayed. Click Never Check.

Figure 3-26: Java Update-Warning
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Settings for VLAN. Perform the following steps to set the options for VLAN:

1. Click Start > Run and type regedit. Press OK to display the Registry Editor
Window.

2. Browse to HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\
Control\Class\{4D36E972–E325–11CE-BFC1–08002BE10318}\00XX
where XX is the instance of the network adapter that you need to see tags
on. You can check by opening and viewing the driver descriptor value
(DriverDesc value should be Intel(R) PRO/1000 MT Network Connection).

Figure 3-27: Registry Editor

3. Right-click to select New > DWORD Value or select Edit > DWORD Value
option. Rename the option to MonitorModeEnabled.
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4. Double-click the DWORD Value to open the Edit DWORD Value dialog box.
Set the Value data to 1 and click OK.

Figure 3-28: Edit DWORD Value

NOTE. Restart the MPEG application to view the changes.

Utility Menu The following table describes the commands in the Utility menu.

Table 3-12: Utility menu commands
Command Description
Communication… Sets the port number that is needed to

remotely control the MPEG Player over an
Ethernet network and the terminator that is
used to communicate with a controller.
When you select this command, the
Communication dialog box appears. Refer
to Communications Dialog Box for more
information. (See page 3-59.)

About… Displays general system information
including the software and hardware
versions.
When you select this command, the About
dialog box appears. Refer to About Dialog
Box for more information. (See page 3-60.)

3–58 MTS400 Series Generator Applications User Manual



Menus and Controls

Communication Dialog Box. When you select the Communication command from
the Utility menu, the Communication dialog box is displayed.

Figure 3-29: Communication dialog box

Port Number: Sets the port number needed to remotely control the MPEG
Player over an Ethernet network. You can set a value from 1024 to 65535.

Terminator

Tx: Selects the terminator that is used when the MPEG Player sends
information to a controller. You can select LF (linefeed), CR (carriage
return), CRLF (carriage return and linefeed), or LFCR (linefeed and
carriage return).

Rx: Selects the terminator that is used when the MPEG Player receives
commands from a controller. You can select LF (linefeed) or CR (carriage
return).

Select the OK button to enable all setting changes.
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About Dialog Box. When you select the About... command from the Utility
menu, the About dialog box is displayed.

This dialog box shows the version of the MPEG Player application and hardware
version of the main and installed interface modules - your versions may differ.

Menus in the Record Screen
This subsection describes the menus available in the Record screen.

NOTE. The IP interface mode does not support the Record functionality.
Therefore, the Record option is disabled for IP.
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File Menu The File menu in the Record screen contains commands for setting the save mode
and for saving and loading a preset file.

Table 3-13: File menu commands (Record screen)
Component Text
Save Specifies the file name used when you save a

stream data. When you select this command,
the Save as dialog box appears. By default,
the current data (yymmdd) is used as a file
name.

Save Mode Sets the save mode when you save stream
data. You can select Over Write or New File.
In the Over Write mode, the existing file is
over written by the new file with the name
specified in the Save command whenever you
save a stream data. In the New File mode,
a new file is created whenever you save a
stream file. The file name is the following:
the name specified by the Save commands +
# (1,2,3,4...).

Load Preset Loads the specified preset file (*.set). When
a preset file is loaded, the current instrument
settings are changed by the file’s content.
Refer to Preset File for more information
about the preset file. (See page 3-71.)

Save Preset Saves the current instrument settings as a
preset file. Refer to Preset File for more
information about the preset file.
(See page 3-71.)

PLAY Switches to the Play screen.
Exit Quits the MPEG Player application. The

MPEG Player application settings are saved.

View Menu The View menu contains commands that control the display of the Toolbar and
Status bar. The View menu in the Record screen is the same as that in the Play
screen. Refer to for the commands available in the View menu. (See Table 3-8.)

Record Menu The Record menu contains commands for setting the input interface, record size,
trigger position, and target source. The following table describes the commands in
the Record menu.
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Table 3-14: Record menu commands
Command Description
Source Sets the interface used to input a stream data. You

can select SPI (DVB SPI connector) or SPI/ASI/310M
(ASI/SMPTE In BNC connector).

Target… Sets the record size, trigger position, and target source
to record the input stream.
When you select this command, the Target dialog box
appears. Refer to Target Dialog Box (See page 3-63.)
for more information.

Timer Record… Sets the time used to record the input stream
automatically.
When you select this command, the Timer Play/Record
dialog box appears. Refer to Timer Play/Record Dialog
Box (See page 3-32.) for more information.

Other… Sets the standard used to display the input stream and
the external trigger status.
When you select this command, the Others dialog box
appears. Refer to Others Dialog Box (See page 3-65.)
for more information.
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Target Dialog Box. When you select the Target command from the Record menu,
the Target dialog box is displayed.

Target: Sets the record target - RAM or hard disk.

Record Size: Sets the recording time (h:m:s) or file size (MB) to record the
input stream. Use the Format list box to set the record size.

The amount of free space available for the RAM or hard disk is displayed
below the data size text box. You cannot set the record size beyond this value.

Disable the Limit record size check box to record the input stream to the full
free space in the hard disk or RAM. When the Limit record size check box
is enabled, the size (in MB) or the available recording time and data size are
automatically set. In addition, when the check box is enabled, the Continuous
Recording check box becomes disabled.

NOTE. When you set the pretrigger portion, the same free space as the record
size is required.

There is a list box in the Record Size field to select which record target (RAM
or hard disk) is used to record the input stream.
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Trigger Position: Sets the trigger position used to record the input stream.
You can set the trigger position by a time (h:m:s) or file size (MB).

Continuous Recording: Sets whether to enable Continuous Recording. With
Continuous Recording, you can record multiple stream files continuously
on the hard disk.

When the check box is enabled, the spin box (at the right side of the check
box) becomes available. Use the spin box to set the number of files to create
before stopping Continuous Recording. After the specified number of files
are created, stream capture stops automatically. You can set the value from
2 to 32767.

When this option is selected, the Without Limit check box becomes disabled.

Refer to Using the Continuous Recording Feature for detailed information
about Continuous Recording. (See page 3-72.)

Ignore Dvalid: Sets whether the MPEG Player ignores the DVALID signal
from the selected interface when stream data is acquired. When it is checked,
the MPEG Player ignores the DVALID signal, and stream data is acquired
according to the internal clock signal. This option is not available for the
ASI interface option.

Format: Specifies the way to set the record size and trigger position. You
can select Time or File Size.

Select the OK button to enable all the settings and to close the dialog box.
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Others Dialog Box. When you select the Other... command from the Record
menu, the Others dialog box is displayed.

Standard: Sets the standard used to display the input stream. You can select
ARIB, ATSC, DVB, or MPEG2.

Numeric: Sets the base value used to describe the component information in
the hierarchy display. You can select Decimal, Hex, or Octal.

Ext Record Start: Sets whether or not to start input stream record using a
trigger signal applied to the TRIG IN connector. You can select Off, Rise, or
Fall. When you select Rise, the input stream record is started at the rising
edge of the applied trigger signal. When you select Fall, the input stream
record is started at the falling edge of the applied trigger signal.

When you use the external trigger signal to record the input stream, if the
pretrigger portion is defined, the MPEG Player acquires pretrigger data when
a valid trigger signal occurs and then waits for a trigger. When a valid trigger
signal occurs again, the MPEG Player acquires posttrigger data and then
creates a stream file.

SPI Output Enable: This item cannot be accessed from the Record screen.

Select the OK button to enable all setting changes.
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SPI/ASI/310M Interface
Menu - Record

Table 3-15: SPI/ASI/310M menu command (Record screen)
Command Description
Input Port Selects either DVB/SPI In (SPI) or ASI/SMPTE In (BNC )

connector for recording input.
BNC Port Selects either ASI or 310M (SMPTE 310) as BNC input.

Utility Menu The Utility menu contains commands for displaying the system information such
as software and hardware versions. The Utility menu in the Record screen is the
same as that of the Play screen. (See Table 3-12.)

Toolbar Buttons
The toolbar provides shortcut buttons for many of the most often used menu
commands. Click a toolbar button to select the corresponding command.

The following table shows the toolbar buttons and their functions.

Table 3-16: Toolbar button descriptions
Icon Name Function

LOAD TS file Opens the Select File
dialog box. Equivalent
to the Open command
in the File menu. This
button is available
when the Play screen
is displayed.

SAVE TS file Opens the Save as
dialog box. Equivalent
to the Save command
in the File menu. This
button is available
when the Record
screen is displayed.

Load Preset Opens the Open
dialog box. Equivalent
to the Load Preset
command in the File
menu.
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Table 3-16: Toolbar button descriptions (cont.)

Icon Name Function
Save Preset Opens the Save as

dialog box. Equivalent
to the Save Preset
command in the File
menu.

Play Outputs the selected
stream. Equivalent to
the PLAY button on
the front panel.

Record Records the acquired
stream. Equivalent to
the RECORD button
on the front panel.

Stop Stops the stream
output or stream
record. Equivalent to
the STOP button on
the front panel.

Clock Opens the Clock
dialog box. Equivalent
to the Clock command
in the Play menu. This
button is available
when the Play screen
is displayed.

Target Opens the Target
dialog box. Equivalent
to the Target
command in the
Record menu. This
button is available
when the Record
screen is displayed.
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This section contains information about the following MPEG Player features:

Outputting streams

Adding jitter to PCRs

Using Preset files

Using the Continuous Recording Feature

Remote control

Interface Card (SPI/ASI/310M Option)
Refer to the MTS400 Technical Reference Manual for detailed specifications of
the interface card connectors.

About the Data Output
Source

When you output the selected stream data, you can select either the hard disk or
the RAM as an output source. This subsection describes the operation of the
MPEG Player when each output source is selected.

RAM. When you select the RAM as an output source, the MPEG Player performs
the following:

When data output rate is less than or equal to 120 Mbps, the MPEG Player
outputs the first stream data while transferring the data from the hard disk
to the RAM and then continuously outputs the data from the RAM using
looping methods.

When data output rate is more than 120 Mbps, the MPEG Player continuously
outputs a stream data from the RAM using looping methods after the data is
completely transferred from the hard disk to the RAM.

If you select RAM as an output source, you cannot output data in excess of the
RAM free space for data output. This RAM free space is displayed on the status
bar.

Hard Disk. If you select the hard disk (Disk) as an output source, the MPEG
Player always outputs the selected stream data from the hard disk regardless of the
data output rate. When the reading speed of the hard disk cannot overtake the data
output rate, the error message "Error: Output Buffer Empty" appears.

Use the Source command in the Play menu to select the output source. (See
page 3-22.) You can see the currently selected output source in the status bar.
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Adding Jitter to PCRs
The MPEG Player provides the capability to add jitter to PCRs (Program Clock
References). Adding jitter to PCRs allows you to simulate transmission delay
variations and to test the robustness of decoders under various conditions.

The jitter function adds jitter to the program_clock_reference_base value and the
program_clock_reference_extension value in the adaptation field of transport
stream packets. You can use this function to modulate the data values of the
PCRs away from their correct values.

Adding Jitter Perform the following procedure to add jitter to PCRs:

1. Select a PCR element in the hierarchy display and select PCR Accuracy
Variation... from the right-click menu.

Figure 3-30: PCR Inaccuracy dialog box

2. The PCR Inaccuracy dialog box lets you set how the parameters for how
jitter will be added to the PCR.

Pattern: Selects the type of the waveform used to add jitter. You can
select Sine, Square, Triangle, Pulse, Sawtooth, Random, or Offset.

Period: Sets the period of the waveform used to add jitter. You can set the
value from 5 to 3000 packets in 1 packet steps.

Amplitude: Sets the amplitude of the waveform used to add jitter. You
can set the value from 0/27 MHz to 135000000/27 MHz (0 s to 5 s).

Pulse Width: Sets the pulse width of the waveform used to add jitter.
You can set the value from 1 to (period–1) packet(s) in 1 packet steps.
This Pulse Width parameter is available only when the Pattern parameter
is set to Pulse.
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3. After you have set the parameters, press the Apply button to enable the jitter
function.

Note that the PCR icon in the hierarchy display changes.

To disable the jitter function, open the PCR Inaccuracy dialog box and select the
Undo button. Note that the PCR icon in the hierarchy display changes.

The following figure shows the relationship among the parameters
and how the PCR values (program_clock_reference_base value and
program_clock_reference_extension) change when Sine is selected as a
jitter-pattern waveform. The PCR values vary by the value of sine waveform
defined by the amplitude and period. The PCR period does not change.
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Using Preset Files
You can save the instrument settings that you defined as a preset file, so that
you can later restore those settings. The preset files are stored in XML format
for your convenience.

Contents of the Preset File Preset files can be created for the Play and the Record screens.

In the Play screen, you can save settings for stream output. All of the
parameter settings available in the Play menu are saved as a preset.

In the Record screen, you can save settings for stream record. All of the
parameter settings available in the Record menu are saved as a preset.

Saving a Preset File Use this procedure to save the current instrument settings as a preset file.

Perform the following steps to save a preset file:

1. Make the required instrument settings.

2. Select File > Save Preset. The Save As dialog box is displayed. In the File
name text box, the following default file names are created:

Play Screen: A two-digit serial number is added to the selected file name
(for example, if the selected file name is "Test_TS", the default file name
becomes "Test_TS00").

Record Screen: A two-digit serial number is added to the name "Preset";
for example "Preset01.xml".

You can change the file name as required.

3. Select OK to save the instrument settings as a preset file.

Loading a Preset File Perform the following steps to load an instrument setup from a preset file.

1. Select File > Load Preset. The Open dialog box is displayed.

2. Select the required file.

3. Press OK to load the preset file into the MPEG Player.
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Using the Continuous Recording Feature
The Continuous Recording feature allows you to record multiple stream files
continuously on the hard disk.

Continuous Recording has the following features:

Record multiple stream files continuously on the hard disk

Variable file size operation

The time stamp information of the first trigger event in a file is recorded as
the updated date property of the file

Can be used in disk recording mode

Basic Action of Continuous
Recording

This section describes how files are recorded by the location of the trigger events
in Continuous Recording.

The following explanation requires that both pretrigger and posttrigger sizes to
be set to 500 MB.

In general, each trigger event occurs intermittently. In this case, each file
contains one trigger event in the file, and the pretrigger and posttrigger areas
have the specified size.
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If a trigger event occurs while the pretrigger area is filled with data, the
pretrigger area becomes smaller than the specified size. However, the
posttrigger area keeps the specified size. In this case, the size of the File
A is smaller than the specified size.

If the second trigger event occurs while the posttrigger area is filled with data,
the second trigger event is ignored.

NOTE. If the trigger position is set to 0 (%), each file is created whenever a
trigger event occurs.

Performing Continuous Recording
Use the following procedure to perform Continuous Recording:

1. Select File > Save... to open the Save dialog box.

2. In the dialog box, select the folder where stream files are to be saved.

3. Select Record > Target... to open the Target dialog box.
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4. In the dialog box, select the Continuous Recording check box.

5. To the right of the check box, set the number of files to be continuously
recorded. After the specified number of files are created, stream capture stops
automatically.

6. In the Record Size field, set the file size to be recorded.

7. In the Trigger Position field, set the trigger position.

8. If you want to start recording by a trigger signal on the External Trigger
connector:

a. Select Record > Other to open the Others dialog box.

b. Select Rise or Fall in the Ext Record Start field.

9. Select the Record button to start continuous recording.

While Continuous Recording is running, the total number of captured files are
displayed in the file counter on the record status indicator.

When the specified number of files are created or you press the front-panel STOP
button, stream capture stops.
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After the stream capture stops, recording of the captured streams starts. The
file counter value decreases every time recording of each file is complete. The
recording starts from the last captured file. If you press the STOP button while
the captured streams are recording, the recording process terminates to the file
currently being recorded.

NOTE. The error message Drive Full appears when there is no space to record a
captured file with the specified file size on the hard disk.

Remote Commands
The MPEG Player can be controlled remotely through the 100/10 BASE-T port
on the MTS400 Series rear panel.

The set of remote commands is described in the MTS400 Series Programmer
Manual (077-0206-xx). This is supplied as a PDF file on the MTS400
documentation (063-4197-xx) CD-ROM.

Refer to the MTS400 Series Quick Start User Started Manual (071-2607-xx)
for information about how to set up the MTS400 Series for remote operation of
the MPEG Player.
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Make Seamless Wizard
This wizard guides you through the process of creating an MPEG-2 file for use
by Stream Player in continuously looped operation.

The wizard is largely self-explanatory. The notes in this section of the manual
provide a slightly more detailed explanation of the wizard and the necessary
user responses.

Starting the Wizard
To start the wizard, select the Make Seamless option from the Start menu.
Alternatively, double-click on the Make Seamless shortcut on the desktop.

The opening window is displayed:

This first page gives a short explanation of the wizard’s activities and offers the
opportunity to skip the page in the future.

Select Next to move to the next screen and specify the input file.
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Progress and Information
Log

The Progress and Information log displays messages during the operation of the
wizard. Three types of message can be displayed:

INFO General processing information.
WARNING Messages which may mean that the output

stream will contain errors.
ERROR Messages indicating catastrophic information

which will cause the wizard to disable the
Next button and prevent further progress.

An icon is displayed in the top right corner of the window and as a prefix to any
messages displayed in the Progress & Information log. The icons are used to
indicate the current processing phase of the Make Seamless Wizard:

Program

Analysis

Multiplex

4–2 MTS400 Series Generator Applications User Manual



Make Seamless Wizard

Selecting an Input File
The first action is to identify the input or source transport stream.

Enter the filename in the File: field. The browse button (…) can be used to open a
standard Windows Open dialog box and locate files.

NOTE. Only the filename will be shown, but by resting the cursor over the
filename, the full path is shown for a short time in a tooltip.

SI Scripts Customized SI scripts are available to the Make Seamless Wizard to enable
custom SI table and descriptor data to be processed successfully. Basic processing
of the Standards does not require additional scripts.
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If a suitably configured script is selected and enabled before a stream is analyzed,
custom data will be analyzed when the stream is opened. If the script is not
selected or enabled, the stream will not fail to be analyzed, but any custom data
will either be ignored or reported as an error in the stream configuration.

(The underlying principles of scripting are described in the Custom SI Scripting
section of this user manual.)

Handling Script Files. To handle SI Scripts, select the general Standard required
by enabling the appropriate radio button and select the Scripts button.

The Script dialog box displays the scripts currently associated with each standard
and allows them to be added, removed, viewed, and manipulated.
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There is, in effect, one Script File list associated with each mode; script files can
be listed in one or more Script file lists. Script files are designated as MPEG, DVB
or ATSC when they are added to the Script File list. Each mode will display only
those script files associated with that mode. Further script files can be added as
required using the Add New button.

Note that a script file will not be used for analysis until:

It is added to the Script File list in the appropriate mode.

It is enabled (displays a check mark in the Script File list).

Adding a Script File.

1. In the Script dialog box, select the Mode to which the script is to be added; for
example, DVB.

2. Select the Add New button. A standard Windows file selection dialog box is
opened. The default file extension is .scp. Select the required file.

Note that the selected script file is now listed in the script file list and is enabled; it
will be used for any analysis.

Enabling a Script File. Select the check mark adjacent to the required script file
to enable the file for analysis.

Moving a Script File. Script files are applied to analysis in the order that they are
listed; in some circumstances this may be important. To move a file in a list,
highlight the file name and select the Move Up or Move Down button as required.
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Each press of the button will move the file up or down one place in the list until it
reaches the top or the bottom.

Viewing a Script File. Script files can be viewed and edited in a text editor
(provided that the scp extension has been associated correctly in Windows
Explorer). To edit a script, highlight the script name and select View. This will
open the script in Notepad or its equivalent. The required edits can then be made
and the script saved.

When the filename is satisfactory and any scripting actions have been performed,
select Next to analyze the file. Progress is indicated by the progress bar and the
appearance of messages in the Progress & Information log.

Select a Program to Make Seamless
During the input file’s analysis the selected transport stream is analyzed to
determine it’s program content. If analysis is unsuccessful in determining
program content, the stream will not be opened and an appropriate message will
be displayed in the Progress & Information log.

Each program found is displayed in the drop-down list ( Program: ) accompanied
by an indication of the number of program elements (video, audio, etc.).

At this stage a priority program must be selected in order for it to be analyzed and
tested for suitability for the "make seamless" treatment.

Program: Highlight the required program from the drop-down list.

4–6 MTS400 Series Generator Applications User Manual



Make Seamless Wizard

Start packet: This value determines from where the primary program is to be
analyzed. Indicates the offset from the original transport stream start point to start
looking for a loop start point.

Number of Packets: Initially, this value is set to the total number of packets in
the transport stream. It indicates the maximum number of packets (up to the end
of the stream) from the Start packet point that may be included in the loop.

Make remaining programs seamless: If enabled, the remaining programs are
made seamless but are constrained by limits defined by the priority program. This
may lead to these remaining programs having a gap at the beginning and end of
the file.

Make PSI/SI/PSIP seamless: The service information contained in the transport
stream is processed to make it seamless.

If this check box is not enabled, the SI is not processed but simply copied to the
output transport stream.
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Select Next. Once again the progress bar will indicate progress. While the stream
is being analyzed, selecting the Abort button will stop the process and allow the
program to be reselected (Note that the Abort button, which replaces the Cancel
button, is only displayed during processing).

When the file has been analyzed, a number of messages will have been posted in
the Progress & Information log.
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Selecting a Multiplex Output File
When a file has been analyzed and found suitable for making seamless, an output
file must be named.

A new filename can be typed or an existing file selected using the Browse button
(…), in which case confirmation of the replacement will be required. Select Next
to create the multiplexed output file.

The screen shown below is displayed upon completion of the process.
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The output file will contain a program which when played out and looped with
the Continuous Time Stamping option enabled will demonstrate minimal picture
disturbances at the loop point.
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Transport Stream Cutter
The Transport Stream Cutter is a wizard that creates a new file from a slice of an
existing file. It is run from the Windows desktop. There are four pages including
the optional introduction page:
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Starting the Wizard
The wizard may be started by selecting the Tektronix TS Cutter option from the
Tektronix Utilities submenu of the Start > Programs menu.

Alternatively, double-click on the Tektronix TS Cutter shortcut on the desktop.

Cutting a File
By default the wizard will display this Introduction first.

The introductory page can be disabled by checking the Skip this page on startup
option. Select the Next button to move on to Step 1. (See page 5-4.)
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Step 1. Specify the name and location of the source file to copy a slice from:

Select the Browse... button to open a standard file browser window to look for
and choose the required file. Then select the Next button to move on to Step
2. (See page 5-4.)

Step 2. The slice is specified by typing in the first packet and the number of
packets to copy. The total number of packets in the file is also shown.

Selecting the Back button will return to Step 1 (See page 5-4.) so that the source
file name and location may be changed.
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Step 3. Specify the name and location for the new file.

Select Finish to create the file and copy the required slice of data. Select Back to
go back to change the source file, starting packet and number of packets.

The wizard now creates the new file and copies the selected data to the destination
file specified. While it is working, this dialog box is displayed to indicate progress.
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When the blue progress indicator reaches the right side the dialog box disappears
and the file is ready to use.
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Script Pad - Getting Started
ScriptPad is supplied with a number of Tektronix products to enable users to
create and modify System Information (SI) scripts.

The rationale underlying SI Scripting is described elsewhere in this document;
this section simply provides a guide to using ScriptPad.

It should be noted that script files are saved as ASCII files and that any ASCII text
editor can be used to view and modify the files (for example, Microsoft Notepad).
However, features such as color-coding of keywords and syntax checking will not
be available; also access to encrypted script files will not be possible.

Setting Up
The ScriptPad utility is installed automatically when the system is set up. There
is no additional specific set up procedure. Simple user interface management
is performed from within the utility.

Starting the Program
ScriptPad is most often started by double-clicking an existing script file. The
necessary file associations (*.scp and *.scx) are made automatically during the
installation process.

Alternatively, you can start ScriptPad by clicking a shortcut placed on the desktop
or by selecting ScriptPad in the Start menu in the taskbar.
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Initial Appearance
When the program has started and is ready for use, the main window is displayed,
as shown below:

The Toolbar (row of buttons above the dark gray area of the empty window) may
be hidden from view, moved to a separate window, either side or the bottom of
the main window.

The Status Line at the very bottom of the window may be hidden from view.

The dark gray area constitutes the Working Area.

Initial Menu Options
File Menu Options The following table lists the initial File menu options.

Table 6-1: File options
Option Function
New Opens a new file.
Open … Opens a script file (*.scp) for analysis.

Choose the required file.
Print Setup … Select which printer and associated options

to use.
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Table 6-1: File options (cont.)

Option Function
1 <filename>
2 <filename>
3 <filename>
4 <filename>

A list of the four most recently analyzed files.
If the program has recently been installed;
the list may be empty or hold less than four
files.
Selecting a filename opens that file for
analysis.

Exit Closes the program.

View Menu Options The following table lists the initial View menu options.

Table 6-2: View menu options
Option Function
Toolbar Shows or hides the toolbar.
Status Bar Shows or hides the status bar.

Select an option to change its status.

Script File Appearance
Scripts displayed in Script Pad are color-coded to aid understanding.

Script Pad makes no formatting corrections or changes; it is recommended that
script authors use conventional programming layout.

Single line comments are prefixed with a double slash (//); in ScriptPad they
are colored green. Multi-line comments of the form /*...*/ are also accepted by
the parser.

Opening a File
Any script file (*.scp or *.scx) can be opened for viewing and editing by this
program.

To open a file, select the Open... option from the file menu. If the required file is
in the list of recently analyzed files, then it can be opened from the list.
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Alternatively, use the Ctrl+O keyboard shortcut.

There is also a shortcut button available on the Toolbar for opening a file, which
has the standard file open symbol.

On opening, the script file is displayed in the working area.
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Viewing and editing can start immediately. Note that multiple script files can be
open simultaneously.
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Menu and Controls
The following pages contain descriptions of the menu options, toolbar controls,
and status bar.

Menu Bar
Different menus and options are presented before and after file opening and
depending upon whether the file window or the message window is active.

The Menu Bar offers all of the options available currently. Options are context
sensitive; they will only be available where relevant. Some options are also
available through keyboard shortcuts; these are indicated on the menus.

A check mark next to an option indicates that the function is currently visible or
active; no check mark means that it is hidden or inactive.

File Menu Options The following table lists the File menu options.

Table 6-3: File menu options
Option Function
New Opens a new file.
Open … Opens a script file (*.scp) for analysis. The

program opens the file selection dialog box
allowing the user to choose the required file.

Close Closes the active script file window.
Save Saves the active script file window.
Save As … Allows the active script file to be saved under

a different file name.
Encrypt When enabled, scripts will be saved in

encrypted format (*.scx) and unencrypted
format (*.scp).

Print … Opens Print dialog.
Print Preview Previews print using current print settings.
Print Setup … Opens a dialog for selecting which printer

and associated options to use.
1 <filename>
2 <filename>
3 <filename>
4 <filename>

A list of the four most recently analyzed files.
If the program has recently been installed the
list may be empty or hold less than 4 files.
Selecting a filename opens that file for
analysis.

Exit Exits the program. The user is given the
opportunity to save any changed script files.

6–6 MTS400 Series Generator Applications User Manual



Menu and Controls

Edit Menu Options The following table lists the Edit menu options.

Table 6-4: Edit menu options
Option Function
Cut Delete the currently highlighted text and

move it to the clipboard.
Copy Copy the currently highlighted text to the

clipboard.
Paste Paste the contents of the clipboard to the

current cursor location.
Find … Finds and highlights the text string entered in

the Find dialog.
Replace … Finds and replaces the text string entered

in the Replace dialog.
Go To … Places the cursor at the specified line

number.

View Menu Options The following table lists the View menu options.

Table 6-5: View menu options
Option Function
Toolbar Shows or hides the Toolbar.
Status Bar Shows or hides the Status Bar.
Auto Syntax Highlights When enabled, automatically color-codes

keywords in the active file as they are typed
during editing.

Refresh Syntax Colors Refreshes color coding of keywords in the
active file.

Window Menu Options The following table lists the Window menu options.

Table 6-6: Window menu options
Option Function
New Window Opens a new empty window.
Cascade Cascades all open windows in the

application.
Tile Tiles all open windows in the application.
Arrange Icons Aligns icons of any minimized windows at the

bottom of the program’s main window.
1 <window title> List the currently open windows. The

active (visible) window is indicated by the
checkmark.
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Script Menu Options The following table lists the Script menu options.

Table 6-7: Script menu options
Option Function
Parse Parses the script file to check for syntax

errors.
Script Message Log Opens the parser message window.

Help Menu Options The following table lists the Help menu options.

Table 6-8: Help menu options
Option Function
About ScriptPad … Opens the About dialog which displays the

program version number.

Toolbar

The Toolbar provides a set of convenient shortcuts for the more frequently used
menu options. The available commands are:

Open a new file.

Allows an existing
script file to be
selected and
opened.
Saves the active
script file.
Finds specified text.

Allows the currently
selected text to be
cut. It can then be
pasted to another
location.
Allows the currently
selected text to be
copied. It can then
be posted to another
location.
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Allows text currently
held on the clipboard
(having been
previously cut
or copied from
elsewhere) to be
pasted to the cursor
location.
Allows the active
script to be printed.
Opens the About
ScriptPad dialog.
Parses the currently
active script for
syntax errors.
Toggles the display
of the Script Parser
Messages window.
Allows the
color-coded
highlights in the
active script to be
refreshed.
Enables encryption.
Scripts saved while
this function is
enabled will be saved
in encrypted format
(*.scx) and encrypted
format (*.scp).

The Toolbar can be dragged off the edge of the main window into a floating pallet.
To do this click on the background inside the Toolbar, that is, not on one of
the buttons, and drag into the main window area. The result is a self contained
window which looks like this:

To replace the Toolbar on the window border drag it over the border until the
outline changes shape. It can be placed on the top, bottom, left or right edges.

Status Bar
The Status Bar displays an information message when the cursor is placed over
any toolbar button or menu option.
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Script File Editing and Encryption
Because script files are saved as ASCII files, editing follows normal text editing
customs. However, ScriptPad does provide extra features to enhance and verify
the process.

Keyword Color-Coding
When the Auto Syntax Highlights option in the View menu is enabled, keywords
are automatically color-coded as they are typed.

When the Auto Syntax Highlights option is disabled, the color-coding can be
refreshed by selecting the Refresh Syntax Colors option in the View menu.

Parsing
Script files can be syntactically checked by selecting the Parse option from the
Script menu. A message box will indicate that errors were or were not found in
the file. The Script Parser Message window will be automatically opened when
the message is acknowledged.

Script Parser Message
Window

The Script Parser Messages window logs the parsing activities and provides errors
and warnings when necessary.

The following icons are used in the message window.

Information

Error

Warning

Double-clicking and error message will bring the associated script file window to
the front of the display.

Messages can be cleared from the window by right-clicking anywhere within the
message window and selecting Clear messages.
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Encryption
There are an increasing number of proprietary standards emerging whereby
analysis is allowable (possibly subject to a licence fee), but the owner of the
standard does not want the script file to be viewed by users. This is solved by
using encrypted script files. The ScriptPad utility, which is used for creating and
editing script files has an Encrypt option, such that a script file is saved in an
unreadable encrypted format, that only the ScriptParser can interpret. ScriptPad
is associated with the .scp and .scx suffixes used for unencrypted and encrypted
scripts respectively during the installation process.

The script encryption process employs a robust, 128 bit symmetric-key algorithm
based on the Feistel block cipher, which is similar to that used in the dongle
encryption scheme. Additional functions have been included to increase the
entropy of the cipher text.

Each time a script is encrypted, a unique file is generated. This makes it hard to
determine the algorithm by making small changes to plain-text and then observing
the change made to the cipher-text. In addition the cipher-text is protected from
interference, meaning that changes to the cipher text are detected on decryption
and the altered file will be rejected.

NOTE. A dongle is a security or copy protection device that must be connected
to an I/O port of the computer while the program is run. Programs that use a
dongle may query the port at start-up and at programmed intervals thereafter, and
terminate if it does not respond with the expected validation code.
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A
Adaptation field control, 2-20
Adaptation Field Error (ADFERR)

icon, 3-18
Adaptation field length, 2-20
Adding jitter to PCRs (MTG300

only), 3-69
Amplitude, 3-20
Audio Elementary Stream

(AUDIO) icon, 3-17

B
Base value, 3-29
BAT icon, 3-12
BNC port, 3-37
Burst mode, 3-45
Burst period, 3-45
Burst size, 3-45

C
Carousel Analyzer, ix
CAT icon, 3-9
CETT icon, 3-19
Checksum error, 3-47
Column repositioning, 1-72
Column sort, 1-72
Compressed string, 1-103
Contents of the preset file, 3-71
Copy Packet, 2-12
CVCT icon, 3-19

D
Delete settings, 3-44
Dialog boxes

PCR Inaccuracy, 3-70
Display elements, 3-2
DIT icon, 3-12
DLT icon, 3-14
DSM_CC icon, 3-18
Duration control, 1-69
Dvalid enable, 3-28

E
EETT icon, 3-19
EIT icon, 3-12
Elementary Stream Analyzer, ix
Entitlement Control Message

(ECM) icon, 3-18
Entitlement Management Message

(EMM ) icon, 3-18
Enumerated value, 1-101
Expert mode, 1-54
Export elementary stream, 1-73
Export section data, 1-73
Extension value, 3-29

F
Fixed ES rate, 3-26

G
GARBAGE icon, 3-18
Gaussian jitter distribution, 3-46
Generate sequence error, 3-48
Generate UDP checksum

error, 3-48
GHOST icon, 3-18

H
Header editor, 2-1

I
Import section data, 1-73
Interface

Option 7, 3-68
Interpretation, 1-6
IP data rate, 3-26
ISDB, 1-9
ISDB-T icon, 3-9
ISDB-T IFFT clock, 3-25

L
Laplacian jitter distribution, 3-46

LDT icon, 3-14
Loading a preset file, 3-71
Lower jitter mode, 3-46

M
M-TMCC icon, 3-9
Max amplitude, 2-35
Menus

Utility, 3-58, 3-66
MGT icon, 3-15
MPEG-2 only, 1-8

N
NBIT icon, 3-14
NIT icon, 3-9
Non-TS icon, 3-9

O
Other settings, 3-38

P
Packet size indicator, 3-6
Packetized Elementary Stream

(PES) Analyzer, ix
Parametric settings, 3-45
PAT icon, 3-9
Pattern, 3-19
PCR icon, 3-9
PCR Inaccuracy dialog box, 3-70
PCR placement, 1-93
PCR recalculation, 2-13
PCR tab, 1-41
PID number, 1-83
PID source, 1-89
PMT icon, 3-9
Position indicator, 3-3
Program Clock Reference (PCR)

iIcon, 3-17
Program view manipulation, 1-27
Psync enable, 3-28
Pulse width, 3-20
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R
Reed solomon, 2-1
Remap PIDs, 2-13
RST icon, 3-12

S
S-TMCC icon, 3-9
Safety Summary, vii
Saving a preset file, 3-71
Scaling bar, 1-68
SDT icon, 3-12
Section timing, 1-86
Set up the NIT, 1-32
Source tab, 1-38
ST icon, 3-12
Standard, 3-33
Standard interpretation, 1-23

Standard mode, 1-54
Store settings, 3-44
Stream timing, 1-92
Subtable timing, 1-85
System time, 3-34

T
TDT icon, 3-12
Timing tab, 1-40
TOT icon, 3-12
Transmission mode, 3-40
Transport Stream (TS) icon, 3-9
Transport Stream Compliance

Analyzer (TSCA), ix
Transport structure

demultiplex, 1-16

Transport structure
modifications, 1-16

TSDT icon, 3-9
TTS settings, 3-38
TTS utility, x
TVCT icon, 3-19

U
Update method, 3-36
Utility menu, 3-58, 3-66

V
Version timing, 1-84
Video Elementary Stream

(VIDEO) icon, 3-17
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